Page 1 of 1

Recently recorded tracks not lining up in Logic X

Posted: Wed May 01, 2019 1:33 am
by iamashriver
Hi all,

I am a Logic X user collaborating with a buddy who is a Live 10 user (but he is very green). We have had some hiccups but nothing like this one. We have a project where he has put down 5 vocals. Everything he tracked before the other night I am able to export and drop in Logic with no issues. Then I get his files from the other night. Same project. Even new parts he put on a couple of the tracks that do line up do not line up audibly. Looking at the waves, they look like they should line up in Logic but don't. Each one seems to lag/start late/not be on the same beat. Sounds fine when played in Live but will not line up in logic. It's almost like post export those new audio parts have a different tempo happening.

HELP! This is driving me mad. I'm wondering if he did something via Warp (which I know nothing about. ha.) What can I do to salvage his parts and tell him what to not do next time he tracks.

Thanks so much!
Andrew

Re: Recently recorded tracks not lining up in Logic X

Posted: Wed May 01, 2019 1:45 am
by [jur]
He probably warped some of the files.

Re: Recently recorded tracks not lining up in Logic X

Posted: Wed May 01, 2019 2:32 am
by iamashriver
Can I unwarp it?

Re: Recently recorded tracks not lining up in Logic X

Posted: Wed May 01, 2019 2:33 am
by iamashriver
And what do I tell him to do next session to not track with warp on? It affected every audio file he tracked the other night.

THANKS!
Andrew

Re: Recently recorded tracks not lining up in Logic X

Posted: Wed May 01, 2019 5:55 pm
by iamashriver
Anyone have suggestions? I did some researching last night and will try a couple things but..

1. Can I unwarp the audio files he warped while recording?
2. What did he 'turn on' to have this happen in the first place?
3. Can I turn off warp during the export?

I'm pretty sure the audio files that do line up fine have the warp button on in the sample editor pane and I tried turning the warp button off on the 'bad' parts and exporting/importing with the same result in Logic. I'll double check my setup and his but pretty sure on my end I have 'use warp on long samples' off in the prefs.

Thanks in advance.
Andrew

Re: Recently recorded tracks not lining up in Logic X

Posted: Thu May 02, 2019 6:35 pm
by TLW
There’s no instant solution to the timing issue. Logic has the ability to alter the timing of audio. It’s called “flextime” and instructions for using it are in the Logic manual under the heading “Edit the timing of audio”. It works quite well, though it can be a slow and fiddly process. Like any timing or pitch shifting algorithm it’s best used to fix minor problems than make huge changes to tempo.

What might work is if your collaborator loads his/her version of the project back into Live, switches off the warp function for all clips in arrangement view then exports them again. Success is not certain, but it might work well enough. Setting Live’s preferences to not automatically warp long recordings is probably a good idea while he’s at it.

Minor timing/bpm differences between DAWs are pretty common, because they’re not sharing a master clock so any small drifts which occur in the bpm on one computer won’t be reproduced on the other. Come to that musician’s - including me - rarely hold an absolutely regular, spot-on bpm either even when using a click or drum track to play against.

Re: Recently recorded tracks not lining up in Logic X

Posted: Fri May 03, 2019 1:18 pm
by iamashriver
Thanks for the reply. I will have him try this. This is definitely not Logic altering something as the previously recorded tracks have all imported just fine. I'm about to create a fresh Live project for him and have him redo what is messed up from the other night.

Thanks again!
Andrew