At My Wits End

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
AlzoXP
Posts: 1
Joined: Mon Jun 03, 2019 3:13 pm

At My Wits End

Post by AlzoXP » Mon Jun 03, 2019 3:24 pm

I really need help from you guys
I have iMac running the latest version of MacOS
I bought last week Ableton Push 2 and Ableton Live Standard - all updated to the latest and was working fine (finding my feet with it)
Upgraded from irig Keys I/O to the Komplete S49 Mk2 and Komplete Ultimate - everything updated to latest including firmware.

I have also followed the following tutorial to configure my controller - https://support.native-instruments.com/ ... /209557689

Where I am getting massive frustration is the auto arming of tracks - I do not want it.

If I only have my Push 2 turned on with Ableton Live the tracks don't auto arm
When i have the Push 2 and the Komplete Kontrol 49 Turned on the tracks Auto Arm and I cannot stop it.
Only connecting Komplete Kontrol 49 still Auto Arms the tracks

I have deployed the Options.TXT file with the NoAutoArming command it does nothing when the keyboard is connected

I have tried every combination of midi control settings, turning ones off turning others on (some of them disable the keyboard entirely). I have also turn on and off Exclusive for Arm and Solo still no joy

I am at my wits end I cannot figure out how to stop it from doing that and I really want to be able to use both the Push 2 and the Komplete Kontrol without the Auto Arming when im jamming ideas out.

Can anyone help me please? :(

Thanks

Alzo

jestermgee
Posts: 3211
Joined: Mon Apr 26, 2010 6:38 am
Contact:

Re: At My Wits End

Post by jestermgee » Mon Jun 03, 2019 10:15 pm

That's a Komplete Kontrol thing, it needs to auto arm the track so it can play it. Push also does this but Ableton designed a "pseudo arm" where it semi-arms the track for playing it with a controller but does not record when in session record mode. Komplete Kontrol will just arm a track.

However, unless you press the session or arrangement record buttons nothing will be recorded and you can still jam along, in fact without the track armed or set to always monitor, you cannot play the track.

What is the reason for not wanting the track armed?

Dallon426
Posts: 37
Joined: Tue Jul 03, 2018 2:08 pm

Re: At My Wits End

Post by Dallon426 » Mon Jun 03, 2019 10:17 pm

You need to use the options.txt and disable autoarm

https://sonicbloom.net/en/10-hidden-fea ... tions-txt/


Also turn off arm in the preferences

jestermgee
Posts: 3211
Joined: Mon Apr 26, 2010 6:38 am
Contact:

Re: At My Wits End

Post by jestermgee » Mon Jun 03, 2019 10:25 pm

Dallon426 wrote:
Mon Jun 03, 2019 10:17 pm
You need to use the options.txt and disable autoarm

https://sonicbloom.net/en/10-hidden-fea ... tions-txt/


Also turn off arm in the preferences
Have you tried this yourself?

There is no "turn off arm" in prefs, only to disable exclusive arm which then allows multiple tracks to arm without pressing CTRL. The options.txt functions will not work if a controller is sending Live a message to arm the track and I can confirm this with a test that it does not stop the track from arming.

Dallon426
Posts: 37
Joined: Tue Jul 03, 2018 2:08 pm

Re: At My Wits End

Post by Dallon426 » Tue Jun 04, 2019 7:59 am

I do not have a push 2 so no I have not tried it. I was just giving you an option.
You can make a video and upload it to youtube and see if you get any responses there as well.

Send a link to this thread and maybe someone can help you.

I personally prefer auto arm. It is silly to me that Ableton does not have a hot key that will allow us to globally turn on auto arm on and off.
In cubase this is called monitoring and there are many options such as record on selected track, monitor on selected track etc.
The main frustrating thing with ableton is the lack of options for each individual user. Basically every option should be able to be customized.

Post Reply