To all those with the Alesis Nitro MIDI record issue - it's a 10.1 bug (or outdated Alesis firmware) - Workaround

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
roho1
Posts: 2
Joined: Tue Sep 13, 2011 8:34 pm

To all those with the Alesis Nitro MIDI record issue - it's a 10.1 bug (or outdated Alesis firmware) - Workaround

Post by roho1 » Sat Jun 22, 2019 4:05 pm

When I saw posts about this issue on Reddit over the past few weeks, I thought it must be a midi setting or something causing your errors. I finally got around to testing myself, and this appears to be an issue with Live 10.1.

MIDI records fine from the Nitro in 10.0.6, but in 10.1 with the same settings the MIDI does not record. MIDI is being received and processed by live, but will not record in either session or arrangement view. I've only tested this on OSX High Sierra, but haven't tried it out on windows yet. This was using the USB MIDI from the Nitro - routing the MIDI out of the Nitro with a MIDI cable into my audio interface works fine (make sure you have the USB disconnected, however) - in addition, my USB MIDI keyboards all record fine.

The kit is my roommates, and Alesis has very convoluted help on their website - I was trying to see if maybe there was a firmware update, but couldn't find any info or download, or even a way in the manual to check firmware on the unit - the kit appears to be the 8-piece mesh Nitro, but says D7X on the back of the module, which seems to relate to an older version, however it is black.

Anyway, I don't really have much patience for this, so thank god for the good 'ol MIDI cable, which appears to be the only workaround to use the kit on 10.1. I'll be sending this in to Ableton support, but I imagine it's some sort of USB MIDI driver thing with the Nitro's USB MIDI not working with some part of the 10.1 update. If I were a betting man, I'd say it has something to do with the Nitro's USB MIDI driver being outdated.

Oh well, hope this workaround helps those experiencing the issue, and I implore you all to badger Ableton and Alesis support until someone figures it out. If anyone has any other insights please share in the comments.

Best, -R

NaiaIzu
Posts: 1
Joined: Tue Sep 24, 2019 2:43 am

Re: To all those with the Alesis Nitro MIDI record issue - it's a 10.1 bug (or outdated Alesis firmware) - Workaround

Post by NaiaIzu » Tue Sep 24, 2019 2:47 am

I have the same problem with the update with or without a midi cable using my Carlsboro Ekit . I reported it months ago glad to see I'm not alone at least. I had to downgrade back

[jur]
Site Admin
Posts: 1705
Joined: Mon Jun 01, 2015 3:04 pm
Location: Ableton

Re: To all those with the Alesis Nitro MIDI record issue - it's a 10.1 bug (or outdated Alesis firmware) - Workaround

Post by [jur] » Tue Sep 24, 2019 4:35 am

roho1 wrote:
Sat Jun 22, 2019 4:05 pm
When I saw posts about this issue on Reddit over the past few weeks, I thought it must be a midi setting or something causing your errors. I finally got around to testing myself, and this appears to be an issue with Live 10.1.

MIDI records fine from the Nitro in 10.0.6, but in 10.1 with the same settings the MIDI does not record. MIDI is being received and processed by live, but will not record in either session or arrangement view. I've only tested this on OSX High Sierra, but haven't tried it out on windows yet. This was using the USB MIDI from the Nitro - routing the MIDI out of the Nitro with a MIDI cable into my audio interface works fine (make sure you have the USB disconnected, however) - in addition, my USB MIDI keyboards all record fine.

The kit is my roommates, and Alesis has very convoluted help on their website - I was trying to see if maybe there was a firmware update, but couldn't find any info or download, or even a way in the manual to check firmware on the unit - the kit appears to be the 8-piece mesh Nitro, but says D7X on the back of the module, which seems to relate to an older version, however it is black.

Anyway, I don't really have much patience for this, so thank god for the good 'ol MIDI cable, which appears to be the only workaround to use the kit on 10.1. I'll be sending this in to Ableton support, but I imagine it's some sort of USB MIDI driver thing with the Nitro's USB MIDI not working with some part of the 10.1 update. If I were a betting man, I'd say it has something to do with the Nitro's USB MIDI driver being outdated.

Oh well, hope this workaround helps those experiencing the issue, and I implore you all to badger Ableton and Alesis support until someone figures it out. If anyone has any other insights please share in the comments.

Best, -R
Did you report to support@ableton.com?
Ableton Forum Moderator

garyboozy
Posts: 2586
Joined: Mon Jul 16, 2007 12:27 pm
Location: UK
Contact:

Re: To all those with the Alesis Nitro MIDI record issue - it's a 10.1 bug (or outdated Alesis firmware) - Workaround

Post by garyboozy » Tue Sep 24, 2019 5:22 pm

10.1.2b8 fixes this apparently
Bugfixes:
• Fixed a bug where very short notes arriving from external MIDI controllers were not always recorded.

DaddyDough
Posts: 1
Joined: Wed Sep 25, 2019 11:30 pm

Re: To all those with the Alesis Nitro MIDI record issue - it's a 10.1 bug (or outdated Alesis firmware) - Workaround

Post by DaddyDough » Wed Sep 25, 2019 11:31 pm

garyboozy wrote:
Tue Sep 24, 2019 5:22 pm
10.1.2b8 fixes this apparently
Bugfixes:
• Fixed a bug where very short notes arriving from external MIDI controllers were not always recorded.
And when can we get our hands on that fix?

[jur]
Site Admin
Posts: 1705
Joined: Mon Jun 01, 2015 3:04 pm
Location: Ableton

Re: To all those with the Alesis Nitro MIDI record issue - it's a 10.1 bug (or outdated Alesis firmware) - Workaround

Post by [jur] » Thu Sep 26, 2019 1:46 am

DaddyDough wrote:
Wed Sep 25, 2019 11:31 pm
garyboozy wrote:
Tue Sep 24, 2019 5:22 pm
10.1.2b8 fixes this apparently
Bugfixes:
• Fixed a bug where very short notes arriving from external MIDI controllers were not always recorded.
And when can we get our hands on that fix?
You can join the beta program or wait for the release of Live 10.1.2.
Ableton Forum Moderator

Post Reply