All my Korg Nanos no longer work with Live 10 - anyone else?

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
craftycurate
Posts: 500
Joined: Thu Sep 27, 2007 2:23 pm

All my Korg Nanos no longer work with Live 10 - anyone else?

Post by craftycurate » Thu Aug 22, 2019 4:05 pm

Hi Folks

Am trying to track down the reason for the following and wonder if others have found this:

I hadn't used many of my MIDI controllers for a few months, but this weekend I'm putting a set together. I noticed that none of my Korg Nanos (NanoKontrol 1, NanoKontrol 1, NanoPad 1) were recognised by Live 10 any more, wherease all the others (Edirol keyboard, Novation LaunchControl, Akai grid controller, M-Audio Mini keyboard) work fine.

The Korg's lights come on when plugged in via USB, and I've tried several different cables, USB ports (all of which work fine with other devices), but Live isn't seeing them.

I've tried updating Korg drivers etc but to no avail.

It seems odd that all 3 have stopped working in the last few months without any use, whereas beforehand they were uber-reliable throughout several years of gigging and live use.

Has anyone else noticed this happening? I'm trying to determine whether it's a change in Windows or Live (maybe missing controller scripts), or whether it's just a freak 1 in a million occurrence that 3 devices from the same manufacturer happen to have spontaneously combusted.

I'm on Windows 7x64, and the latest stable Live 10.1.

Cheers
Richard
Core i7 2.3GHz|Win7x64|8GB|1.5TB & Core 2 Duo T7200, XP Pro SP3,
Nio 2|4, Edirol PCR800, NanoKontrol , Komplete Synths + Reaktor 5, Cameleon, Alchemy, FabFilter 2 suite
http://www.myspace.com/richardlyallmusic http://craftycurate.blogs.com

yur2die4
Posts: 6438
Joined: Sat Oct 03, 2009 3:02 am
Location: Menasha, Wisconsin
Contact:

Re: All my Korg Nanos no longer work with Live 10 - anyone else?

Post by yur2die4 » Fri Aug 23, 2019 2:45 pm

KORG has annoying drivers.

The first thing I would do is open the Driver utility and make sure it is set to 64 bit.

But when you use the editor software it needs to be set to 32 bit.

Another possibility is their USB midi limitation. I think there is a tool to clear out Windows’ USB MIDI stuff (assuming you are using windows) which allows the Korg devices to work again.

Sorry for being vague, kinda in a rush haha. Good luck!

craftycurate
Posts: 500
Joined: Thu Sep 27, 2007 2:23 pm

Re: All my Korg Nanos no longer work with Live 10 - anyone else?

Post by craftycurate » Fri Aug 23, 2019 3:16 pm

yur2die4 wrote:
Fri Aug 23, 2019 2:45 pm
KORG has annoying drivers.

The first thing I would do is open the Driver utility and make sure it is set to 64 bit.

But when you use the editor software it needs to be set to 32 bit.

Another possibility is their USB midi limitation. I think there is a tool to clear out Windows’ USB MIDI stuff (assuming you are using windows) which allows the Korg devices to work again.

Sorry for being vague, kinda in a rush haha. Good luck!
Thanks I'll give that a spin!
Core i7 2.3GHz|Win7x64|8GB|1.5TB & Core 2 Duo T7200, XP Pro SP3,
Nio 2|4, Edirol PCR800, NanoKontrol , Komplete Synths + Reaktor 5, Cameleon, Alchemy, FabFilter 2 suite
http://www.myspace.com/richardlyallmusic http://craftycurate.blogs.com

maestrovoltaire
Posts: 1
Joined: Sun Dec 01, 2019 10:38 pm

Re: All my Korg Nanos no longer work with Live 10 - anyone else?

Post by maestrovoltaire » Sun Dec 01, 2019 11:30 pm

A follow up note here for the next traveler who would otherwise have to spend 2 hours debugging, (re)installing drivers, and experimenting with various configurations.
  1. The KORG MIDI Driver installer installs a secondary program nestled under the Windows > Korg start menu called "KORG MIDI Driver Setup Utility". Opening this and hitting 'Install' seems logical and says installation is a success, but I have yet to verify what this actually entails.

    2. If MIDI-OX and/or Ableton still do not recognize the nanoKontrol2 (as was so in my case), some registry editing may be necessary. At 'HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\Drivers32' (due caution in regedit emphasized), I changed `midi1` and `mixer1` from the default `wdmaud.drv` to KORG's `KORGUM64.DRV`. Be careful not to end up in the WOW6432Node\...\Drivers32 registry directory, as edits in this area seem to work in MIDI-OX, but not Ableton.

    3. As per the nanoKontrol2 manual, holding the SET and STOP during device boot will put it into Ableton-compatible mode. Note that putting it in Ableton mode or generic MIDI CC mode made no difference for me without the registry edits. It simply did not appear in Ableton.
Note as well that M-Audio has a `MidiFixUtil` executable that supposedly resets registry MIDI configuration. I did in fact run this during a period of frustration so may have some other drivers to reinstall, but as it stands the nanoKontrol2 is recognized and fully operable in Ableton 10.1.5.

This thread did not show up in Google, but there are some dated YouTube videos attempting to address the issue.

Hope this helps. Any addendums welcome.

craftycurate
Posts: 500
Joined: Thu Sep 27, 2007 2:23 pm

Re: All my Korg Nanos no longer work with Live 10 - anyone else?

Post by craftycurate » Mon Dec 02, 2019 1:10 am

maestrovoltaire wrote:
Sun Dec 01, 2019 11:30 pm
A follow up note here for the next traveler who would otherwise have to spend 2 hours debugging, (re)installing drivers, and experimenting with various configurations.

...
Thanks for posting. I managed to get them back up and running by uninstalling the driver (I had previously installed the latest driver over the old one, which didn't work), and reinstalling the latest version.
Core i7 2.3GHz|Win7x64|8GB|1.5TB & Core 2 Duo T7200, XP Pro SP3,
Nio 2|4, Edirol PCR800, NanoKontrol , Komplete Synths + Reaktor 5, Cameleon, Alchemy, FabFilter 2 suite
http://www.myspace.com/richardlyallmusic http://craftycurate.blogs.com

Post Reply