10.1.4 crashing on High Sierra and displaying "The VST2 plug-in is damaged and can't be opened"

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
oratowsky
Posts: 109
Joined: Wed Apr 11, 2007 12:09 am
Location: la

10.1.4 crashing on High Sierra and displaying "The VST2 plug-in is damaged and can't be opened"

Post by oratowsky » Wed Nov 13, 2019 8:26 pm

Hi, I submitted a support ticket with this info as well but wanted to note it here as well in case others are having similar issues. Mac specific:

I have automatic updates on and after updating to 10.1.4, I was getting the "The VST2 plug-in is damaged and can't be opened" error message on many projects.

After loading sets where that error would occur, the plugins would of course be disabled, but Live would crash on pretty much the first action after loading the Set.

Initially I thought it was an issue with the plugins that weren't loading, so I reinstalled those plugins, but it did not resolve the issue.

After seeing the "The VST2 plug-in is damaged and can't be opened" note about 10.1.4, I reverted back to 10.1.1, and everything works.

The note says that 10.1.4 fixes issues loading certain plugins on Mojave or Catalina, but for me it actually caused crashes when loading certain plugins, and I am on macOS 10.13.6 High Sierra, not Mojave or Catalina. I am using the latest versions of legitimate plugins.

Hope this is useful info if anyone is searching about this or having similar issues.

Tl;dr if 10.1.4 is crashing and displaying "The VST2 plug-in is damaged and can't be opened" error, reverting to 10.1.1 may fix it.

soundpal
Posts: 1
Joined: Fri Nov 15, 2019 2:01 am

Re: 10.1.4 crashing on High Sierra and displaying "The VST2 plug-in is damaged and can't be opened"

Post by soundpal » Fri Nov 15, 2019 2:02 am

I'm having the exact same problem.

Just gonna use the AU-version of the particular plug-in for now, but I'm really hoping it gets solved in the next update. There was no issue with this in any of the prior updates for me btw, just 10.1.4

[jur]
Site Admin
Posts: 1744
Joined: Mon Jun 01, 2015 3:04 pm
Location: Ableton

Re: 10.1.4 crashing on High Sierra and displaying "The VST2 plug-in is damaged and can't be opened"

Post by [jur] » Fri Nov 15, 2019 6:06 am

Some informations here.
Ableton Forum Moderator

oratowsky
Posts: 109
Joined: Wed Apr 11, 2007 12:09 am
Location: la

Re: 10.1.4 crashing on High Sierra and displaying "The VST2 plug-in is damaged and can't be opened"

Post by oratowsky » Tue Nov 19, 2019 9:35 pm

[jur] wrote:
Fri Nov 15, 2019 6:06 am
Some informations here.
Just want to point out that I'm having the issues this article describes BUT on High Sierra.

[jur]
Site Admin
Posts: 1744
Joined: Mon Jun 01, 2015 3:04 pm
Location: Ableton

Re: 10.1.4 crashing on High Sierra and displaying "The VST2 plug-in is damaged and can't be opened"

Post by [jur] » Tue Nov 19, 2019 10:06 pm

To anyone who get this problem, please write to support@ableton.com detailing the problematic VSTs and your system's specs.
thx
Ableton Forum Moderator

sam_saw
Posts: 1
Joined: Sat Nov 23, 2019 7:47 pm

Re: 10.1.4 crashing on High Sierra and displaying "The VST2 plug-in is damaged and can't be opened"

Post by sam_saw » Sat Nov 23, 2019 7:51 pm

Has this vst issue been addressed in the 10.1.5 update ???
Not interested in having to roll back unless this is not going to be fixed.
And why was this not seen in testing?

Post Reply