"Alchemy VST plugin damage" - but its not

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
Thom Frank
Posts: 1
Joined: Mon Dec 09, 2019 4:37 am

"Alchemy VST plugin damage" - but its not

Post by Thom Frank » Mon Dec 09, 2019 4:40 am

I have been using Alchemy in Ableton for years. Just two months ago I used in a new piece, now it won't open and says it is damaged. But it still works in Cubase. Also, just to be sure I reinstalled Alchemy (fortunately I kept and installer). So it works fine in Cubase and in Reason 10. Anyone have any ideas?
Thanks
Thom Frank

koranek
Posts: 460
Joined: Thu Apr 24, 2003 3:51 am
Location: You got to be somewhere

Re: "Alchemy VST plugin damage" - but its not

Post by koranek » Sun Jan 05, 2020 4:39 am

I just got the same problem today. I tested it by removing all the other plugins from the VST folder except Alchemy. It didn't fail the vst scan, but now it doesn't show up in the browser in Live 10.1.6 at all.

I was able to launch Live 10.1 and it displays and runs Alchemy fine.

The good news is that the AU version runs in Live 10.1.6.

The terrible news is that I have a lot of Live sets that use instances of Alchemy VST. Since they don't load, I have no idea what preset or settings were saved with each set.

For me this is really bad.
Licensed Counselor
johnkoranekcounseling.com
https://soundcloud.com/johnkoranek

Mac Pro 3.33 Ghz 6 core Xeon, 32 G ram, OS 10.12.6
Push 2
Novation Impulse
iConnectAudio 2+, iConnectMidi 4+
Live 10 Sweet

pottering
Posts: 858
Joined: Sat Dec 06, 2014 4:41 am

Re: "Alchemy VST plugin damage" - but its not

Post by pottering » Sun Jan 05, 2020 8:59 pm

The last change to how Live handles plugins in MacOS was in 10.1.4, not 10.1.6.

https://www.ableton.com/en/release-notes/live-10/

https://help.ableton.com/hc/en-us/articles/360010030639
Due to new security requirements in macOS, certain outdated or cracked plug-ins can crash Live 10.1.2 and Live 10.1.3. The crashes may occur when loading sets, scanning plug-ins or loading the affected plug-ins from the browser.

Live 10.1.4 (and later) shouldn't crash, however Live displays the error message "The VST2 plug-in is damaged and can't be opened" when trying to open affected plug-ins.

annadyne
Posts: 245
Joined: Thu May 02, 2002 5:37 pm
Location: Asheville, NC, us
Contact:

Re: "Alchemy VST plugin damage" - but its not

Post by annadyne » Tue Jan 07, 2020 1:16 am

Argh this is so bad!! I love and use Alchemy all the time - since 2009!

So the VST no longer works in latest Live?

Guess I'll have to find out ~

jestermgee
Posts: 3691
Joined: Mon Apr 26, 2010 6:38 am
Contact:

Re: "Alchemy VST plugin damage" - but its not

Post by jestermgee » Tue Jan 07, 2020 1:54 am

annadyne wrote:
Tue Jan 07, 2020 1:16 am
Argh this is so bad!! I love and use Alchemy all the time - since 2009!

So the VST no longer works in latest Live?

Guess I'll have to find out ~
No, should work as long as you use the latest version and if the dev is maintaining updates to cope faith macOS changes

Tarekith
Posts: 17452
Joined: Fri Jan 07, 2005 11:46 pm
Location: Ableton Forum Administrator
Contact:

Re: "Alchemy VST plugin damage" - but its not

Post by Tarekith » Tue Jan 07, 2020 3:39 pm

Wasn't alchemy plug in development stopped awhile ago when Apple bought Camel Audio?

annadyne
Posts: 245
Joined: Thu May 02, 2002 5:37 pm
Location: Asheville, NC, us
Contact:

Re: "Alchemy VST plugin damage" - but its not

Post by annadyne » Tue Jan 07, 2020 4:31 pm

Yes CrApple bought it and developed it a bit after one of the major sound designers involved with Camel Audio - Tim Conrardy - passed.
That was a big sad moment for the developer.
In its original day it was years ahead of its time.

Ole v1.55 VST crashes a once in a while - but not that much - so I've kept using it.
Crazy modulation and sound-design for sample mangling.
Spectral and Additive too.
No wave-table but it's still pretty amazing. Reasonable CPU for what it can do.

I've been using the v1.55 VST in - I think - the 10.1.12 or 10.1.2 version.

Great sound library too. Still available here and there for the old version.

Post Reply