Recording external audio w/ MIDI clips just a touch delayed?

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
wellsoliver
Posts: 42
Joined: Sat Dec 17, 2016 9:33 pm

Recording external audio w/ MIDI clips just a touch delayed?

Post by wellsoliver » Sat Apr 25, 2020 7:10 pm

I dunno how else to describe this, but when I have a MIDI clip locked to the start of the clip, recording an external audio clip from that is just ever so slightly delayed as to make the loop a little clipped. Here's two quick images, one of the MIDI clip then the audio clip.

Is this just the way it is w/ external audio? Is there some latency setting? Am I an idiot?

Image

Image

TLW
Posts: 807
Joined: Thu Aug 23, 2018 2:37 am

Re: Recording external audio w/ MIDI clips just a touch delayed?

Post by TLW » Sat Apr 25, 2020 11:49 pm

It’s the result of the time it takes for the MIDI to reach the synth and the synth to convert the MIDI to audio. Which, to complicate things, varies from synth to synth and sometimes patch to patch.

Live should auto-correct for the audio latency set in the audio driver preferences, but hardware synths take varying amounts of time to process MIDI. There’s also the issue of slow VCA attack envelopes which might also delay the sound output from the synth.

Live can be set in preferences to try and cope with this and the track delay function might help, but my way of dealing with it is to grab the audio and nudge or quantise it to where it “should” be because I have several synths and they each have their own MIDI processing lag. To make this easier I sometimes record a single note from a synth with the attack envelope settings at zero, from which I can work out how delayed the audio is. It’s usually a very few milliseconds and can often be ignored - if it wasn’t visible on a screen but was audio on a tape the delay would often never be noticed.
Live 10 Suite, 2020 27" iMac, 3.6 GHz i9, MacOS Catalina, RME UFX, assorted synths, guitars and stuff.

gross9978
Posts: 44
Joined: Tue May 08, 2018 2:18 pm

Re: Recording external audio w/ MIDI clips just a touch delayed?

Post by gross9978 » Sun Apr 26, 2020 2:33 am

If you look in the live help menu for delay compensation there should be some lessons to help you get it sorted out👍

wellsoliver
Posts: 42
Joined: Sat Dec 17, 2016 9:33 pm

Re: Recording external audio w/ MIDI clips just a touch delayed?

Post by wellsoliver » Sun Apr 26, 2020 8:10 pm

thank you both, very helpful pointers

Post Reply