Ableton Electric Keys Get Louder With Repeated Notes

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
Posts: 1
Joined: Tue Jun 06, 2017 5:04 pm

Ableton Electric Keys Get Louder With Repeated Notes

Post by AkasaDhatu » Fri Sep 11, 2020 11:45 pm


I'm trying to use the Electric Keys instrument in Ableton in piano roll (specifically the Wurli2 Soft Piano) but it does this super annoying thing where every repeated note (the same note played multiple times with no gaps) will get louder and have harder velocity with each note until it starts clipping. This makes the volume of the instrument incredibly inconsistent, with stand-alone notes being barely audible and 8th-note repeats painfully loud.

I guess this is somewhat intentional because mallet instruments get a bit louder if you keep playing the same note quickly, but the effect is just way too exaggerated on the Abelton instrument. Basically, if I play a D note 4 times in a row with a gap between them (8th notes with 8th note rests) the volume and velocity stays the same (good) but if I play a D note 4 times in a row with no gap between them (constant 8th notes with no rests), the first note will be the right volume and velocity, the second note will be way louder, and the last two notes are blasting my monitors and clipping. This happens even when all of the notes show the exact same velocity in the piano roll.

How do I turn off this increasing velocity "feature" of the Ableton Electric Keys instrument? I want all of the notes to be the same volume and velocity unless I make them quieter or louder in the piano roll its self.

I've tried fiddling with all of the knobs and settings but none of them seem to fix the issue. Any help would be greatly appreciated.


Posts: 143
Joined: Sat Dec 17, 2011 2:51 am

Re: Ableton Electric Keys Get Louder With Repeated Notes

Post by ObtuseMoose » Sun Sep 13, 2020 4:17 pm

Sounds like you have a sustain pedal plugged into your controller and it's either stuck "on" or set to the wrong polarity. That instrument will give exactly the behavior you describe when a properly configured sustain pedal pressed (or the corresponding MIDI control message is sent.) If you have a pedal plugged into your controller, try unplugging it and see if that fixes the problem. I don't think there's a way to turn off that behavior in the instrument itself.

Hope this helps.
"all the musical ability of a blocked nostril"

Post Reply