Super weird crackling sound ableton

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
MarcusvS
Posts: 6
Joined: Mon Nov 18, 2019 8:08 pm

Super weird crackling sound ableton

Post by MarcusvS » Sat Jan 30, 2021 7:55 pm

Hi guys!

So I reached out to ableton support a while back. Unfortunately they were not able to solve my problem but hopefully someone of you geniuses will be able to. When I got a new sound card (SSL 2+), I started having a problem when using Ableton live 10 suite. I haven't experienced something similar before and even now, this problem only appears when using ableton and not other DAWS like cakewalk by bandlab.
When I record things like guitar, vocals etc, a weird crackling sound often appears when playing back the audio I recorded. It's not the crackling sound that happens when using a to low buffer size for the processor. My crackling sound also appears in the recording when I export it and start playing it in a media player. If I loop the section where the crackling noise appears in, it can start crackling in different parts of the audio file and it sometimes disappears completely for a while.

If I change the sample rate in ableton to a sample rate I didn't record the audio in (either a lower or a higher sample rate) , it suddenly disappears for a while. But oftentimes, it appears again after some time. However, this makes me think that the crackling noise is not within the recording itself. I've now tried 2 other sound cards out (from 2 different manufacturers), one of them being the sound card I was using before, and I now have the same problem with those sound cards as well. I've also tried them out on a different computer with different cables but the problem still occurs on there. Not in cakewalk by bandlab though. I also sent ableton support a status report but they couldn't find anything that stuck out. Worth noting is that I never get any crackling sound on midi-tracks. Just audio.

In the examples that I'm attaching, I recorded my guitar with a sample rate of 48k in preferences. Then I exported the guitar recording. Then I switched the sample rate to 44,1k in preferences and exported the guitar recording. Then I switched the sample rate to 96k in preferences and exported the guitar recording. As you can hear, the crackling sound only appears in the audio file named “48k in preferences”.

Link to drive folder with the examples: https://drive.google.com/drive/folders/ ... sp=sharing
Last edited by MarcusvS on Sun Feb 21, 2021 11:58 am, edited 1 time in total.

teo halm
Posts: 1
Joined: Sun Feb 21, 2021 5:14 am

Re: Super weird crackling sound ableton

Post by teo halm » Sun Feb 21, 2021 5:14 am

same here sigh

Mark Williams
Posts: 549
Joined: Sun Aug 10, 2014 2:43 pm
Location: Kent

Re: Super weird crackling sound ableton

Post by Mark Williams » Sun Feb 21, 2021 9:15 am

Oh well, yet another help me help me thread, without telling us basic system setup info.

Enjoy.
Live 10, Win10, Push 2, KK S61 MK2, Focusrite Scarlett 18i20 & ADA8200, Softube Console 1 Mk2, Deepmind12D, Eventide H9, Line 6 M5, Komplete 12, Hydrasynth, Cobalt 8M, NDLR, Bass Station2, MicroFreak, Alesis Multi Strike Pad

miyaru
Posts: 1025
Joined: Tue Jan 10, 2017 12:08 pm
Location: The Netherlands

Re: Super weird crackling sound ableton

Post by miyaru » Sun Feb 21, 2021 9:39 am

LOL...... :lol:

They just don't seem to get it, do they?
Last edited by miyaru on Sun Feb 21, 2021 9:42 am, edited 1 time in total.
Greetings from Miyaru.

Prodaw i7-7700, 16Gb Ram, Focusrite Scarlett 18i20 3rd gen, Live Suit 10, Push2, Reason Suite 11, Presonus Eris E8, Lexicon MPX1,
Korg N1, Korg R3, NI Massive, Rob Papen's Predator 2, Sonarworks Reference 4 and Scaler.

miyaru
Posts: 1025
Joined: Tue Jan 10, 2017 12:08 pm
Location: The Netherlands

Re: Super weird crackling sound ableton

Post by miyaru » Sun Feb 21, 2021 9:40 am

miyaru wrote:
Sun Feb 21, 2021 9:39 am
LOL...... :lol:

They just don't seem to get it, do they?
Greetings from Miyaru.

Prodaw i7-7700, 16Gb Ram, Focusrite Scarlett 18i20 3rd gen, Live Suit 10, Push2, Reason Suite 11, Presonus Eris E8, Lexicon MPX1,
Korg N1, Korg R3, NI Massive, Rob Papen's Predator 2, Sonarworks Reference 4 and Scaler.

MarcusvS
Posts: 6
Joined: Mon Nov 18, 2019 8:08 pm

Re: Super weird crackling sound ableton

Post by MarcusvS » Sun Feb 21, 2021 11:50 am

This is my second post in this forum so I dont really know what info to include and not. Im using an asus laptop (2017 vivobook with i7 and 16 gb RAM) running windows 10, 64 bit. Latest version of Ableton 10 (now trying out the ableton 11 beta). The other computer I use is a desktop with similar specs. When doing these tests, I just added an audio track, plugged my guitar in , recorded, put the amp from ableton on the default setting, then exported it. Nothing third party at all and nothing on the master. If U need more info I'll gladly add it in my next reply!

Mark Williams
Posts: 549
Joined: Sun Aug 10, 2014 2:43 pm
Location: Kent

Re: Super weird crackling sound ableton

Post by Mark Williams » Sun Feb 21, 2021 12:09 pm

Maybe your third post, but you been a member for several years, so you shouldve read, that in order for help, you need to provide some sort of system/setup info, its quite basic, but saves a lot of time. Without it, other members wont give up their free time to try and help.

You must ensure, that Ableton and Windows are using the exact same settings, sample rate, driver etc ir you will get weird artifacts. Using the correct soundcard drivers?
Live 10, Win10, Push 2, KK S61 MK2, Focusrite Scarlett 18i20 & ADA8200, Softube Console 1 Mk2, Deepmind12D, Eventide H9, Line 6 M5, Komplete 12, Hydrasynth, Cobalt 8M, NDLR, Bass Station2, MicroFreak, Alesis Multi Strike Pad

MarcusvS
Posts: 6
Joined: Mon Nov 18, 2019 8:08 pm

Re: Super weird crackling sound ableton

Post by MarcusvS » Sun Feb 21, 2021 1:01 pm

Ok I understand. I have the 24 bit 48k (studio quality) option enabled in windows. Using 48k in ableton preferences as well. In the "Record/Warp/Launch" section in preferences I can also see that im recording in 24 bit WAV. Yeah, I have the correct drivers. I even uninstalled the other sound cards drivers in order to make sure they didnt cause any issues while testing.

Mark Williams
Posts: 549
Joined: Sun Aug 10, 2014 2:43 pm
Location: Kent

Re: Super weird crackling sound ableton

Post by Mark Williams » Sun Feb 21, 2021 1:56 pm

Windows using the same playback device as Ableton?

how is Interface connecting to PC USB hub? A lot of interfaces need a direct USB port, and dont like going via Hub.
Live 10, Win10, Push 2, KK S61 MK2, Focusrite Scarlett 18i20 & ADA8200, Softube Console 1 Mk2, Deepmind12D, Eventide H9, Line 6 M5, Komplete 12, Hydrasynth, Cobalt 8M, NDLR, Bass Station2, MicroFreak, Alesis Multi Strike Pad

MarcusvS
Posts: 6
Joined: Mon Nov 18, 2019 8:08 pm

Re: Super weird crackling sound ableton

Post by MarcusvS » Sun Feb 21, 2021 2:25 pm

Yeah the same playback device. Im not using a USB-hub. My sound card is always connected directly into the laptop. I've also tried different USB-ports. I keep my setup really minimalistic so other than the sound card, I only have an external screen, a USB-mouse, and a bluetooth keyboard connected. I've also tried out disconnecting the 3 latter devices , but with no success. The problem only occurs on audio tracks, even audio tracks i haven't recorded myself, like splice samples.

MarcusvS
Posts: 6
Joined: Mon Nov 18, 2019 8:08 pm

Re: Super weird crackling sound ableton

Post by MarcusvS » Mon Feb 22, 2021 2:40 pm

Ok, so now I've also tried fl studio for a few days and I don't get the problem with fl... I've also tried out cakewalk by bandlab as I said before and had no issues there either. It's just in ableton, which makes me believe that It's not something wrong with the sound cards, the drivers of the sound cards, nor anything wrong with the windows settings. It must be something weird going on inside ableton? Anyone having any more suggestions of things/settings to try out? highly appreciate any help I can get!

Breizhonneg
Posts: 1
Joined: Mon Feb 22, 2021 3:53 pm

Re: Super weird crackling sound ableton

Post by Breizhonneg » Mon Feb 22, 2021 4:41 pm

Hi everyone,

I'm experiencing the same kind of problem : I am currently ripping some of my vinyls so I purchased couple month ago a brand new audio interface (Motu M2).

To proceed to the recording, I plug into my DJ mixer A&H Xone 23 a decent quality cable (Cordial) that is connected to my audio interface in both left and right entrances. The audio interface is then plug by USB to my computer. Once the gain adjusted so it never clip and remain between -1dB and -3dB (in ableton audio track), I start my recording : ALL of my recordings are crackling in a very harsh way in some part of the records, not even the louder parts of the records. It never happen twice at the same place of a same track. I'm saying crackling, but It would be more appropriate to say that at these moment, It's like the sample rate is passing from 44k to 1k for a few seconds. Those rips are unusable.
Here an example : https://soundcloud.com/antoine-allain-4/harsh-crackling

I've been using Audacity for a few recordings since I was not able to solve this issue with different parameters, and never had this problems, all of the recordings are super clean. This probably come from or my OSX version or ableton, if audacity is working perfectly fine with my setup.

FYI : I'm running latest ableton version 10.1.30 on macOS High Sierra, Intel Core i7, 16Go RAM.

Just wanted to share my experience here to see if other people is experiencing the same kind of problem. If it happens with vinyl ripping, this might happen with any other source. I'll be soon using a hardware synth and would like to record it within ableton, this would be a pity if I couldn't do it.

Hope to read you soon!

Post Reply