Has anyone tried OSX 10.2.4 with Live 2.01 yet?

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
amwintx
Posts: 35
Joined: Thu May 09, 2002 6:18 pm
Location: austin, tx
Contact:

Has anyone tried OSX 10.2.4 with Live 2.01 yet?

Post by amwintx » Fri Feb 14, 2003 6:57 pm

All:

Has anyone tried OSX 10.2.4 with Live 2.01 yet? If so, I'd be interested in your experience, especially with regard to any performance changes and stability with any audio harware you may be using (m-audio, motu, etc).

Thanks.

logicat2001
Posts: 159
Joined: Tue Jan 21, 2003 3:08 pm

Post by logicat2001 » Fri Feb 14, 2003 10:38 pm

I worked for an hour last night... I didn't experience any problems. As for performance increases, time will tell.

Best,
Logicat

amwintx
Posts: 35
Joined: Thu May 09, 2002 6:18 pm
Location: austin, tx
Contact:

What hardware do you use?

Post by amwintx » Fri Feb 14, 2003 11:58 pm

Logicat,

What audio hardware are you using? I have both an m-audio quattro and a m-audio delta tdif pci card. I'm interested to see if you or anyone else has had experiences with either of those 2 devices under 10.2.4.

Thanks.

iMapnes
Posts: 9
Joined: Sat Dec 14, 2002 4:18 am

Post by iMapnes » Sat Feb 15, 2003 11:37 am

Hi amwntx,
I just tried it and sorry to say its no improvement. It's not the macs fault anyway but Live's non-support of coreaudio thats the problem. But on the bright side live launches quicker in 10.2.4 :) so thats an improvement from apple's side.
FYI i'm not using anything fancy, just an iMic out of an old Yamaha RM602 mixer, works great for me. Also if anyone wants to bash iMic as a cheap piece of equipment being the cause...its not. This setup works just fine under os9 (soundmanager) w/512 samples. No dropouts or breakups in the audio. It also works with NO audible latency with amadeus II, so it isn't coreaudio's fault. The problem for us who use osX seems to be ableton not optimizing live for coreaudio. I don't know if htey are working on it or not as the tech support specialist never answers email but its a damn shame. Other programs are taking advantage of coreaudio's performance and latency is really not an issue with those apps. I just hope ableton gets on the ball and fixes this problem soon, its a real downer to have to keep switching bet.9 and X just to record.

amwintx
Posts: 35
Joined: Thu May 09, 2002 6:18 pm
Location: austin, tx
Contact:

Post by amwintx » Sat Feb 15, 2003 3:31 pm

Actually, I've been having extremely good luck with Live 2.0 with my hardware, no real problems to speak of. I'm more concerned with 10.2.4 CREATING problems, than I am with solving them.

logicat2001
Posts: 159
Joined: Tue Jan 21, 2003 3:08 pm

Post by logicat2001 » Sat Feb 15, 2003 6:29 pm

Hiya,

I'm also using an iMic for audio input. Sorry that I can't help you with your specific interface questions, amwintx.

iMapnes, I know how you feel. I can't wait until all the rough spots get smoothed over during the transition to X.

Until then, let's enjoy the tools and continue to
Best,
Logicat

iMapnes
Posts: 9
Joined: Sat Dec 14, 2002 4:18 am

Post by iMapnes » Sat Feb 15, 2003 10:06 pm

Logicat, i agree wholeheartedly! Even with its flaws Live2 is still awesome!

Novacosmic
Posts: 17
Joined: Wed Jan 29, 2003 3:15 pm
Location: Toronto, Canada
Contact:

Post by Novacosmic » Sun Feb 16, 2003 3:05 pm

Live 2.0.2 + OS 10.2.4 = 12 hour recording session last night, lots of tracking, editing, etc., and no crashes or weird behaviour. Reason ran in slave mode smoothly.

I am using M-Audio's Quattro + Omni, a Ti Powerbook 800 mHz with 1 gig ram.

Apple's website says that 10.2.4 improves Firewire for audio, and since I am using a Firewire 120 gig Lacie HD, I decided to take the plunge. My only regret is that I never ran 2.0.2 in 10.2.3 even once, for a performance comparison.

Startup took 32 seconds, which is half the time it used to take.

iMapnes
Posts: 9
Joined: Sat Dec 14, 2002 4:18 am

Post by iMapnes » Mon Feb 17, 2003 9:07 am

what kind of latency do you get with the quattro in 10.2.4?

Novacosmic
Posts: 17
Joined: Wed Jan 29, 2003 3:15 pm
Location: Toronto, Canada
Contact:

Post by Novacosmic » Mon Feb 17, 2003 4:41 pm

iMapnes wrote:what kind of latency do you get with the quattro in 10.2.4?
12 ms output latency
12 ms input latency
+ 14 ms
= 38 ms

I haven't experimented with latency settings at all, I should add. The default settings have worked fine for me and I tend to only delve into a subject when it starts interrupting my creativity, ie., I have no other choice.

iMapnes
Posts: 9
Joined: Sat Dec 14, 2002 4:18 am

Post by iMapnes » Mon Feb 17, 2003 6:53 pm

Thanks... 38 is pretty good.

os
Posts: 278
Joined: Tue Apr 16, 2002 12:49 pm
Location: UK
Contact:

Post by os » Tue Feb 18, 2003 11:56 am

iMapnes wrote:It's not the macs fault anyway but Live's non-support of coreaudio thats the problem.
In what sense does Live not support coreaudio?
It seems to be using coreaudio drivers for my MIO under OS X. The performance is appalling, but it's using coreaudio.

Novacosmic
Posts: 17
Joined: Wed Jan 29, 2003 3:15 pm
Location: Toronto, Canada
Contact:

Post by Novacosmic » Tue Feb 18, 2003 1:31 pm

CoreAudio is very new: not even Apple has managed to make it work the way it will in upcoming months. Ableton was one of the first audio companies to support OSX (and therefore, CoreAudio), so it is obviously going to take some time to get it right.

Our great hope lies in a major performance boost under OSX in the coming months, as Altivec processing and OS improvements will practically double performance.

Does anyone know if Live can support dual processors? I am thinking about buying a new dual G4 desktop.

FORMAT
Posts: 1776
Joined: Thu Jan 10, 2002 12:13 pm
Contact:

Post by FORMAT » Tue Feb 18, 2003 7:21 pm

I tried live in 10.2.4 and experienced a major slowdown - what used to be 25 % CPU in 10.2.3 was then 49! I'm going back ----- and once again this is proof of the fact that Apple are not always improving their OS.... well, can't be helped. If anyone knows of any tips how to improve performance in 10.2.4, please let me know.

format

os
Posts: 278
Joined: Tue Apr 16, 2002 12:49 pm
Location: UK
Contact:

Post by os » Wed Feb 19, 2003 9:03 am

Format - I've read elsewhere that sometimes updating the OS via software update gets it wrong, and in this case it's best to download the Combo updater from the Apple website (which contains all the changes since 10.2.0 rolled up into one updater) and apply that.
Maybe that will help. I can't believe a working installation of 10.2.4 would hit your performance like that, all other things being equal.

Post Reply