Expected latency for USB 2.0 or Firewire?

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
decrepitude
Posts: 105
Joined: Thu Oct 28, 2004 5:30 pm

Expected latency for USB 2.0 or Firewire?

Post by decrepitude » Mon Nov 21, 2005 9:39 pm

I have a friend on mac who will be purchasing Live, but he is not so pleased that his Mbox is hard wired for 10ms latency (well, there are 2 settings and 10ms is the lowest.)

I am guessing this has to do with the inherent limits of USB bandwidth than anything else.

His I-book has no cardbus slot, so he will have to use USB or Firewire.

Does anyone have any ideas of what improvements in latency he would get from a firewire interface. What is the lowest possible latency for Firewire?

Any experiences from other firewire-connected mac users much appreciated.

sp0bjogu
Posts: 59
Joined: Wed Aug 18, 2004 6:19 pm

Post by sp0bjogu » Mon Nov 21, 2005 11:42 pm

Comparing Firewire 400 and USB2 generally means lower stress on your system (CPU) using Firewire. Impossible to say what your latency will be - too many parameters involved.

My experience: quality gear == more expensive == lower latency.

Check out RME Fireface 800 for latencies at 1 ms.
http://www.rme-audio.de/english/firewire/ff800.htm


/sp0

Clearscreen
Posts: 1743
Joined: Sun Jul 11, 2004 5:07 am
Location: Melbourne AU
Contact:

Post by Clearscreen » Tue Nov 22, 2005 12:20 am

latency is a tricky thing to predict, but i can run stuff at 64 samples (about 2ms) if i use the internal or firewire soundcards. i can't go lower than about 12ms over usb 1.1 though.

seeing you're on mac i'd recommend firewire as you can power the soundcard from it as well if you need to. most of the usb 2 soundcards seem to require external power to run. also, i have an external hard drive that has usb2 and firewire in it, so i ran a little test the other day for the hell of it and firewire was running with better bandwidth (according to the test program anyway...)
Hp Elitebook 2.8Ghz. Live 7.0.14 & Live 8.1.5, XP Pro. and stuff...

jasefos
Posts: 534
Joined: Sun Jan 11, 2004 6:31 am
Location: Melbourne, Australia
Contact:

Post by jasefos » Tue Nov 22, 2005 1:35 am

Achieving good low latency operation (with minimal CPU hit) is most often effected by:

1) the connection protocol's speed .... thus USB1.1 devices don't wear favourably in this respect

2) the QUALITY of the device driver code.


The latency achieved by cards such as those manufacturer by Lynx (broadcast quality audio interfaces) are among the best available however have a price tag to match.

A good sign of a soundcard having well programmed drivers is how close to 100% CPU you can drive your system at low latency (less than 256 samples for instance) before audio/GUI performance starts to fall apart. Lynx cards allow you to seriously push your system's CPU resources before suffering audio buffer breakup.

Next down the rung are the well regarded crop of audio interfaces by RME and Echo ... great quality A/D and D/A for the money and low latency operation (however slighly higher CPU overhead drivers).

Yamaha's M-Lan audio devices (Yamaha 01X and i88x) are also on par with RME and Echo audio interfaces. Yamaha 01X's are remarkably cheap at the moment incidentally however only recommended only if you have a good tech brain however since deploying m-Lan can be a frightening prospect for the novice.


An anamolly to the "you get what you pay for" rule:
ESI's Juli@ cards. Although this is a bargain basement priced card (and don't have A/D and D/A convertors of quality comparable to those found on Apogee or Lynx cards) they are supplied with **superb** drivers.

At the end of the day it doesn't matter how many bells and whistles an audio interface may have, if the DRIVERS are crap it will let down performance of the whole system.

Cheers
JaseFOS

-Live10.1 |Push2|Maschinemk2|KeyLab61|LaunchPad|MCUpro|MCExt|MCExt|iPad2|TouchABLE2
-Mac Pro 5.1 (dual hex core Xeon 3.46gHz, 28Gb RAM) running MacOS 10.13.6
-Universal Audio Apollo Quad (firewire)
-SHITLOADS OF HARDWARE SYNTHS

Hypomixolydian
Posts: 812
Joined: Wed Jun 16, 2004 9:54 pm

Post by Hypomixolydian » Tue Nov 22, 2005 2:19 am

With USB 1.1 I can get about 7ms with my Tascam US-122 unit and with my Novation X-Station 3 or 4ms. Both which I am happy with!

jasefos
Posts: 534
Joined: Sun Jan 11, 2004 6:31 am
Location: Melbourne, Australia
Contact:

Post by jasefos » Tue Nov 22, 2005 3:35 am

Astral Fridge Magnet wrote:With USB 1.1 I can get about 7ms with my Tascam US-122 unit and with my Novation X-Station 3 or 4ms. Both which I am happy with!

Dont'worry - it wasn't my intention to offend USB1.1 interface users however **generally** better latency with lower CPU overhead is achieved with FW400/800, USB2, PCI and PCMCIA audio interface compared with USB1.1.


The latency figures you quote are impressive for USB1.1 ...

FOR EACH DEVICE .....
What is your CPU overhead like when Live is idle (i.e. empty project)?
At which ASIO buffer size (in samples) / sample rate / bit depth ?

Cheers
JaseFOS

-Live10.1 |Push2|Maschinemk2|KeyLab61|LaunchPad|MCUpro|MCExt|MCExt|iPad2|TouchABLE2
-Mac Pro 5.1 (dual hex core Xeon 3.46gHz, 28Gb RAM) running MacOS 10.13.6
-Universal Audio Apollo Quad (firewire)
-SHITLOADS OF HARDWARE SYNTHS

continuous
Posts: 1012
Joined: Sat Aug 06, 2005 7:11 pm
Location: PDX

Post by continuous » Tue Nov 22, 2005 3:39 am

If anybody could tell me what Latency they get with their Traveler I would be most appreciative.

Cheers

Hypomixolydian
Posts: 812
Joined: Wed Jun 16, 2004 9:54 pm

Post by Hypomixolydian » Tue Nov 22, 2005 3:45 am

No offense taken by the way! All I was doing was giving you my figures, I didn't interpret you having a go at USB interface users at all.

Anyway, My CPU overhead is 1%, and my ASIO buffer size is 256, Sample rate 44.1 and bit depth 24bit. This is on my Tascam unit.

My PC is a 2.4 Ghz with 512 RAM

Right now I don't have my Laptop going so I can't tell you my Novation figures.

sweetjesus
Posts: 8803
Joined: Wed Mar 31, 2004 3:12 pm
Location: www.fridge.net.au
Contact:

Post by sweetjesus » Tue Nov 22, 2005 4:18 am

Astral Fridge Magnet wrote:No offense taken by the way! All I was doing was giving you my figures, I didn't interpret you having a go at USB interface users at all.

Anyway, My CPU overhead is 1%, and my ASIO buffer size is 256, Sample rate 44.1 and bit depth 24bit. This is on my Tascam unit.

My PC is a 2.4 Ghz with 512 RAM

Right now I don't have my Laptop going so I can't tell you my Novation figures.
at first my mbox was showing only two options of latency but now i can get it right down to 128 but most often 256...

decrepitude
Posts: 105
Joined: Thu Oct 28, 2004 5:30 pm

Post by decrepitude » Tue Nov 22, 2005 4:32 pm

sweetjesus wrote: at first my mbox was showing only two options of latency but now i can get it right down to 128 but most often 256...
Huh? New driver? How'd you accomplish that?

Thanks!

Post Reply