CPU driving me crazy

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
Iggie
Posts: 8
Joined: Sun Jan 15, 2006 12:06 pm
Location: Glasgow
Contact:

CPU driving me crazy

Post by Iggie » Sun Jan 15, 2006 12:15 pm

Hi all,

I recently made the excellent decision to purchase Live 5. I am running Live 5 on a PC with a 3.2Ghz processor and i have 1 GB of RAM. However, I am having real problems with the CPU usage, and its doing my head in.

I am using Live 5 mainly to lay down tracks rather than the DJ side of things. For example i am working on a track just now and i have recorded 9 clips. I have not begun to sequence the track yet but my CPU is going above the 80% threshold and Live 5 keeps freezing etc and i am unable to add to the track.

Do you guys have any ideas on how to resolve this. I think my processor is good enough, should i buy more RAM?

Any suggestions would be greatly appreciated.

Thanks
Iggie

sqook
Posts: 2430
Joined: Mon Oct 04, 2004 8:14 pm
Location: Sweden
Contact:

Post by sqook » Sun Jan 15, 2006 12:20 pm

What type of soundcard do you have?

suburbanbather
Posts: 1376
Joined: Sat Jul 03, 2004 11:19 am
Location: Waldorf MD

Post by suburbanbather » Sun Jan 15, 2006 12:28 pm

Is your video card sharing your memory?

A gig of memory should be fine with Live 5, but it may not be so good if its being shared with your video card.

Your processor speed should handle it just fine.

Your not using a Celeron processor are you?

How fast is your harddrive?

Whats your buss speed?

Have you tried doing a "disk clean up" and "Defragging" your harddrive(s)?

Iggie
Posts: 8
Joined: Sun Jan 15, 2006 12:06 pm
Location: Glasgow
Contact:

Post by Iggie » Sun Jan 15, 2006 12:40 pm

Thanks for repkying guys.

At the moment i am using a realtek AC97 sound card, its the card that cam with the computer when i bought it.

Suburbanpanther, how do i check to see if its being shared with my video card?
I'm using a Intel Pentium 4 processor.
I'm not sure about harddrive or buss speeds, how do i check.
I've done disk clean up but it hasn't made any difference and i'm not sure how to defrag my harddrive, would this help?

sqook
Posts: 2430
Joined: Mon Oct 04, 2004 8:14 pm
Location: Sweden
Contact:

Post by sqook » Sun Jan 15, 2006 12:54 pm

Ouch, the ac97 is a very bad card. It's the standard with most motherboards these days, and I would wager that it's responsible for at least some of your problems. It is a sufficient card for audio playback, but for recording or any audio-intensive task, its weaknesses will become apparent.

To check your system stats, you can right click on 'my computer' and go to properties. Some of them are listed under there. To defrag your hard disk, right click on the hard drive and go to 'properties'.... there is an option under there somewhere for defragmenting the volume. Also, it's worth asking... how much spare hard disk space do you have? If the answer is 1Gb or less, than it's likely that windows has run out of swap space.

Probably the best thing you can do to boost system performance with your system specs is to set windows to prioritize 'background services' instead of applications (I think that's somewhere in the 'system' dialog under the control panel... I don't have a windows machine handy at the moment, so I can't check, unfortunately). Sound is considered a background service in windows, so doing this will (theoretically) boost your sound performance, particularly if you have a slow soundcard.

Iggie
Posts: 8
Joined: Sun Jan 15, 2006 12:06 pm
Location: Glasgow
Contact:

Post by Iggie » Sun Jan 15, 2006 1:35 pm

Thnx,

I 'm defragmenting just now.
I,'ve still got about 100 GB left on my hard disk so that should not be a problem.
I'm struggling to fing where i can prioritize background services though, i'll keep trying.
Thanks for the reply.

stinky
Posts: 1182
Joined: Mon Jul 25, 2005 1:06 am

Post by stinky » Sun Jan 15, 2006 4:00 pm

Right click My Computer, go to properties, click on the Advanced tab, click on the Performance button, under Visual Effects, click on the button that states "Adjust for best performance"... then, click on the Advanced tab, under Processor Scheduling, change Programs to Background. You also want to make sure that under Virtual Memory, you have at least 1-1.5 times virtual memory as your machine has RAM. I'd suggest no less than 1 gig, but prefferably 2gigs... and if you have a spare drive, put it on the second drive.

I would also go through this tutorial and make sure that you've made a good check of all it's points. It'll teach you alot, and make your system hum.

http://www.digitalproducer.com/2002/11_ ... caudio.htm

martin808
Posts: 584
Joined: Mon Jul 25, 2005 2:09 pm
Location: Glasgow
Contact:

Post by martin808 » Sun Jan 15, 2006 4:31 pm

most importantly, check your power settings are set to always on.

right click the desktop>properties>screen saver tab>power>select always on>apply

this will make the 3.2p4 run at full speed all the time.

also if it has hyper threading, turn it off in the BIOS. I found this helped a lot.


It's not a packard bell is it?

Angstrom
Posts: 14662
Joined: Mon Oct 04, 2004 2:22 pm
Contact:

Post by Angstrom » Sun Jan 15, 2006 4:38 pm

if you aren't using it already - install the Asio4all driver for your soundcard

http://www.asio4all.com/

when you can afford it - get a better soundcard though.

sweetjesus
Posts: 8803
Joined: Wed Mar 31, 2004 3:12 pm
Location: www.fridge.net.au
Contact:

Post by sweetjesus » Sun Jan 15, 2006 4:39 pm

hey mate,

not sure if you tried this but go to http://www.asio4all.com and get these drivers and once they are installed, in the options > audio panel of Live, set this as your ASIO driver.

im sure things will get a lil better then.

martin808
Posts: 584
Joined: Mon Jul 25, 2005 2:09 pm
Location: Glasgow
Contact:

Post by martin808 » Sun Jan 15, 2006 4:47 pm

sweet jesus and angstrom on a parallel there. :)

longjohns
Posts: 9088
Joined: Mon Dec 22, 2003 3:42 pm
Location: seattle

Post by longjohns » Sun Jan 15, 2006 4:58 pm

also, check in you preferences and make sure that live is not automatically warping your new tracks to complex mode. get 9 tracks going like this and i think your cpu would be feeling it

Iggie
Posts: 8
Joined: Sun Jan 15, 2006 12:06 pm
Location: Glasgow
Contact:

Post by Iggie » Tue Jan 17, 2006 8:05 pm

Thanks all for the replys

What was running at 70 - 80% CPU, is now running at around 40%.
Will definately get a decent soundcard soon, its next on the list.

Thanks
Iggie fae the shire

Post Reply