Alesis Photon X25 - anyone using?

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
pauncy
Posts: 4
Joined: Fri Jan 27, 2006 9:31 pm

Alesis Photon X25 - anyone using?

Post by pauncy » Tue May 02, 2006 1:31 pm

Hi,
Just awaiting one of these little beauties...anyone using one with Live - any probs. How is the AXYZ thingy. How is the audio etc....

Thanks

Groovecake
Posts: 140
Joined: Thu Jan 20, 2005 10:12 pm
Location: Omaha

Post by Groovecake » Tue May 02, 2006 2:23 pm

Some of my presets have become corrupted with an "Error 037" - whatever the hell that is. Alesis support has never e-mailed me back.

Other than that, I like it.
MacBook Pro 2.0 Dual, 2 Gig RAM, MOTU Ultralite, Ableton Live, Moog Voyager RME, MultiMoog, Rhodes stage 73, Hammond B-3, Hammond XK-3, Leslie 145, Yamaha Motif, Alesis Photon X-25, M-Audio Oxygen

theque
Posts: 614
Joined: Mon May 30, 2005 11:47 am
Location: adelaide
Contact:

Post by theque » Wed May 03, 2006 7:28 am

i got one really like it, simple to use, except i havent sussed out the xyz thing yet, assigning it is hard. i might just be an idiot though. but for the price with a built in sound card it is magnificent.

Goseba
Posts: 187
Joined: Tue Jun 08, 2004 10:12 pm

Post by Goseba » Wed May 03, 2006 10:30 pm

I have had one for nearly a year now but have not used it a great deal (not by choice, just very little time recently).
I do find it quite good but again have only tried the XYZ thing once or twice so cannot comment too much other than it worked fine. I recently bought KLCDE and am looking forward to using it with the Wavestation.

Now the bad news. When I bought it, it wasn't working properly. Alesis support (Numark in the UK) talked me through a reset procedure which sorted it out.
A few months ago it died completely. It took 5 or 6 weeks for it to be repaired which is piss poor performance for a warranty repair.

Post Reply