Sustain pedal midi issue?

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
stickmartin
Posts: 18
Joined: Tue Jul 31, 2007 3:34 am

Sustain pedal midi issue?

Post by stickmartin » Tue Jul 31, 2007 3:41 am

Hey everyone,
Need a little help figuring this out.

When I build up a track I usually record everything as loops and then mess around with arrangement view until I get things set up the way I want.

Here's my issue:
I laid down a midi part using Abelton's Organ patch from the new instrument library. I had to use the sustain pedal on some parts to free up my hands.

As loops everything sounds fine, but when I switch the stuff over to arrangement view, things get weird.

It's basically like my sustain pedal will get stuck on and every midi note will just continue to ring out until I press the stop button.

Basically, what I need to know is if there is some kind of sustain pedal automation I can control in Ableton. I know the sustain pedal is just another midi signal, but I don't know how I can adjust it.

Please let me know.

Thanks
stick

longjohns
Posts: 9088
Joined: Mon Dec 22, 2003 3:42 pm
Location: seattle

Post by longjohns » Tue Jul 31, 2007 3:55 am

I sometimes (OK, often...) find that the sustain pedal will get stuck ON at the end of a playback pass where it was active. i.e. there is no OFF message when you stop the transport.

But pressing the pedal down to clear it solves this, and then the recorded sustain pedal automation plays fine.

Is this what you are experiencing or is it something worse?

stickmartin
Posts: 18
Joined: Tue Jul 31, 2007 3:34 am

KInd of...

Post by stickmartin » Tue Jul 31, 2007 10:50 am

Yeah, that's was one of the ways I would fix it. However, I just found foot pedal automation under the clip envelope at the bottom of the page, I think that should clear up my issues. Thank you though for your reply.

thuzen4bWbQnXr
Posts: 84
Joined: Sat Apr 07, 2007 1:36 am

Topic

Post by thuzen4bWbQnXr » Fri Jun 13, 2008 4:07 am

deleted
Last edited by thuzen4bWbQnXr on Sun Apr 01, 2012 2:19 am, edited 1 time in total.

m.Lo
Posts: 102
Joined: Thu Aug 30, 2007 3:45 pm
Location: Germany
Contact:

Re: Sustain pedal midi issue?

Post by m.Lo » Fri Jun 13, 2008 2:45 pm

stickmartin wrote:Hey everyone,
Need a little help figuring this out.

When I build up a track I usually record everything as loops and then mess around with arrangement view until I get things set up the way I want.

Here's my issue:
I laid down a midi part using Abelton's Organ patch from the new instrument library. I had to use the sustain pedal on some parts to free up my hands.

As loops everything sounds fine, but when I switch the stuff over to arrangement view, things get weird.

It's basically like my sustain pedal will get stuck on and every midi note will just continue to ring out until I press the stop button.

Basically, what I need to know is if there is some kind of sustain pedal automation I can control in Ableton. I know the sustain pedal is just another midi signal, but I don't know how I can adjust it.

Please let me know.

Thanks
stick
It´s a very old problem of LIVE that still drives me nuts sometimes. Seems like no other LIVEuser plays a keyboard, and so the abletons don´t have to sort it out. The reason for the hold pedal remaining down is: If you stop a midi clip on a position where the pedal is down and go to the startpoint of the clip, the pedal remains pressed down instead of taking the status of the clip´s beginning. Don´t know who´s idea that was and what reason for...Problems like this, there are some similar ones that make it nearly impossible to use LIVE live made me stop investing in Ableton.

laird
Posts: 1996
Joined: Tue Feb 27, 2007 10:05 pm
Location: PDX
Contact:

Post by laird » Fri Jun 13, 2008 4:28 pm

Is this a problem in Live?

Its been a problem with every sequencer I've ever used, that if you Loop a section where the sustain pedal gets turned on... then you delete/never play the section where it gets turned off... well, it stays on.

MIDI CC64 is the sustain pedal continuous controller number. try putting a "0" value in the automation lane where you need it turned off.

As was mentioned earlier, pressing it again also works. two on commands in a row does nothing, but can give you the Off command you need/lost.

m.Lo
Posts: 102
Joined: Thu Aug 30, 2007 3:45 pm
Location: Germany
Contact:

Post by m.Lo » Fri Jun 13, 2008 6:16 pm

laird wrote:Is this a problem in Live?

Its been a problem with every sequencer I've ever used, that if you Loop a section where the sustain pedal gets turned on... then you delete/never play the section where it gets turned off... well, it stays on.

MIDI CC64 is the sustain pedal continuous controller number. try putting a "0" value in the automation lane where you need it turned off.

As was mentioned earlier, pressing it again also works. two on commands in a row does nothing, but can give you the Off command you need/lost.
Can´t remember having this issue in cubase earlier, but maybe I didn´t use it that way. I mean this shouldn´t be. I cannot edit automation playing live.

laird
Posts: 1996
Joined: Tue Feb 27, 2007 10:05 pm
Location: PDX
Contact:

Post by laird » Fri Jun 13, 2008 6:35 pm

Well, some sequencers have a function ... "MIDI Follow" was how mastertrax! called it, i think...

where the sequencer would actually look behind where you hit play to see what any CC value should be. That way if nothing was specified at the exact moment in the song where you hit play from, you didn't just hear settings from elsewhere in the song.

Whether the squencer does it for you or not, you gotta send a CC64=0 message

thuzen4bWbQnXr
Posts: 84
Joined: Sat Apr 07, 2007 1:36 am

Post by thuzen4bWbQnXr » Thu Oct 09, 2008 9:21 pm

the midi cc 64 doesn't solve the sustain problem for me

any more ideas?

i'm using Jazz Organ and Electro Arp (Analog)

abletonjim
Posts: 42
Joined: Sun Oct 18, 2009 9:22 am

Re: Sustain pedal midi issue?

Post by abletonjim » Thu Nov 26, 2009 11:14 am

I still can't find the sustain pedal automation..

edit: found the answer:
in track view, click on the track you wish to edit the automation.. then click Envelope.. then select 64.. voila
Ableton 8.1, MacBook Pro 2.2ghz, APC40, Motif XS8, Adam A7, Adam Sub8, Apogee Ensemble, PC Desktop Quad 2.4ghz, PC Laptop Duo Core 2ghz
Next: Lemur

michael4u
Posts: 47
Joined: Thu Aug 13, 2009 8:06 pm
Location: Scottland

Re: Sustain pedal midi issue?

Post by michael4u » Thu Nov 26, 2009 11:51 am

Thank you very much. I was searching the soluion of my problem from long time and atlast i got here. Great information ! Keep it up man!

fluentc
Posts: 3
Joined: Thu Jan 16, 2014 7:46 am

Re: Sustain pedal midi issue?

Post by fluentc » Sun Jul 06, 2014 11:36 am

edit: found the answer:
in track view, click on the track you wish to edit the automation.. then click Envelope.. then select 64.. voila[/quote]

I had the same problem of sustain being stuck, the above fix totally worked, thanks all, was beginning to feel like Ableton was deliberately fucking with me. 8O

doghouse
Posts: 1413
Joined: Fri Aug 29, 2008 5:30 pm

Re: Sustain pedal midi issue?

Post by doghouse » Sun Jul 06, 2014 12:27 pm

It's not just Live...any MIDI sequencer will have this sort of problem if you stop recording before you release the sustain pedal or if you're editing the data and accidentally delete the bar with the pedal release msg.

This is true of recording any CC actually. Depending on which CC it is and how that maps to the receiving device all kinds of strange things can happen.

Xa Sancle
Posts: 5
Joined: Thu Jul 18, 2019 6:10 pm

Re: Sustain pedal midi issue?

Post by Xa Sancle » Fri Sep 13, 2019 10:35 am


adamjmusic@hotmail.com
Posts: 2
Joined: Tue Apr 27, 2010 2:17 am

Re: Sustain pedal midi issue?

Post by adamjmusic@hotmail.com » Tue Dec 24, 2019 1:22 am

I solved this by using this: https://www.maxforlive.com/library/devi ... tain-pedal

If sustain is ever stuck I just have to click "off" with it and sustain is now off.

Post Reply