Ultra-Portable Notebooks will not Work with Audio Interfaces

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
dn83
Posts: 218
Joined: Thu Jan 11, 2007 6:06 pm
Location: USA

Ultra-Portable Notebooks will not Work with Audio Interfaces

Post by dn83 » Thu Oct 25, 2007 5:49 pm

Hi everybody - I thought I would post about a recent episode of mine. Get ready, it's a bit long...

After switching to a MacBook for a while, I decided to go back to PC. I went with a refurbished DELL xps m1210 laptop, which is a 12.1" "ultra-portable" model. I soon noticed that I was experiencing an occasional audible crackle noise with any sound output from my audio interface, even though I knew the latency wasn't the problem and I had never had this problem before. It seemed to be mostly when I would do something that forced the on-screen image to have to be redrawn, like moving or resizing windows, but especially anything 3D (like a 3D screensaver).

Of course, I researched and tried EVERYTHING - drivers, updates, disabling any unused and possibly conflicting hardware (including the Wifi adapter), a fresh format/OS install, and many other tweaks, etc.

Thinking it could be the interface, I eventually tried FOUR other interfaces in addition to my PreSonus Inspire 1394 FireWire interface. I tried the m-Audio FastTrack USB, Lexicon Lambda USB, Tapco Mackie Link.USB and the TASCAM US-122L USB 2.0, but experienced the same issue! So, it wasn't related to the audio interface either. With no other options left to try, I returned the first xps m1210 for another one. But guess what? Same thing, and that's just the beginning!

I next tried a 12.1" Jetta notebook and then a 12.1" HP Notebook, both brand new, and tried them with all of the above mentioned interfaces, and they both did the same thing. Unbelievable! I tried ruling out even more possibilities. Of the laptops I tried, a couple had Windows XP and a couple had Vista, also, some had Intel integrated graphics, whereas some had dedicated nVidia graphics, and none of it made a difference! All the laptops I tried had Intel Core 2 Duo processors, except the HP, which had a dual core AMD processor, but again, none of these factors mattered - I still experienced the problem!

At this point, I was beyond frustrated. How could new notebooks, from different brands, with different operating systems, slightly different components and using different audio interfaces be doing this?? The only common thread that I could see at this point was the fact that they were all ultra-portable models...

So, I returned all the laptops for refunds as well as all of the audio interfaces. I ordered a new 15.4" SONY VAIO notebook to try out. It arrived just yesterday and I tried it out with my interface and luckily, the problem is totally gone! The only thing different with this notebook? The size. All the previous laptops I tried were ultra-portable 12.1" models. There has to be some problem with the tightly integrated components of ultra-portable models.

So, if you're looking for a laptop to use with an external audio interface, I wouldn't try anything smaller than probably a 13.3" model - it just will not work. That is, until this issue is resolved, if ever.

Apparently, currently manufactured ultra-portable notebooks simply cannot be used with external audio interfaces - who knew?!?! You've been warned! Haha, good luck!


Doni
Last edited by dn83 on Thu Oct 25, 2007 9:42 pm, edited 3 times in total.

Tone Deft
Posts: 23911
Joined: Mon Oct 02, 2006 5:19 pm
Location: SF, CA

Post by Tone Deft » Thu Oct 25, 2007 5:56 pm

where they all running the same OS? or to say, was it a Vista thing?

I dunno man, it's just audio, it's not rocket science and in a basic setup doesn't use nearly the full bandwidth that USB has to offer.

it's dubious but I don't know if there's conclusive evidence. might be a good one to throw at the KVR forum.
"Obsession is a great substitute for talent." - Steve Martin on learning the banjo

Dell Inspiron 15 7000, Live 10.1, Win10 Home, Edirol UA101, APC40, Remote SL, SPD-SX, mic, POD500HDX, JX305, Nova
soundcloud.com/tone-deft

xxxmorphicxxx
Posts: 152
Joined: Tue May 04, 2004 9:21 pm

Post by xxxmorphicxxx » Thu Oct 25, 2007 5:57 pm

Without actually troubleshooting your problem, my guess would be that the crackling has to do with IRQ sharing. There are ways around this.

rikhyray
Posts: 3644
Joined: Wed Aug 25, 2004 12:13 pm
Contact:

Post by rikhyray » Thu Oct 25, 2007 6:05 pm

It has not much to due with any tightness but with the components used.
Though the integrated graphic they mostly use is not ideal for audio, plenty of Macbook users have no problem with them.
The best for portability /quality- Vaio SZ series, the 2 cards option lets you use Intel on the move and Nvidia in studio. Only problem they are bloody expensive.
Quality comes at a price and for me it is either MBP or top Vaio models. Unfortunately looks like we have to wait longer for MBP ultraportable.

dn83
Posts: 218
Joined: Thu Jan 11, 2007 6:06 pm
Location: USA

Post by dn83 » Thu Oct 25, 2007 6:25 pm

Hey guys, thanks for the replies. Yep, IRQ conflicts sounds very likely.

And nope, as I mentioned, a couple that I tried were running XP, and a couple were running Vista, and it made no difference.

Cool that you mention it - I've got a refurbished VAIO SZ notebook on it's way, can't wait!! I just hope it works! Haha...if it works fine, then I'll return this 15.4" model...which is nice, but bulky.

beats me
Posts: 23319
Joined: Fri Mar 30, 2007 6:39 pm

Post by beats me » Thu Oct 25, 2007 6:34 pm

You lost me at I went from Mac to PC. The rest was blah blah blah. You problably could have skipped this entire mess if you skipped that very first step.

icedsushi
Posts: 1652
Joined: Wed Jan 12, 2005 8:36 pm

Post by icedsushi » Thu Oct 25, 2007 6:44 pm

rikhyray wrote:integrated graphic they mostly use is not ideal for audio,
Why not? How do the graphics affect the audio? I don't see how you you would get lesser sound quality just because the graphics are integrated. This is the first time I ever heard this comment. Doesn't sound right to me.
Last edited by icedsushi on Thu Oct 25, 2007 6:45 pm, edited 2 times in total.

dn83
Posts: 218
Joined: Thu Jan 11, 2007 6:06 pm
Location: USA

Post by dn83 » Thu Oct 25, 2007 6:44 pm

beats me - I guess you're a Mac devotee? :wink: Haha, don't get me wrong - Macs are cool! I just prefer PC. Anyway, I don't want this to turn into a Mac versus PC discussion...
Last edited by dn83 on Thu Oct 25, 2007 6:56 pm, edited 1 time in total.

dn83
Posts: 218
Joined: Thu Jan 11, 2007 6:06 pm
Location: USA

Post by dn83 » Thu Oct 25, 2007 6:46 pm

icedsushi - what he probably means is that integrated graphics usually have more potential for interference with other components. Nothing to do with actual sound quality...

icedsushi
Posts: 1652
Joined: Wed Jan 12, 2005 8:36 pm

Post by icedsushi » Thu Oct 25, 2007 6:53 pm

hmm...ok, so what kind of non-audio "interference" problems could be possible when using a macbook for audio?

I ask out of curiosity because I'm considering a macbook soon.

dn83
Posts: 218
Joined: Thu Jan 11, 2007 6:06 pm
Location: USA

Post by dn83 » Thu Oct 25, 2007 6:58 pm

Hm well you should be fine with a Mac, I mean, Macs are really geared towards audio and other multimedia, so you're pretty much guaranteed to not have issues like this with a Mac, since Apple knows that so many people use Macs for audio and such...

I just prefer the Windows operating system, so that's why I've gone to PCs again. I guess what I could/should have done was keep my MacBook, put BootCamp on it, and install Windows... =\

samsensual
Posts: 43
Joined: Wed Sep 12, 2007 1:28 pm

Post by samsensual » Thu Oct 25, 2007 7:06 pm

It is always a matter of discussion what one means with his/her words. What kind of crackling was it exactly what you experienced? It sounds very unlikely that all of these notebooks of that size - why should that be the cause for crackeling at all - come with a built-in problem for external audio interfaces, both USB and FW? I don't mean to say you're an idiot and there were no strange sounds, I would only guess it is what I suffer - the ground loop sounds, especially audible when moving the mouse, loading from a disc etc. If you get hold again of one of your testing candidates that made these sounds, try unplugging your A/C adapter. If the sound was exactly like overloading the CPU (the ground loop is [not always] that loud, especially not static) you may say that I tell bullshit :D .

dn83
Posts: 218
Joined: Thu Jan 11, 2007 6:06 pm
Location: USA

Post by dn83 » Thu Oct 25, 2007 7:35 pm

samsensual - yeah, it's hard to tell what the culprit was, it's quite an obscure issue.

The phenomenon was just a single crackle/pop noise in the sound output occasionally. It's like something was interrupting the data stream. It would occur at random, but quite frequently, like every 30 seconds or so.

I could also reproduce it if I resized or moved a window, or launched a 3D screen saver. Maybe it's linked to DirectX somehow? Although, I tried updating DirectX too of course. It just has to be some sort of hardware conflict...?

Besides, even if it were linked to running the laptop off of A/C power, running it off of the battery is an unsatisfactory solution - you could only work as long as the battery lasted...?

rikhyray
Posts: 3644
Joined: Wed Aug 25, 2004 12:13 pm
Contact:

Post by rikhyray » Thu Oct 25, 2007 7:54 pm

Remember to remove anything with the name Norton or Symantec, Sony comes with useless consumer software, you wont need any of it except CD/DVD burning, DVD player and perhaps DV/video transfer utility.

dCross
Posts: 445
Joined: Tue Mar 02, 2004 9:01 pm
Location: Ableton NY
Contact:

Post by dCross » Thu Oct 25, 2007 7:59 pm

I have run a Xone 3D and a Fast Track Pro on my XPS M1210 with no problems at all.
David Cross
Public Media Coordinator
Ableton Inc. (NYC)

cross@ableton.com

Post Reply