Guys at Ableton: Which OS are YOU using?

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
Maxim
Posts: 69
Joined: Mon Feb 04, 2002 2:04 pm

Guys at Ableton: Which OS are YOU using?

Post by Maxim » Thu May 30, 2002 8:14 pm

Just wondering what operating system the Live programmers prefer; Windows; Os9; OSX ??

At the moment i'm having stability problems using Live in OSX. I get audio drop-outs for longer that 1 second. I'm trying another defrag this evening but don't know if it'll work.

-Maxim

ps. system is iBook 600mhz, 512mb

Alex
Posts: 4006
Joined: Wed Apr 03, 2002 1:07 pm
Location: Ableton Headquarter

Post by Alex » Fri May 31, 2002 10:10 pm

Hi Maxim,

there is no general answer for the operating system related question. For myself, I work mostly under Win2000 (PC), sometimes on OS 9.2.2 and OS X (Mac). But from the development point of view I have to work also under Win98, Me and XP.

Often the decision is related to the used audio or midi hardware. Some drivers working better under on Win98, other better on Win2000 and so on...

Currently there are also not much driver available for OS X. I think in a half year and with the release of OS X 10.2 the situation will be better.

So sooner or later the future will be XP (or the XP follower:-))on PC side and OS X on the Mac side.

Concerning to the drop out problem you have. Which audio interface do you use? The internal of the iBook or an external? Do you get the also drop outs for playing just one sample without effects?

Feel free to mail me directly, it's the faster communication way.

regards,
Alex

Maxim
Posts: 69
Joined: Mon Feb 04, 2002 2:04 pm

Post by Maxim » Fri May 31, 2002 10:28 pm

Hi Alex,

Thanks for the quick reply.

Well, I did a defrag again last night (PlusOptimize), and tonight I have played Live all evening without any drop-outs. I think that Live in OSX is very susceptible to fragmentation. Harddisk is full for 50%. I will apply defrag every week now.

I'm using internal audio.

I didn't test for dropout with no-fx. But the drop-outs happened at 30% or 40% cpu usage.

Next time the dropouts occur I'll do some extra tests and will try to reproduce them.

greetz!

Gerald-o

Post by Gerald-o » Sat Jun 01, 2002 5:59 pm

I have also had stability problems ( your same complaints + freezes and program quits)under OSX using sound manager and have sent my crash logs to C. Kleine @ Ableton. I just got a MOTU 828 and switched back to 9.2.2 and the stability seems greatly improved. So far no crashes. Interestingly, I get much better latency performance in OS 9.2.2 using the MOTU 828. This was unexpected since OSX core audio is supposed to be better. It seems MOTU's ASIO drivers are very well designed. I think its a OSX/Sound Manager thing. So, I am finally having fun with LIVE under OS 9.2. I think I will stay away from the bleeding edge until Apple or Ableton figure a few more things out.

Post Reply