LIVE 6 & 7 PERFORMANCE TEST - Results Here

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
Tarekith
Posts: 17332
Joined: Fri Jan 07, 2005 11:46 pm
Location: Ableton Forum Administrator
Contact:

LIVE 6 & 7 PERFORMANCE TEST - Results Here

Post by Tarekith » Tue Dec 04, 2007 7:55 pm

Ableton Live 6 & 7 Performance Test

This test was created to let users compare the performance of Ableton Live versions 6 and 7 on different computer set ups. Prior to Live version 6, this was done via the test located here:

http://www.ableton.com/forum/viewtopic. ... highlight=

However, Live 6 was then optimized to take advantage of the fact that many computers were coming out with dual or quad processors, and the test project above was not truly set up to take advantage of this. Thus the test would not yield consistent results, nor was it always taking advantage of the the enhancements made to support newer Operating Systems or Intel versions of Mac's. This test does take those factors into account however, based upon the following guideline from Ableton:

- Processor load is split between even and odd-numbered tracks and sends. I.E. Track 1 is run on CPU processor 1, Track 2 is run on CPU processor 2, Send 1 is calculated by processor 1, Send 2 is calculated by processor 2, etc.

In addition, the potential CPU load was increased in this project to take advantage of the faster CPU's available today. Many thanks to Globalgoon on the Ableton forums for helping me work out some of the details of this test.


Instructions for the test:

1. Download the test project here:

http://www.djgroovy.com/images/ableton/ ... ceTest.zip

or here:

http://www.boognishrising.com/LivePerformanceTest.zip

2. Set your audio buffer to 512 samples in the Audio Preferences window in Live. The easiest way to do this is to select this field with your mouse and press the Delete Key. (The default is 512 samples).

3. Set Audio Input Device to "No Device", Sample Rate to "44100", and Driver Error Compensation to "0.00ms" in Live's Audio Preferences window. Also, make sure that only one pair of Outputs is active if your soundcard has multiple outs.

Image

Image

4. Begin playback at Locator 1 - "8 Tracks". Allow 16 measures of playback for your Live CPU meter to stabilize. Write down the reading you get after the meter has stabilized.

Image

Image

5. If you computer is not fast enough to play back the full 8 tracks in this test, stop playback, wait a second, and then start playback from Locator 2 - "6 Tracks". Continue trying less and less tracks until you are able to playback for at least 16 measures without drop outs or interruptions to the audio. Make sure to note how many tracks you were playing back if you need to do this step.

6. Post the results of your test on the Ableton Forum in this thread:

http://www.ableton.com/forum/viewtopic. ... 945#593945

Please use the following format, fill in as much information as you can to make the test as worthwhile as possible for others:

1) Ableton Live CPU Meter % (if it bounces around, please list the peak)
2) Laptop/Desktop? Make/Model?
3) Operating System?
4) Ableton Live version?
5) CPU Make, Model, and Speed?
6) Amount of Ram?
7) Soundcard (and driver version if you know it)?
8) Hard Disk Drive Speed (if you know)?
9) Number of playback tracks?

Thanks, and I hope that you find this test useful for comparing different computers!

Tarekith

http://tarekith.com
Last edited by Tarekith on Fri Dec 28, 2007 6:54 pm, edited 4 times in total.

Tarekith
Posts: 17332
Joined: Fri Jan 07, 2005 11:46 pm
Location: Ableton Forum Administrator
Contact:

Post by Tarekith » Tue Dec 04, 2007 8:25 pm

1) Ableton Live CPU Meter: 56%
2) Laptop/Desktop? Make/Model: Laptop, Apple MacBook Pro
3) Operating System: OSX 10.5.1
4) Ableton Live version: Live 6.10
5) CPU Make, Model, and Speed: Core 2 Duo, 2.16gHz
6) Amount of Ram: 2GB
7) Soundcard: MOTU Ultralite, driver 1.4.4
8) Hard Disk Drive Speed: 5400 RPM
9) Number of playback tracks? 8 Tracks

capo-wear-i
Posts: 160
Joined: Sun Dec 31, 2006 4:28 pm

Post by capo-wear-i » Tue Dec 04, 2007 8:41 pm

1) Ableton Live CPU Meter: 56%
2) Laptop/Desktop? Make/Model: Laptop HP NX7400
3) Operating System: Windows XP Sp2
4) Ableton Live version: Live 7.01
5) CPU Make, Model, and Speed: Core 2 Duo, 2.00 Ghz
6) Amount of Ram: 2GB
7) Soundcard: EMU 1616 Cardbus
8) Hard Disk Drive Speed: 5400 RPM Hitachi internal
9) Number of playback tracks? 8 Tracks


The first playback was all over the place (65%-75%) then it settled down to a pretty steady 56%.

EDIT : I had power options set to "portable/laptop" rather than "always on". It's a steady 55 - 56% now :oops:

DJ VAKIS
Posts: 2084
Joined: Sun Oct 31, 2004 7:26 am
Location: MUNICH-GERMANY
Contact:

Post by DJ VAKIS » Tue Dec 04, 2007 9:04 pm

1)AbletonLive CPU Meter:66%to 70%
2)Laptop:macbook pro
3)OSX 10.4.10
4)Live7
5)Core duo 2Ghz
6)Ram:2GB
7)Sound card.Presonus FireBox
8)Hard disc:5400RPM
9)Number of playback tracks:8 Tracks


I will test it again.
Because i was analyzing some mp3's with the mixed in key program,i was runing Live
and mixed in key at the same time.I did the test again only live was runing and i get about 75% to 80%.
I will make the test tomorow again.
Last edited by DJ VAKIS on Tue Dec 04, 2007 9:19 pm, edited 1 time in total.
http://www.myspace.com/djvakis
http://mix2r.fm/audio/user/221


----------------------------------------
MacBookPro 13" Core 2 Duo 2.26Ghz 2GB
Live 8 -Operator -Sampler
AKAI LPD8-GENELEC 1029A-iPhone runing TouchOSC.

parma
Posts: 381
Joined: Tue Mar 02, 2004 11:14 am

Post by parma » Tue Dec 04, 2007 9:07 pm

1) Ableton Live CPU Meter: 30%
2) Desktop, Apple Mac Pro
3) OSX 10.4.11
4) Live 7.0.1
5) Dual-Core Intel Xeon, 2 x 2.66gHz
6) Amount of Ram: 2GB
7) Soundcard: M-Audio Firewire Audiophile (same results with internal card)
8) Hard Disk Drive Speed: 7200 RPM
9) Number of playback tracks? 8 Tracks

jez3122
Posts: 534
Joined: Tue Jan 16, 2007 9:02 pm
Location: Lincs,England
Contact:

Post by jez3122 » Tue Dec 04, 2007 9:13 pm

1) Ableton Live CPU Meter 57% (if it bounces around, please list the peak)
2) Laptop/Desktop? Make/Model? Laptop Toshiba
3) Operating System? Vista
4) Ableton Live version? 7.0.1
5) CPU Make, Model, and Speed? Intel(R)Core 2 Duo 2ghz T7300
6) Amount of Ram? 2Gb
7) Soundcard (and driver version if you know it)? ESI U46 SE
8) Hard Disk Drive Speed (if you know)?
9) Number of playback tracks? 8
Last edited by jez3122 on Tue Dec 04, 2007 9:45 pm, edited 3 times in total.
Live 7.0.16, core 2 Quad 2.66ghz 4 gb ram,ESI U46SE,Vestax VCM-600, M-Audio Axiom 25,
evolution249c,Maudio Xpression pro, various guitars,Akai mpd16, NI intact,YamahaMSP3's,zoom323, a Ukulele and a Crate of Stella.

substance_g
Posts: 486
Joined: Sun Oct 29, 2006 8:30 pm
Location: Berlin
Contact:

Post by substance_g » Tue Dec 04, 2007 9:33 pm

1) Ableton Live CPU Meter:67%
2) Laptop, Apple Powerbook G4
3) OSX 10.4.11
4) Live 7.0.1
5) PowerPC, 1.5GHz
6) Amount of Ram: 1.5GB
7) Soundcard: MOTU Ultralite
8) Hard Disk Drive Speed: 5400RPM
9) Number of playback tracks? 1 Track and remove 3/4 sends to get below 100% CPU

Pretty impressive, I'm sure you'll agree...
MBP-Live7-Oxygen8-Ultralite-UC33e-WaldorfPulse

marsh240sx
Posts: 74
Joined: Tue Oct 04, 2005 5:17 pm
Location: Altamonte Springs, FL
Contact:

Post by marsh240sx » Tue Dec 04, 2007 9:34 pm

1) Ableton Live CPU Meter: 59%
2) Laptop/Desktop? Make/Model: Desktop (custom built)
3) Operating System: WinXP SP2
4) Ableton Live version: Live 6.10
5) CPU Make, Model, and Speed: Core 2 Duo (E6300) 1.86gHz
6) Amount of Ram: 1GB
7) Soundcard: M-Audio Delta 44
8) Hard Disk Drive Speed: 7200rpm sata 300
9) Number of playback tracks? 8 Tracks
Ableton 6.10 on PC; Delta 44 sound card;
Intel Core 2 Duo 1.86ghz; 1gig DDR2 800; 120gig 7200 8meg SATA150 WD and 300gig 7200 16meg SATA300 Seagate; MSI 975X Platinum V.2 MB; UC-33e; Korg Kontrol 49

m:o
Posts: 1321
Joined: Fri Sep 16, 2005 1:48 am
Location: Dreiländereck
Contact:

Post by m:o » Tue Dec 04, 2007 9:56 pm

Holy Moly - I feel soooo outdated :?

1) Ableton Live CPU Meter: 91%
2) Laptop, Acer Travelmate 2350
3) WinXP Pro Sp2
4) Live 7.0.1
5) Intel Celeron M 1,3 Ghz
6) Amount of Ram: 1,2 Gb
7) Soundcard: RME Multiface I
8 ) Hard Disk Drive Speed : 5400 RPM
9) Number of playback tracks? 1 Track

Where is my Core2Duo - i want mine - NOW! :evil:
4770K/Live9Suite/Max4Live/Push/RME UFX/NordModularG2X/Machinedrum SPS1 UW/Elektron Analog Four/MBase11/Adam A7X

http://soundcloud.com/sphereandlowthing

basetwo
Posts: 167
Joined: Mon Oct 25, 2004 11:33 pm
Location: COLORADO

Post by basetwo » Tue Dec 04, 2007 10:04 pm

Can someone do v6 and v7 on the same hardware so we can see the difference? That would be most informative.
The question is not whether or not you are influenced, but rather what it is that influences you.
-----
Gigabyte GA-K8NS Ultra-939/AMD 64
Seagate 80Gb/Samsung 120Gb SATA
1GB RAM/Delta 66/Firebox
32bit WinXP

ernene
Posts: 384
Joined: Wed Jun 16, 2004 3:46 pm
Location: Rome

Post by ernene » Tue Dec 04, 2007 10:09 pm

1 ) Ableton Live CPU Meter % 59
2 ) Laptop/Desktop? Apple iMac
3 ) Operating System? Mac OS X 10.4.11
4 ) Ableton Live version? 7.0.1
5 ) CPU 2.16 GHz Intel Core 2 Duo
6 ) Amount of Ram? 3 GB 667 MHz DDR2 SDRAM
7 ) Soundcard M-AUDIO FW 410 :roll:
8 ) Hard Disk Drive Speed 7200 rpm
9 ) Number of playback 8 tracks
Last edited by ernene on Tue Dec 04, 2007 10:13 pm, edited 1 time in total.

garyboozy
Posts: 2580
Joined: Mon Jul 16, 2007 12:27 pm
Location: UK
Contact:

Post by garyboozy » Tue Dec 04, 2007 10:10 pm

1 ) CPU Meter 67%
2 ) Macbook Pro
3 ) OSX 10.4.11
4 ) Ableton Live 6.0.10
5 ) Intel Core2Duo 2.16ghz
6 ) 2gb memory
7 ) Focusrite Saffire LE
8 ) 5400rpm HD
9 ) tracks: 8

Tarakith, we're pretty much on the same spec machines, so it seems my macbook is running below parr compared to yours - any idea why?

i also tried this with the Live 7b21 and get a 3% increase on Live 6's CPU usage, coming in at 70%
Last edited by garyboozy on Tue Dec 04, 2007 10:17 pm, edited 2 times in total.

Tarekith
Posts: 17332
Joined: Fri Jan 07, 2005 11:46 pm
Location: Ableton Forum Administrator
Contact:

Post by Tarekith » Tue Dec 04, 2007 10:12 pm

Leopard?

R.J.Dubya
Posts: 909
Joined: Tue Dec 12, 2006 6:26 am
Location: Guelph, Ontario.

Post by R.J.Dubya » Tue Dec 04, 2007 10:18 pm

Tarekith wrote:1) Ableton Live CPU Meter: 56%
2) Laptop/Desktop? Make/Model: Laptop, Apple MacBook Pro
3) Operating System: OSX 10.5.1
4) Ableton Live version: Live 6.10
5) CPU Make, Model, and Speed: Core 2 Duo, 2.16gHz
6) Amount of Ram: 2GB
7) Soundcard: MOTU Ultralite, driver 1.4.4
8) Hard Disk Drive Speed: 5400 RPM
9) Number of playback tracks? 8 Tracks
Do you have Live 7 yet?

I'd be interested to see the comparison.
aka glitchrock-buddha
303 posts as Winston

Macbook pro C2D 2.16, Firepod, rubber band and a stick.

garyboozy
Posts: 2580
Joined: Mon Jul 16, 2007 12:27 pm
Location: UK
Contact:

Post by garyboozy » Tue Dec 04, 2007 10:20 pm

Tarekith wrote:Leopard?
woah! if so, thats quite a drop. will investigate...

Post Reply