Clip envelopes annoying, or is it just me?

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
lazlo_funktek
Posts: 62
Joined: Tue Feb 19, 2008 8:06 am
Location: Leeds, UK
Contact:

Clip envelopes annoying, or is it just me?

Post by lazlo_funktek » Sun Feb 24, 2008 9:32 am

I've been having problems with clip envelopes for some time now.

What it is, is that for most things it's great, but for a couple it's really annoying.

For example - sends. Why, when you go to automate a send withina clip does it start you off at 100%, when the send is at zero? It's the same with the dry/wet nob on reverbs.

The only way I've found around this is to turn the sends up full, then automate from there. This is obviously ridiculous, because every time you add a new clip to the track you have to alter the envelopes just to hear it normally. Hardly quick and user friendly.

Am I doing something wrong?

Tom

:?

Ten Square
Posts: 25
Joined: Fri Dec 29, 2006 10:17 am
Location: Montpellier, France
Contact:

Re: Clip envelopes annoying, or is it just me?

Post by Ten Square » Sun Feb 24, 2008 12:38 pm

Clip enveloppes are relative values (%), not absolute ones. That's the reason why when you want to automate a send value using enveloppe inside a clip, it is yet at 100% even if your send knob is at -inf. :?:

So you may ask: relative to what? To the current value of the knob or the fader you are about to automate! Such a mechanism is indeed very practical because it allows you to choose a static value for your send knob, let's say -20dB, and then to automate this value in the range 0% > 100% which corresponds in that case to -inf > -20dB. If during mixing you decide to increase the static value of your send knob, let's say to -13dB, you are allowed to do it without being in conflict with the automation enveloppe because this latter is only relative. And in that case, 0% still corresponds to -inf but now 100% is the same as -13dB! 8O

Note that while you play a clip containing such a send enveloppe, Live shows you (in session view in this example) both the static value of the knob (the little black line inside the circle) and the dynamic changes relatively to that value (in orange over the circle of the knob). :wink:

Hope this will help. :wink:

sinnatagg
Posts: 137
Joined: Sat Mar 19, 2005 7:45 pm
Location: Oslo, Norway
Contact:

Post by sinnatagg » Sun Feb 24, 2008 12:38 pm

It's useful behavior if you're working live and want to control the span of the automation. Annoying if you just want to add an envelope to one clip though.


-a

Robert Henke
Posts: 1193
Joined: Fri Jun 04, 2004 10:38 am
Location: Berlin

Post by Robert Henke » Mon Feb 25, 2008 3:45 am

A bit of inside info regarding this topic: The clip envelope's modulative nature, the fact that you cannot record automation directly into session clips and many other details concerning parameter automation are related to the way Live handles automation data internally. Changing this will become the most complex and time consuming internal change of the Live software ever. We definitely want that change at some point, but currently we are not even sure if it can be done without losing compatibility with older documents in some cases... we are still trying to come up with great ideas for this change. Once it is done we will open some bottles of champagne and we all will be happy. And you can be sure it will be announced BIG. But don't ask me when...

Robert

Tone Deft
Posts: 23565
Joined: Mon Oct 02, 2006 5:19 pm
Location: SF, CA

Post by Tone Deft » Mon Feb 25, 2008 3:57 am

Image




but thanks for the honesty.


you guys can engineer anything, you're German!!!
oddstep wrote:I agree with all of this. I'm just bored of writing "its music, just listen and trust your judgement"

Post Reply