PSP audio plugins

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
Enots
Posts: 102
Joined: Tue Nov 14, 2006 4:02 am

PSP audio plugins

Post by Enots » Tue Apr 15, 2008 5:59 pm

How many people use psp audio plugs in abeleton 7? I'm particularly interested in the mix pack!

Does it work well? What are your experiences?
Christ Jesus is King
www.tonystonebeats.com

morerecords
Posts: 837
Joined: Sun Dec 02, 2007 11:36 pm

Post by morerecords » Tue Apr 15, 2008 6:02 pm

I love the psp 84 + 42, but unfortunatle they are the only plug ins I can think of whose parameters can't be automated in Ableton...The tape warmer is a must ahve though

GUY SMILEY
Posts: 712
Joined: Mon Apr 02, 2007 2:35 am
Location: London, UK
Contact:

Post by GUY SMILEY » Tue Apr 15, 2008 6:05 pm

yeah second that recommendation for the PSP42 and PSP84.

Enots
Posts: 102
Joined: Tue Nov 14, 2006 4:02 am

Post by Enots » Tue Apr 15, 2008 6:35 pm

morerecords wrote:I love the psp 84 + 42, but unfortunatle they are the only plug ins I can think of whose parameters can't be automated in Ableton...The tape warmer is a must ahve though
Cool!

The parameters can't be automated in abe? that's an abe issue exclusively? You're running v 7?
Christ Jesus is King
www.tonystonebeats.com

morerecords
Posts: 837
Joined: Sun Dec 02, 2007 11:36 pm

Post by morerecords » Tue Apr 15, 2008 6:46 pm

Yes Abe 7. They cannot be automated, It seems like aproblem on PSP side, since evey single other 3rd party plug in I own can be automated...
Have only tried with audio units, I can install and try VSTs if it's a deal breaker for you

leedsquietman
Posts: 6659
Joined: Sun Nov 19, 2006 1:56 am
Location: greater toronto area

Post by leedsquietman » Tue Apr 15, 2008 9:38 pm

Master Comp is a superb mastering compressor plugin.

Also Neon is a nice EQ and Vintage Warmer is a nice plugin in certain circumstances.

they make excellent plugins, pity they seem intent on putting them all on Ilok (windows users are free from this if they buy individual plugs but bundles are iloked)
http://soundcloud.com/umbriel-rising http://www.myspace.com/leedsquietmandemos Live 7.0.18 SUITE, Cubase 5.5.2], Soundforge 9, Dell XPS M1530, 2.2 Ghz C2D, 4GB, Vista Ult SP2, legit plugins a plenty, Alesis IO14.

Enots
Posts: 102
Joined: Tue Nov 14, 2006 4:02 am

Post by Enots » Tue Apr 15, 2008 9:55 pm

morerecords wrote:Yes Abe 7. They cannot be automated, It seems like aproblem on PSP side, since evey single other 3rd party plug in I own can be automated...
Have only tried with audio units, I can install and try VSTs if it's a deal breaker for you
Thanks much for this info! I'll scower the site to see if they have downloadable demos that i can try that out myself.

I appreciate it!
Christ Jesus is King
www.tonystonebeats.com

mr.adl
Posts: 861
Joined: Tue Mar 21, 2006 2:02 pm

Post by mr.adl » Wed Apr 16, 2008 6:55 am

Anybody else gets stutter sounds from time to time when holding a knob of any Mixpack2 Plugin for about 3-5 Seconds?

I get them occasionally and can´t figure out why!

It´s really annoying when adjusting the Attack Times of Mixpressor and suddenly it goes DRRRRRRRR.


Anybody experience the same?

I am on Win XP with Live 7.0.3

Bagle
Posts: 786
Joined: Sun Jun 03, 2007 7:45 pm
Location: Ireland
Contact:

Post by Bagle » Mon Apr 21, 2008 5:51 pm

VINTAGE WARMER on everything
put it on everytrack, on the master, busses,
jesus, vintage warm the vintage warmer

then vintage warm that signal too[/quote]
Anything at my disposal..
http://soundcloud.com/jagle

bogh
Posts: 38
Joined: Fri Jul 16, 2004 8:01 am
Location: Denmark
Contact:

Post by bogh » Mon Apr 21, 2008 6:04 pm

Bagle wrote:VINTAGE WARMER on everything
put it on everytrack, on the master, busses,
jesus, vintage warm the vintage warmer

then vintage warm that signal too
Hey, that's what I do!

Bagle
Posts: 786
Joined: Sun Jun 03, 2007 7:45 pm
Location: Ireland
Contact:

Post by Bagle » Mon Apr 21, 2008 10:33 pm

its the only way to get a decent sound haha

then import the bunced track, vintage warm it a few more times, crank it till the slightest sound puts it in the red and hey presto, just call it a glitch song haha
Anything at my disposal..
http://soundcloud.com/jagle

bogh
Posts: 38
Joined: Fri Jul 16, 2004 8:01 am
Location: Denmark
Contact:

Post by bogh » Tue Apr 22, 2008 5:25 am

Bagle wrote:its the only way to get a decent sound haha

then import the bunced track, vintage warm it a few more times, crank it till the slightest sound puts it in the red and hey presto, just call it a glitch song haha
... after which you run it though VW a couple of more times (needless to say) :lol:

musicmachine
Posts: 433
Joined: Mon Sep 11, 2006 3:40 pm

Post by musicmachine » Tue Apr 22, 2008 6:07 am

I have the psp mixpack.Great bundle of plugins.No problems so far but i've only used mix saturator so far in a track.I'm running Live 7.02.Seems like there a few bugs with 7.03 so i'd try them with 7.0205 if it is buggy.
Dell Inspiron 1525|Live 8.03|Akai MPC1000|Waldorf Blofeld||NI AK1|Event TR8s|

Bagle
Posts: 786
Joined: Sun Jun 03, 2007 7:45 pm
Location: Ireland
Contact:

Post by Bagle » Tue Apr 22, 2008 8:06 am

thats strange ive never had any issue with mine any of there products.
but im sure it will be sorted quickly
Anything at my disposal..
http://soundcloud.com/jagle

Post Reply