External Sound Card Freezing Midi ?

Discussion of music production, audio, equipment and any related topics, either with or without Ableton Live
Post Reply
Trypset
Posts: 868
Joined: Mon Jan 21, 2008 2:14 pm
Location: Horticulture Dept., Texas A&M

External Sound Card Freezing Midi ?

Post by Trypset » Tue May 13, 2008 7:01 pm

OK so i have an Edirol Fa-101 setup with my laptop, ableton 6, a korg sampler and a microkorg as well. I think somethin causes the Edirol to freeze when its connected to midi sometimes. It freezes all of ableton and i have to restart everything including MIDI ox.

1. It might be cell phone frequencies, i've noticed it happen around a active cell before.

2. any other ideas to look into>?

three
Posts: 220
Joined: Mon May 12, 2008 2:16 am
Location: secret lair
Contact:

Post by three » Tue May 13, 2008 8:22 pm

Drivers are the biggest nightmare in whole mix. For some reason most companies kinda throw them together as an afterthought.

They're extremely difficult to debug, I don't know if you're a developer but driver bugs will really drive you up the wall.

My recommendation: to to use only the soundcard for a week, and see if it gets better. If it does, you add the other parts back one at a time until you figure out what's knocking over CoreAudio/CoreMIDI,

HTH,

Chris

Trypset
Posts: 868
Joined: Mon Jan 21, 2008 2:14 pm
Location: Horticulture Dept., Texas A&M

Post by Trypset » Wed May 14, 2008 12:25 am

it might be the drivers, i have XP 64-bit and a therefore have experimental 64-bit drivers. It works flawlessy, and sometimes freezes the incoming MIDI light signal in live even when i'm not sending any signals to it. I think its a cell phone, would this cause interference?

Tone Deft
Posts: 24155
Joined: Mon Oct 02, 2006 5:19 pm

Post by Tone Deft » Wed May 14, 2008 12:29 am

it's not your cell phone. that's what the UL label means on that stuff on your sound card and your cell phone.

it's drivers or you're making a midi loop. I think the latter.
In my life
Why do I smile
At people who I'd much rather kick in the eye?
-Moz

Trypset
Posts: 868
Joined: Mon Jan 21, 2008 2:14 pm
Location: Horticulture Dept., Texas A&M

Post by Trypset » Wed May 14, 2008 12:43 am

can you explain on what a midi loop is? I run MIDI I/O from my Korg ES-1 mkII, and a edirol UM-1 I/O for my microkorg. This freezing happens sometimes when no keys are being pressed or notes played.

So if theres only one drivers available i'm screwed into having random blackouts?

Tone Deft
Posts: 24155
Joined: Mon Oct 02, 2006 5:19 pm

Post by Tone Deft » Wed May 14, 2008 1:04 am

connect a midi out to a midi in, then send midi out, it loops back in causing feedback.

seems like you're still pretty green to the scene, sorry, ya gotta pay your dues, spend some time with your gear trying to find the problem. it's not your phone, it might not be the driver.

wish I could help more. most of us have spent hundreds of hours scratching our heads over gear, there's a learning curve, not all the answers are on the internet.
In my life
Why do I smile
At people who I'd much rather kick in the eye?
-Moz

adventurepants_
Posts: 1773
Joined: Tue May 29, 2007 3:05 am

Post by adventurepants_ » Wed May 14, 2008 1:59 am

Trypset wrote:it might be the drivers, i have XP 64-bit and a therefore have experimental 64-bit drivers.
thats where id start looking once youve eliminated the midi loop.

Trypset
Posts: 868
Joined: Mon Jan 21, 2008 2:14 pm
Location: Horticulture Dept., Texas A&M

Post by Trypset » Wed May 14, 2008 8:17 pm

well ok. Thats why i posted is because i have extinguished my knowledge. Isn't that what a forum is for>? I listed specific information for specific gear asking if anyone has run into the same problem. I asked for ideas not a written answer on how to solve the problem. Its replies to post like this that make me not want to be an active part and just read. Thanks for your ideas.

adventurepants_
Posts: 1773
Joined: Tue May 29, 2007 3:05 am

Post by adventurepants_ » Thu May 15, 2008 12:01 am

XP64 is a non consumer OS, so you must know a reasonable amount about computers and troubleshooting. If not, drop to XP32 and watch all of your issues disappear.

Trypset
Posts: 868
Joined: Mon Jan 21, 2008 2:14 pm
Location: Horticulture Dept., Texas A&M

Post by Trypset » Thu May 15, 2008 6:44 pm

is it a possibility that my hardware could have a stuck midi note causing everything else to freeze?

Tone Deft
Posts: 24155
Joined: Mon Oct 02, 2006 5:19 pm

Post by Tone Deft » Thu May 15, 2008 6:49 pm

midi ox and c4 (made by elektron) are both free and will let you monitor midi activity in your DAW, try that.

check your external gear as well, they might be sending clocks or cc data, does it have a light beam or some control that sends continuous CC data?

you'll get there, we've all been thoroughly stuck and pissed off at our DAWs at one point, do that a few hundred times and eventually you learn.
In my life
Why do I smile
At people who I'd much rather kick in the eye?
-Moz

Trypset
Posts: 868
Joined: Mon Jan 21, 2008 2:14 pm
Location: Horticulture Dept., Texas A&M

Post by Trypset » Thu May 15, 2008 10:55 pm

ok the Midi Ox thing is good. I use midi ox to convert my NRPN from my electribe to usable MIDI. When my ableton freezes Midi OX stops recieving midi from whatever device is plugged into the External sound cards MIDI I/O. I have not noticed this problem on gear hooked up via the USB->MIDI adapter. Something in the card is freezing all MIDI causing ableton to freeze with it. I think i will just get a USB to MIDI hub.

Post Reply