Ableton Live 8 Running horribly slow on Mac Pro 8 Core

UHE is now closed. For Technical Support from Ableton, please go here: http://www.ableton.com/support
lanquarem
Posts: 58
Joined: Sun Jul 11, 2004 6:10 pm
Location: Paris, France
Contact:

Re: Ableton Live 8 Running horribly slow on Mac Pro 8 Core

Post by lanquarem » Thu Apr 09, 2009 2:57 pm

Add me to the list of mac users (MacBook Pro 2,2Ghz, 4Gb RAM, 10.5.6) who experience s...l....o...w..l..i...n..e...s....s with Live 8 as soon as I use more than 6 tracks.

Happy to have Live 7 working. I'll wait but what a frustration...

Update : I throwed preferences and verified the authorizations on my hard drive and now everything goes smoothly... Go figure.
Last edited by lanquarem on Thu Apr 23, 2009 2:45 pm, edited 1 time in total.

yannxou
Posts: 148
Joined: Fri Feb 27, 2004 8:39 pm
Location: Barcelona

Re: Ableton Live 8 Running horribly slow on Mac Pro 8 Core

Post by yannxou » Thu Apr 09, 2009 3:32 pm

The bug seems to be related to the window size and the Detail View shown/hidden.

I've done the following test in my Macbook black 2.4ghz / 2GB ram / OSX 10.5.6:

Test#1:
Live 6.0.10 on external monitor (1920x1200) maximized.
1. Open empty live set (standard 1 audio track + 1 midi track).
2. Arm midi track and start recording one blank clip (no need to record notes). Show Detail View.
3. Activity Monitor shows Live eating 10% cpu. Live meter 2%.

Test#2:
Live 8.0.1 on external monitor (1920x1200) maximized.
1. Open empty live set (standard 1 audio track + 1 midi track).
2. Arm midi track and start recording one blank clip (no need to record notes). Show Detail View.
3. Activity Monitor shows Live eating 96% cpu. Live meter 1%.

Test#3:
Live 8.0.1 on external monitor (1920x1200) maximized.
1. Open empty live set (standard 1 audio track + 1 midi track).
2. Arm midi track and start recording one blank clip (no need to record notes). Hide Detail View.
3. Activity Monitor shows Live eating 30-40% cpu. Live meter 1%.

Test#4:
Live 8.0.1 on external monitor. Window resized to aprox 960x600.
1. Open empty live set (standard 1 audio track + 1 midi track).
2. Arm midi track and start recording one blank clip (no need to record notes). Show Detail View.
3. Activity Monitor shows Live eating 20-30% cpu. Live meter 1%.

I hope this issue gets fixed soon. Thanks!
Live 9 Suite / MaxForLive / MacBook Black 2.4Ghz / 4Gb RAM / OSX 10.7.5 / Motu828 mk1 / MicroKONTROL / Midisport 4x4 / Korg Kaoss Pad II / Nocturn / Wiimote.

cids
Posts: 482
Joined: Fri Jul 16, 2004 5:53 pm
Location: Amsterdam, Netherlands

Re: Ableton Live 8 Running horribly slow on Mac Pro 8 Core

Post by cids » Thu Apr 09, 2009 6:08 pm

Hi did your test on my Mac.

Between 10 and 13% with "hide detail"
Around 25% with "show detail"

Live CPU util. is 1% in both cases, no idea if this is normal behaviour, performance of Live 8 is fine on my system, no issues.
Mac mini 6-core

Genelec M030; Live 10.1; macOS 10.15

Ableton Push 2

yannxou
Posts: 148
Joined: Fri Feb 27, 2004 8:39 pm
Location: Barcelona

Re: Ableton Live 8 Running horribly slow on Mac Pro 8 Core

Post by yannxou » Thu Apr 09, 2009 6:23 pm

cids wrote:Hi did your test on my Mac.

Between 10 and 13% with "hide detail"
Around 25% with "show detail"

Live CPU util. is 1% in both cases, no idea if this is normal behaviour, performance of Live 8 is fine on my system, no issues.
And did you try at 1920x1200? Because mine goes to 95%! It's weird and I don't know what else to try...

I've seen yours is a Macbook pro. Do you think it could be related to the dedicated vs integrated graphics card?

Or could there be something related to previous installed beta versions? I deleted the beta directory but don't know if some setting can affect to this behaviour...
Live 9 Suite / MaxForLive / MacBook Black 2.4Ghz / 4Gb RAM / OSX 10.7.5 / Motu828 mk1 / MicroKONTROL / Midisport 4x4 / Korg Kaoss Pad II / Nocturn / Wiimote.

gunforhire
Posts: 62
Joined: Thu Jan 29, 2009 4:55 pm

Re: Ableton Live 8 Running horribly slow on Mac Pro 8 Core

Post by gunforhire » Thu Apr 09, 2009 7:56 pm

I'm having serious performance issues on my PC as well - I'm running a core 2 quad (Q6600) overclocked to 3GHZ and the projects that I were running during the beta at about 30% cpu usage now sometimes get as high as 70%, in some cases even above the limit of 100%.

maxmin
Posts: 27
Joined: Sat Mar 01, 2008 10:41 am
Contact:

Re: Ableton Live 8 Running horribly slow on Mac Pro 8 Core

Post by maxmin » Thu Apr 09, 2009 8:31 pm

yannxou wrote:The bug seems to be related to the window size and the Detail View shown/hidden.
Exactly. What a weird bug. Live 8 is running fine as long as the window size does not exceed about 1000px width. Crazy crazy bug.
Max Min | I make songs at http://www.hellomaxmin.com

cids
Posts: 482
Joined: Fri Jul 16, 2004 5:53 pm
Location: Amsterdam, Netherlands

Re: Ableton Live 8 Running horribly slow on Mac Pro 8 Core

Post by cids » Thu Apr 09, 2009 11:23 pm

I'm using 1920 x 1200 but I did the test on my Mac Pro, not on my MacBook Pro...
Mac mini 6-core

Genelec M030; Live 10.1; macOS 10.15

Ableton Push 2

Piccolo Tigre
Posts: 14
Joined: Tue Aug 14, 2007 1:56 pm
Location: paris, france

Re: Ableton Live 8 Running horribly slow on Mac Pro 8 Core

Post by Piccolo Tigre » Thu Apr 23, 2009 2:29 pm

Same here, but i'on a a PC.

K.

cids
Posts: 482
Joined: Fri Jul 16, 2004 5:53 pm
Location: Amsterdam, Netherlands

Re: Ableton Live 8 Running horribly slow on Mac Pro 8 Core

Post by cids » Thu Apr 23, 2009 4:57 pm

@ Adey: Just did a test with Sylenth (VST), 6 playing tracks gives me 7% CPU util in Live, 14 playing tracks gives me 13/14% util. Are you using AU or VST?
Mac mini 6-core

Genelec M030; Live 10.1; macOS 10.15

Ableton Push 2

STERIO
Posts: 3
Joined: Mon Oct 08, 2007 11:10 pm
Location: USA
Contact:

Re: Ableton Live 8 Running horribly slow on Mac Pro 8 Core

Post by STERIO » Mon Apr 27, 2009 9:39 pm

Damn it Ableton.... Still waiting on an email back on this issue, and a fix. Been working within Live 7 still!!!
((( [>STERIO <] )))

myspace.com/listeninsterio

mofus
Posts: 15
Joined: Mon Jan 26, 2009 11:17 am

Re: Ableton Live 8 Running horribly slow on Mac Pro 8 Core

Post by mofus » Sat May 02, 2009 10:58 pm

has anyone tried turning off hyperthreading on their nehalem mac pro's to see if thats it?

http://www.gearslutz.com/board/4044777-post102.html

br
Anders

cids
Posts: 482
Joined: Fri Jul 16, 2004 5:53 pm
Location: Amsterdam, Netherlands

Re: Ableton Live 8 Running horribly slow on Mac Pro 8 Core

Post by cids » Sat May 02, 2009 11:24 pm

As far as I'm concerned, Live 8 runs fine on my Nehelam Mac Pro...
Mac mini 6-core

Genelec M030; Live 10.1; macOS 10.15

Ableton Push 2

mofus
Posts: 15
Joined: Mon Jan 26, 2009 11:17 am

Re: Ableton Live 8 Running horribly slow on Mac Pro 8 Core

Post by mofus » Sun May 03, 2009 4:38 pm

I just tried to disable hyperthreading and play around with the settings of my nehalem mac pro.
I got the best results using only 2 cores and no hyperthreading.

Hope that Apple will make it ease for Ableton and others to really harnest the power of these machines in snow leopard.
Cause it feels a bit stupid that my machine runs at its best when its only using, in theory, 1/8 of its potiential.

My specs are;
Nehalem 8 core 2.26ghz
12 GB ram
RME HDSPe MADI soundcard

Btw, I have the same problems in Cubase as I do in Live.

Happy sunday to all of you 8)

cids
Posts: 482
Joined: Fri Jul 16, 2004 5:53 pm
Location: Amsterdam, Netherlands

Re: Ableton Live 8 Running horribly slow on Mac Pro 8 Core

Post by cids » Sun May 03, 2009 4:45 pm

Hi Mofus, what kind of issues do you have? You can always send me a test Live set to see the results on my Mac Pro?
Mac mini 6-core

Genelec M030; Live 10.1; macOS 10.15

Ableton Push 2

mofus
Posts: 15
Joined: Mon Jan 26, 2009 11:17 am

Re: Ableton Live 8 Running horribly slow on Mac Pro 8 Core

Post by mofus » Mon May 04, 2009 10:56 am

I am getting very poor performance compared to my "old" 2008 mac pro that was an eight core 2.8ghz.
I have problems reaching lower latencies than 512/1024 samples with a decent amount of plugins.

One session I am running now has 11 tracks and around 30 mixed plugins. That consumes 83% of the CPU with hyper threading enabled. This is with a buffer size of 1024 samples. This takes only around 35% if I go down to two processors and no hypertheading.

Same problem in cubase, I cant even go below a buffersize of 256 if I have 5-10 tracks with no plugins on them.

This machine seems to be a bad choice for a daw machine until snow leopard makes hyper threading more usable.

Locked