8.0.4 search freeze bug

UHE is now closed. For Technical Support from Ableton, please go here: http://www.ableton.com/support
Locked
Nokatus
Posts: 1064
Joined: Fri Jul 01, 2005 7:06 am

8.0.4 search freeze bug

Post by Nokatus » Sat Sep 12, 2009 9:46 pm

When working on a project and wanting to quickly use a plugin, writing a part of the plugin name into the search box - but accidentally searching in the Live library instead of the plugin view... You slap your head, exclaim a suitable curse, and go get a cup of coffee/tea, as you know you can't use Live in a long while.

Searching from the library, Live freezes for a long, long time, and there's no way of stopping the search while it's running.

This is a long way of saying "you can't search anything from the library, as it takes ages and you can't stop the search" :P ... I've got to pass the time somehow, as Live is doing this right now.

I have seen this more than once, and yeah, currently as I'm writing this, Live has been sitting for eleven minutes on my Q6600 machine already, rinsing the HD doing the "search" and not reacting to any input.

Edit: getting near half an hour already :roll:

Edit #2: okay, I let it run its course. Took a sweet while. Now the search index is said to be up to date, and when ever I do a search like this, it doesn't cut off input from the user any more. The search takes a reasonable time, and I can just stop the search when ever I feel like it. Because of this, I suspect I have never let it run through the process because it has always looked like the program was just hanging, not accepting any input or showing any kind of progress bar, and sitting there for tens of minutes.

Conclusion: the index updating process should most definitely be handled and presented in a different manner, even when (and especially when) it's being done for the first time. If this is the common way Live's index building works, people using Live for the first time after installation are going to sit for something like 30-60 minutes without any ability to stop the process or do anything else inside Live, with no indication of the progress.

alen milivojevic
Posts: 29
Joined: Fri Jun 26, 2009 6:41 pm
Location: Mostar
Contact:

Re: 8.0.4 search freeze bug

Post by alen milivojevic » Tue Sep 15, 2009 10:28 am

Nokatus wrote:When working on a project and wanting to quickly use a plugin, writing a part of the plugin name into the search box - but accidentally searching in the Live library instead of the plugin view... You slap your head, exclaim a suitable curse, and go get a cup of coffee/tea, as you know you can't use Live in a long while.

Searching from the library, Live freezes for a long, long time, and there's no way of stopping the search while it's running.

This is a long way of saying "you can't search anything from the library, as it takes ages and you can't stop the search" :P ... I've got to pass the time somehow, as Live is doing this right now.

I have seen this more than once, and yeah, currently as I'm writing this, Live has been sitting for eleven minutes on my Q6600 machine already, rinsing the HD doing the "search" and not reacting to any input.

Edit: getting near half an hour already :roll:

Edit #2: okay, I let it run its course. Took a sweet while. Now the search index is said to be up to date, and when ever I do a search like this, it doesn't cut off input from the user any more. The search takes a reasonable time, and I can just stop the search when ever I feel like it. Because of this, I suspect I have never let it run through the process because it has always looked like the program was just hanging, not accepting any input or showing any kind of progress bar, and sitting there for tens of minutes.

Conclusion: the index updating process should most definitely be handled and presented in a different manner, even when (and especially when) it's being done for the first time. If this is the common way Live's index building works, people using Live for the first time after installation are going to sit for something like 30-60 minutes without any ability to stop the process or do anything else inside Live, with no indication of the progress.
i have exactly the same problem mate!! you say that i should let it search for about 30-60 minutes for the first time, and then it will be ok?? please explain.
thanks in advance!
Pornographic Recordings, 1605 Music Therapy, InterTech

Nokatus
Posts: 1064
Joined: Fri Jul 01, 2005 7:06 am

Re: 8.0.4 search freeze bug

Post by Nokatus » Tue Sep 15, 2009 2:36 pm

alen milivojevic wrote:i have exactly the same problem mate!! you say that i should let it search for about 30-60 minutes for the first time, and then it will be ok??
Yep, it needs to do a HUGE index update the first time you run it, and after that it seems to be just fine. The problem is, it gets totally unresponsive during that first update, not showing any progress bar, not reacting to keyboard/mouse... Even stopping screen redraws, showing plain white bars instead of the menubar etc.

If it was planned to work like this, I think it's still pretty much a bug.

So yeah, make sure you don't have any other HD load going at the same time (like having the project playing), start a library search and go have a cuppa :) ... After a (long) while it should be ok from that point on. Might even take longer than an hour, depending on your setup, as it took this long on a Q6600 machine with a brand new SATA drive.

jok
Posts: 1412
Joined: Tue Apr 24, 2007 2:56 pm
Location: Ableton Headquarters
Contact:

Re: 8.0.4 search freeze bug

Post by jok » Tue Sep 15, 2009 3:40 pm

Hi guys,

that sounds strange: rescanning/rebuilding the index should not take that long normally, it should also be possible to stop the process anytime by clicking 'x' (works fine over here). Please contact support@ableton.com with your specs and log.txt, see: http://www.ableton.com/pages/support/co ... al_support

Best,
Jörg
ableton support team
support@ableton.com

alen milivojevic
Posts: 29
Joined: Fri Jun 26, 2009 6:41 pm
Location: Mostar
Contact:

Re: 8.0.4 search freeze bug

Post by alen milivojevic » Tue Sep 15, 2009 4:40 pm

jok wrote:Hi guys,

that sounds strange: rescanning/rebuilding the index should not take that long normally, it should also be possible to stop the process anytime by clicking 'x' (works fine over here). Please contact support@ableton.com with your specs and log.txt, see: http://www.ableton.com/pages/support/co ... al_support

Best,
Jörg
of course it is strange, but i have done what he said and it is all fine now!! thanks!
Pornographic Recordings, 1605 Music Therapy, InterTech

chaircrusher
Posts: 89
Joined: Fri Dec 03, 2004 7:54 pm

Re: 8.0.4 search freeze bug

Post by chaircrusher » Sun Sep 27, 2009 10:13 pm

jok wrote:Hi guys,

that sounds strange: rescanning/rebuilding the index should not take that long normally, it should also be possible to stop the process anytime by clicking 'x' (works fine over here). Please contact support@ableton.com with your specs and log.txt, see: http://www.ableton.com/pages/support/co ... al_support

Best,
Jörg
This is still a problem in 8.0.5 and no, the x doesn't work. In XP, the title bar changes to 'Untitled - Live 8 (Not responding)'

I've had it happen on my desktop and my laptop. Really f*cking annoying. It's not like it's some exotic thing, either -- my machines are as close to vanilla xp machines as possible.

Milkster
Posts: 1
Joined: Sun Jan 17, 2010 11:17 pm

Re: 8.0.4 search freeze bug

Post by Milkster » Sun Jan 17, 2010 11:18 pm

This is still a problem in 8.1

tomfoolery
Posts: 27
Joined: Wed Nov 07, 2007 10:16 am
Contact:

Re: 8.0.4 search freeze bug

Post by tomfoolery » Fri Feb 26, 2010 8:19 pm

having this problem on my mac as well. every search. it eventually becomes responsive again after 10 min or more. I am on a macbook pro with a 150gig drive. I let it sit overnight last night and it still has not finished the search processes.
http://myspace.com/djtomfoolery
macbook pro 2.4 intel 2 duo, 4 gig ram, motu 828mkii

zeepster
Posts: 310
Joined: Thu Sep 27, 2007 2:03 pm

Re: 8.0.4 search freeze bug

Post by zeepster » Fri Feb 26, 2010 9:37 pm

Same problem on 8.1.1
XP SP2

Abes, when doing the search for the first time, what index is building where please?

Good luck fixing btw ;)

tomfoolery
Posts: 27
Joined: Wed Nov 07, 2007 10:16 am
Contact:

Re: 8.0.4 search freeze bug

Post by tomfoolery » Sat Feb 27, 2010 7:13 am

my search wheels are still spinning going on 24 hours. I have functionality as long as i don't run another search but i have 2 going since last night.
http://myspace.com/djtomfoolery
macbook pro 2.4 intel 2 duo, 4 gig ram, motu 828mkii

blastique
Posts: 180
Joined: Wed Nov 23, 2005 7:52 pm
Location: Kuala Lumpur, Malaysia

Re: 8.0.4 search freeze bug

Post by blastique » Mon May 10, 2010 5:25 am

Are there any updates on this issue? It's alright after the first search (taking about 2 - 3 mins on my 160gb external I am usually searching on during DJ gigs), but it seems to rebuild the index every time I restart Live (especially annoying right before a show the following night!) On 8.1.3 at the moment but can remember it being an issue since 8.0.4. All my control devices remain responsive (incl. APC40). The only things are that nothing updates on the screen and the gui is effectively frozen during this period.
milehighsounds.com | blastique.com
Ableton Certified Trainer
Malaysia

soundcloud.com/blastique

deanbigbee
Posts: 3
Joined: Tue Jun 29, 2010 4:32 am

Re: 8.0.4 search freeze bug

Post by deanbigbee » Tue Jun 29, 2010 4:32 am

Same problem here.. have had it for a long time. Ableton freezes on search. Win7 64bit

Locked