"Old" pluggo plug-ins incompatible with Live 8.1

UHE is now closed - please head to http://ableton.com/answers for help from other users.
For Technical Support from Ableton, please go here: http://www.ableton.com/support
.at/on
Posts: 29
Joined: Wed Jun 24, 2009 8:52 am

"Old" pluggo plug-ins incompatible with Live 8.1

Post by .at/on » Wed Nov 25, 2009 8:26 pm

I cannot open "old" pluggo plugins after I installed Live 8.1 and max 5 version.
Can't you provide information about how can I use old pluggo plugins with Live8.1?
Will max4live be compatible with old pluggo?

kleine
Posts: 1850
Joined: Sat Dec 15, 2001 11:46 am
Location: ableton
Contact:

Re: "Old" pluggo plug-ins incompatible with Live 8.1

Post by kleine » Wed Nov 25, 2009 9:28 pm

Hello

Pluggo is already integrated, normal "old" pluggo´s won´t work.
See also http://cycling74.com/2009/05/14/pluggo- ... -for-live/

Best,
Christian

.at/on
Posts: 29
Joined: Wed Jun 24, 2009 8:52 am

Re: "Old" pluggo plug-ins incompatible with Live 8.1

Post by .at/on » Wed Nov 25, 2009 10:07 pm

kleine wrote:Hello

Pluggo is already integrated, normal "old" pluggo´s won´t work.

Best,
Christian
But what about plugins that were not in pluggo pack?
There was a lot of plugins that was created in max4 and saved as pluggo... It is very disappointing...

Even future releases of Live8.1 will not support them?

kleine
Posts: 1850
Joined: Sat Dec 15, 2001 11:46 am
Location: ableton
Contact:

Re: "Old" pluggo plug-ins incompatible with Live 8.1

Post by kleine » Wed Nov 25, 2009 10:24 pm

Hello,

Pluggos should work in the normal Live version but in order to make them work in Max for Live,
they need to be recoded. Pluggo is discontinued.

Best,
Christian

beubbo
Posts: 52
Joined: Mon Jan 23, 2006 2:52 am

Re: "Old" pluggo plug-ins incompatible with Live 8.1

Post by beubbo » Thu Nov 26, 2009 9:37 pm

kleine wrote:Hello,

Pluggos should work in the normal Live version but in order to make them work in Max for Live,
they need to be recoded. Pluggo is discontinued.

Best,
Christian
Hi,

Could you please explain what is exactly a "normal" Live version ?

I own Live 8 Suite and am still on v8.0.9, just about to update to v8.1, but if support of plug-ins like Cycling74, Tritone Digital (web site down ATM) is dropped... mmmh, could be a BIG prob. :| especially for mixes in progress...

IOW, is it possible to install v8.1 - without Max4Life - and still be able to use "old" Pluggo plug-ins with ?

Thanks.
B

jon_moore
Posts: 320
Joined: Thu Oct 23, 2008 4:50 pm

Re: "Old" pluggo plug-ins incompatible with Live 8.1

Post by jon_moore » Thu Nov 26, 2009 10:51 pm

kleine wrote:Hello,

Pluggos should work in the normal Live version but in order to make them work in Max for Live,
they need to be recoded. Pluggo is discontinued.

Best,
Christian
Another fine example of great customer care from Ableton. I'm not sure if it's just a case of English not being not being a first language but he word the phrase 'unfortunately Pluggo is discontinued' just might have been a bit more palatable. This is simple stuff surely... :(
JM

http://leftside-wobble.blogspot.com/

MacBook Pro 2.8 (10.5.6)

.at/on
Posts: 29
Joined: Wed Jun 24, 2009 8:52 am

Re: "Old" pluggo plug-ins incompatible with Live 8.1

Post by .at/on » Fri Nov 27, 2009 5:49 am

Yeah this is very sad.
I noticed that it was a lot of trouble with pluggo in live8 since release.

Some plugins crashes all the time (f.e. Tritone Digital) and ableton support did nothing about it.
They just said that "we change plug-in handling, and you should write to pluggo plug-in support". But really such problem is only in ableton live 8.

Why should I care about "plug-in handling" or incompatibility old features after new features were added???


BTW here similar topics
http://cycling74.com/forums/topic.php?id=23048
http://cycling74.com/forums/topic.php?id=23029

kleine
Posts: 1850
Joined: Sat Dec 15, 2001 11:46 am
Location: ableton
Contact:

Re: "Old" pluggo plug-ins incompatible with Live 8.1

Post by kleine » Fri Nov 27, 2009 7:07 am

Hello,

It turned out that there is currently a problem using older pluggo technology (Hipno is affected as well) - we´re investigating.
Sorry for the inconvenience!

Christian

dnigrin
Posts: 32
Joined: Sat Mar 03, 2007 12:52 am

Re: "Old" pluggo plug-ins incompatible with Live 8.1

Post by dnigrin » Sun Nov 29, 2009 2:25 am

Yes, this is a major problem for me, as a developer that sold/continues to sell Pluggo-based plugins. Hopefully there can be a way to temporarily disable MFL functionality within Live 8.1 to allow these plugins to work? There are *lots* of Pluggo-based plugins out there (commercial and free) that have nothing to do with the "Pluggo" set of plugins that Cycling sold.

Thanks for looking into it...

Dan
Dan Nigrin
Defective Records
Klee Sequencer / MC-202 Hack / Jack OS X / Major Malfunction / PC-1600 User
http://www.defectiverecords.com
http://www.jackosx.com

beubbo
Posts: 52
Joined: Mon Jan 23, 2006 2:52 am

Re: "Old" pluggo plug-ins incompatible with Live 8.1

Post by beubbo » Sun Nov 29, 2009 5:42 pm

beubbo wrote:
kleine wrote:Hello,

Pluggos should work in the normal Live version but in order to make them work in Max for Live,
they need to be recoded. Pluggo is discontinued.

Best,
Christian
Hi,

Could you please explain what is exactly a "normal" Live version ?

I own Live 8 Suite and am still on v8.0.9, just about to update to v8.1, but if support of plug-ins like Cycling74, Tritone Digital (web site down ATM) is dropped... mmmh, could be a BIG prob. :| especially for mixes in progress...

IOW, is it possible to install v8.1 - without Max4Life - and still be able to use "old" Pluggo plug-ins with ?

Thanks.
B
Anyone ?!

jon_moore
Posts: 320
Joined: Thu Oct 23, 2008 4:50 pm

Re: "Old" pluggo plug-ins incompatible with Live 8.1

Post by jon_moore » Sun Nov 29, 2009 6:08 pm

beubbo wrote:
beubbo wrote:
kleine wrote:Hello,

Pluggos should work in the normal Live version but in order to make them work in Max for Live,
they need to be recoded. Pluggo is discontinued.

Best,
Christian
Hi,

Could you please explain what is exactly a "normal" Live version ?

I own Live 8 Suite and am still on v8.0.9, just about to update to v8.1, but if support of plug-ins like Cycling74, Tritone Digital (web site down ATM) is dropped... mmmh, could be a BIG prob. :| especially for mixes in progress...

IOW, is it possible to install v8.1 - without Max4Life - and still be able to use "old" Pluggo plug-ins with ?

Thanks.
B
Anyone ?!
I've tested in 8.09 and my Pluggo's work (DrMS & Colortone). I also have MaxForLive installed as part of my 8.1 installation but the crippling effect doesn't seem to effect older versions.

Hope this helps
JM

http://leftside-wobble.blogspot.com/

MacBook Pro 2.8 (10.5.6)

Machinesworking
Posts: 11068
Joined: Wed Jun 23, 2004 9:30 pm
Location: Seattle

Re: "Old" pluggo plug-ins incompatible with Live 8.1

Post by Machinesworking » Sun Nov 29, 2009 8:07 pm

kleine wrote:Hello,

It turned out that there is currently a problem using older pluggo technology (Hipno is affected as well) - we´re investigating.
Sorry for the inconvenience!

Christian
Wow? That's really bad. So as an old Pluggo set owner on Live 7, I'm not about to upgrade until I hear they're stable.
Every time I think of jumping to 8, some new bug emerges that keeps me on 7, this one is pretty horrible, just found out that Pluggo users get a whopping $49 dollars off of M4L,(an insult really) and now if I just upgrade Live to 8, Pluggo is hosed. Honestly why this wasn't caught in the beta testing is pretty much a mystery to me? Wouldn't this be pretty much the first set of VSTs to test as they'd be most likely to have issues with M4L enabled Live?

kleine
Posts: 1850
Joined: Sat Dec 15, 2001 11:46 am
Location: ableton
Contact:

Re: "Old" pluggo plug-ins incompatible with Live 8.1

Post by kleine » Sun Nov 29, 2009 11:23 pm

Pluggo is old and discontinued technology - Cycling 74 does not develop it anymore.
As for Live 8.1, you can either use M4L or Pluggo but not both.
This conflict is one of the many problems that caused Cycling74 to give up on trying to
support Pluggo. Still, there´s a current problem with Live 8.1 and
Pluggo which is investigated at the moment.
M4L has nothing to do with VST´s/Pluggo technology.

Best,
Christian

Machinesworking
Posts: 11068
Joined: Wed Jun 23, 2004 9:30 pm
Location: Seattle

Re: "Old" pluggo plug-ins incompatible with Live 8.1

Post by Machinesworking » Mon Nov 30, 2009 6:14 pm

kleine wrote:Pluggo is old and discontinued technology - Cycling 74 does not develop it anymore.
OK that's a little off putting. Pluggo was discontinued at the same time that M4L came out, old as in last summer, not as in
5 years ago. I realize last year is 7 dog years in software though. :lol:
As for Live 8.1, you can either use M4L or Pluggo but not both.
OK cool, but that's even more disapointing as far as upgrading, any plug ins in Pluggo that don't make it to M4L are history. :(
This conflict is one of the many problems that caused Cycling74 to give up on trying to
support Pluggo. Still, there´s a current problem with Live 8.1 and
Pluggo which is investigated at the moment.
M4L has nothing to do with VST´s/Pluggo technology.

Christian, you contradict your previous statement, or I'm not understanding? correct me if I'm wrong?
I think this is what you meant?

1. 8.1 currently has problems with Pluggo regardless of whether you have M4L instaled. That will be fixed.

2. There will always be conflicts with Pluggo and M4L, like you said, it's one of the reasons Cycling dropped Pluggo.

Like I said before I'm a little disappointed in the crossgrade discount to M4L for Pluggo users. Cycling pretty much admitted that the product had problems, and it wasn't a cheap plug in. It was buggy as hell for years. Using it in OS9 was like walking a tightrope. Funny that once it stabilized on my system, they discontinue it. :(

kleine
Posts: 1850
Joined: Sat Dec 15, 2001 11:46 am
Location: ableton
Contact:

Re: "Old" pluggo plug-ins incompatible with Live 8.1

Post by kleine » Mon Nov 30, 2009 7:19 pm

Hello,

Here are my answers:
1. Pluggo has a problem with Live 8.1 or vice versa - we´re investigating.
2. If you use M4L you´ll always have conflicts with Pluggo.

Best
Christian

Locked