Ableton 8.1 and Behringer bcr2000 on Mac

UHE is now closed. For Technical Support from Ableton, please go here: http://www.ableton.com/support
Locked
mattb
Posts: 19
Joined: Fri Aug 30, 2002 12:17 pm

Ableton 8.1 and Behringer bcr2000 on Mac

Post by mattb » Fri Nov 27, 2009 4:09 pm

Hi
Matt from Coldcut here, working on a new mix!

I am trying to use the bcr2000 with Live to control plugins. I have it selected as a control surface, and also selected it for Input and Output Remote in Midi prefs. I can assign knobs and buttons on the controller to parameters in Live no problem. But the controller doesnt update its knobs position /leds correctly ...if I record some knob moves and play them back, the plugin params change fine in Live, but the leds dont move. What am I doing wrong?

Does DUMP work from Control Surfaces to set up the bcr2000?? I tried it but it didnt seem to do anything.

The annoying thing is , it was working! Then something changed, and now it doesnt. Maybe DUMP messed it up?

I think Live is sending messages to the bcr because the key/midi out indictaor is flashing. I noted the params I am controlling Live have little red arrows on them, dont know what this means?

I see the BC manager mentioned a lot, but it doesnt work on Mac..

Thanks for any help.

daveberger
Posts: 19
Joined: Thu Sep 13, 2007 11:37 pm
Location: UK

Re: Ableton 8.1 and Behringer bcr2000 on Mac

Post by daveberger » Thu Jan 21, 2010 10:02 pm

I've got similar problems with exactly the same setup (Live 8.1, Intel Macbook, 10.5.8)

I managed to get everything to work but if I don't send any signals from the BCR2000 (as in, if I don't touch any of the knobs) for about 2 minutes, the whole thing stops working. Ableton can still see the controller, it comes up in the list of active MIDI devices (the botton bit of the MIDI preferences window) but Ableton stops receiving any MIDI messages.

If I then turn the BCR2000 off and back on or unplug/replug the USB cable it works again, until I leave it for too long.

Proper weird.

Anyone?

Dave

daveberger
Posts: 19
Joined: Thu Sep 13, 2007 11:37 pm
Location: UK

Re: Ableton 8.1 and Behringer bcr2000 on Mac

Post by daveberger » Thu Jan 21, 2010 10:04 pm

Also, if I press DUMP, the controller goes into some kind of preset mode, with pre-assigned functions for the knobs. Which is at least something but I haven't managed to get it to work reliably either so...

8O
Posts: 5502
Joined: Fri Mar 28, 2008 9:29 am
Location: Berlin

Re: Ableton 8.1 and Behringer bcr2000 on Mac

Post by 8O » Thu Jan 21, 2010 10:24 pm

Hi,

Dunno on the BCR, sorry, but...
mattb wrote:...I noted the params I am controlling Live have little red arrows on them, dont know what this means?
If you record automation to the parameters, afterwards each parameter that was changed is marked with a little red dot (think it's called a red LED in the manual), to indicate that control is now automated. Maybe that's what you're seeing...?
Image

daveberger
Posts: 19
Joined: Thu Sep 13, 2007 11:37 pm
Location: UK

Re: Ableton 8.1 and Behringer bcr2000 on Mac

Post by daveberger » Sat Jan 23, 2010 9:40 pm

check this out

http://www.erolalkan.co.uk/forum/viewtopic.php?id=7918

the guy says use sack off the USB lead and use it with MIDI leads, the old way.I tried it and so far it seems to work. pretty rubbish though. i just bought the launchpad...

Locked