Am I going mad? Notes stopping after note off no matter what

UHE is now closed. For Technical Support from Ableton, please go here: http://www.ableton.com/support
Badger123
Posts: 82
Joined: Sun Sep 09, 2007 3:48 pm
Location: Bristol, UK
Contact:

Am I going mad? Notes stopping after note off no matter what

Post by Badger123 » Fri Oct 15, 2010 10:59 pm

In operator I can't get any instrument patch to have a release time using my midi keyboard controller. No matter where I set the release time, all sound stops instantly on release of the key. When using the computer keyboard notes ring on according to release time settings as expected. Midi controlled notes have no sound after key off message?

I remember having this problem before and solving it somehow getting ableton to snap out of behaving oddly but I can't get out of this glitch now.

Has anyone else had this problem?

Ta for your time

ShelLuser
Posts: 4030
Joined: Sun Dec 06, 2009 10:26 pm
Location: Wageningen, Netherlands

Re: Am I going mad? Notes stopping after note off no matter what

Post by ShelLuser » Fri Oct 15, 2010 11:36 pm

Never had this problem before. Sounds to me as if you should double check your midi configuration.
With kind regards,

Peter

Using the 'Power' Trio: Live 10 Suite (+ Push & Max 8 ), Reason 10 and Maschine Mk3 (+ the ultimate Komplete 12).
Blog: SynthFan (under heavy construction!)

southsounder
Posts: 98
Joined: Sun Oct 17, 2010 2:31 am
Location: Olympia

Re: Am I going mad? Notes stopping after note off no matter what

Post by southsounder » Sun Oct 17, 2010 2:55 am

You're not going mad, or if you are you're not alone as I too have noticed the same problem.

Not sure how it could be related to a user's midi configuration. Release time is supposed to start at note-off. If all active volume envelopes have been assigned lengthy release times and all sound still stops instantly upon receiving the note-off message, operator is not following it's assigned release times.

I've found that Sampler also has this problem. Analog, Collision, Electric, and Tension seem to function as expected, as do external synths.

More interestingly, the "instant off" only occurs when there the last key is released. If you sustain one note and then play another note staccato, you'll hear the release of the staccato note following the assigned release times. It's only when the last note is released that the envelopes' release times are ignored.

For what it's worth, I'm still on 8.0.4. Maybe this was an issue addressed in a later bug-fix? Or maybe we're just missing a setting not directly or obviously related to the volume envelopes?

I sure hope someone has the answer, because it seriously reduces the usefulness of these two synths.

ShelLuser
Posts: 4030
Joined: Sun Dec 06, 2009 10:26 pm
Location: Wageningen, Netherlands

Re: Am I going mad? Notes stopping after note off no matter what

Post by ShelLuser » Sun Oct 17, 2010 3:32 pm

First thing to do is to try an upgrade, the latest version can be used besides your current one (as long as you don't start saving your current projects there won't be any problems) and it allows you to check for bugfixes.

But apart from that; I'd still say double check your midi setup. I started out with Live around the end of last year (and followed all upgrades) but never experienced something like this. Not with the keyboard nor with my mpd.
With kind regards,

Peter

Using the 'Power' Trio: Live 10 Suite (+ Push & Max 8 ), Reason 10 and Maschine Mk3 (+ the ultimate Komplete 12).
Blog: SynthFan (under heavy construction!)

southsounder
Posts: 98
Joined: Sun Oct 17, 2010 2:31 am
Location: Olympia

Re: Am I going mad? Notes stopping after note off no matter what

Post by southsounder » Mon Oct 18, 2010 5:26 am

Agreed on the need to update - I'll definitely be updated to 8.2.1 soon, although 8.0.4 has been remarkably stable for me at least.

In the meantime can anyone tell me if the versions of Operator and Sampler are different between those that came with 8.0.4 and those that come with 8.2.1?

Because if they aren't, then I'm not sure the problem will be fixed by upgrading Live itself.

As described in my previous post, version 8.0.4 is correctly responding to note-off messages in ALL instances except the last released key on Operator and Sampler. It seems to me it would be reasonable to assume the problem is with those two instruments, not Live itself. Again, I could be wrong and maybe upgrading to 8.2.1 will be the solution.

Ableton_David
Posts: 1766
Joined: Fri Aug 20, 2010 7:31 pm
Location: Ableton
Contact:

Re: Am I going mad? Notes stopping after note off no matter what

Post by Ableton_David » Mon Oct 18, 2010 10:05 am

What do you have the release set to in Operator or Sampler?

Badger123
Posts: 82
Joined: Sun Sep 09, 2007 3:48 pm
Location: Bristol, UK
Contact:

Re: Am I going mad? Notes stopping after note off no matter what

Post by Badger123 » Mon Oct 18, 2010 4:29 pm

Thank you for your replies.

I am working in Live 8.2 and the problem occurs there no matter what the length of the release time. It's as Southsounder says. Whatever the release time if one note is played and released, operator plays as if the release time is set to 1ms. If one note is held while another is played and released the release time displayed is adhered to for the released note.

I still have Live 8.1.3 and 8.1.5 on my drive and the problem is identical in both cases.

I'm using an emagic mt4 as my midi interface. It works fine with logic 9 and has worked before with Ableton quite recently. I'm not sure what has caused things to turn strange with released notes.

southsounder
Posts: 98
Joined: Sun Oct 17, 2010 2:31 am
Location: Olympia

Re: Am I going mad? Notes stopping after note off no matter what

Post by southsounder » Wed Oct 20, 2010 3:24 am

I'm using an external midi controller connected to a MOTU midi express 128. I can verify the note-off message via the lights on the MOTU as well as the midi activity light in Live.

The note-off message works as expected in Logic for me as well, in addition to all of Live's synths except Operator and Sampler as mentioned previously.

So David, does this situation warrant an email to support? Or is an upgrade to 8.2.1 a necessary prerequisite?

Badger123
Posts: 82
Joined: Sun Sep 09, 2007 3:48 pm
Location: Bristol, UK
Contact:

Re: Am I going mad? Notes stopping after note off no matter what

Post by Badger123 » Wed Oct 20, 2010 10:04 am

I've stuck something in my keyboard to hold a high note down quietly so the other notes release as programmed. Thanks for the workaround southsounder.

Interesting that sounds work properly via computer keyboard.

Anyone else getting this problem?

Ableton_David
Posts: 1766
Joined: Fri Aug 20, 2010 7:31 pm
Location: Ableton
Contact:

Re: Am I going mad? Notes stopping after note off no matter what

Post by Ableton_David » Wed Oct 20, 2010 12:45 pm

southsounder wrote:I'm using an external midi controller connected to a MOTU midi express 128. I can verify the note-off message via the lights on the MOTU as well as the midi activity light in Live.

The note-off message works as expected in Logic for me as well, in addition to all of Live's synths except Operator and Sampler as mentioned previously.

So David, does this situation warrant an email to support? Or is an upgrade to 8.2.1 a necessary prerequisite?
Yes, it's a good idea to contact support. You can do that here: http://www.ableton.com/support

southsounder
Posts: 98
Joined: Sun Oct 17, 2010 2:31 am
Location: Olympia

Re: Am I going mad? Notes stopping after note off no matter what

Post by southsounder » Thu Oct 21, 2010 5:25 am

Thanks David, I guess that's the next step.

I too noticed that the computer keyboard works correctly, very weird. I guess another workaround is to always make sure your last note is triggered by the computer keyboard. Kind of a one-hand-per-keyboard organ-style setup?

I'll post with any resolution from support, although apparently this is somehow an isolated problem. Either that, or everyone else in the entire world is using Operator and Sampler for percussion sounds only... :)

southsounder
Posts: 98
Joined: Sun Oct 17, 2010 2:31 am
Location: Olympia

Re: Am I going mad? Notes stopping after note off no matter what

Post by southsounder » Fri Oct 22, 2010 8:09 pm

While answering some questions for tech support I noticed one more very interesting aspect of this problem: it only occurs while monitoring!

Recorded notes play back correctly, even if the release envelopes were truncated during the recording process. So how weird is that??

I'll be sure to post any information support can come up with on this problem. Stay tuned! (I hope...)

southsounder
Posts: 98
Joined: Sun Oct 17, 2010 2:31 am
Location: Olympia

Re: Am I going mad? Notes stopping after note off no matter what

Post by southsounder » Tue Oct 26, 2010 5:10 am

Well, at the suggestion of tech support I swapped out my main controller (a Kawai K11) and replaced it with another keyboard (a Yamaha CS2x).

Indeed, the problem went away.

Very confused, as the ONLY difference between the two scenarios is that the Kawai has aftertouch and the Yamaha does not.

The present theory (mine at least) is that Operator and Sampler do not respond correctly to note-off messages from keyboards that transmit channel aftertouch while in monitoring mode. As mentioned in my previous post, recorded notes work fine.

Badger123, does your controller have aftertouch? Does anyone else have a controller with aftertouch that could test this theory?

BTW, kudos to Christian @ tech support - 24 hour response time or less on every email, and I know this is not the most arduous issue they're currently dealing with.

Badger123
Posts: 82
Joined: Sun Sep 09, 2007 3:48 pm
Location: Bristol, UK
Contact:

Re: Am I going mad? Notes stopping after note off no matter what

Post by Badger123 » Tue Oct 26, 2010 9:01 am

Hi Southsounder. My controller indeed does have aftertouch. It's a Roland D50. There's a slider to turn the aftertouch off but this makes no difference to the behavior. I'm pretty sure in the past the problem disappeared and then came back but I'm not sure why. I've now taken to wedging something in to hold one key down and getting by like this. Thanks again for the tip. Once the track is unarmed and armed again the held down note is not recorded and other notes decay correctly.

dickchampion
Posts: 1
Joined: Mon Oct 25, 2010 11:20 am

Re: Am I going mad? Notes stopping after note off no matter what

Post by dickchampion » Mon Nov 22, 2010 2:53 pm

Figured I'd pitch in when I saw this thread.

Just ran into the same problem here.
But the thing with the aftertouch makes no sense in my test setup.

I have a Prophet 08 (aftertouch), Juno-106 and a Roland FP-5 stagepiano (both no aftertouch) hooked up to a MOTU microlite in ports 1, 2 and 3.
And I have Moog Little Phatty (also no aftertouch) hooked up to the MOTU Ultralite midi-in.

Prophet, Phatty and FP-5 all work as they should, but the Juno-106 doesn't. No release time on the Juno.
So no consistency in my end.

Its no big deal, but as I'm making a travel setup to use with different midicontrollers, it would be nice with a fix in the next update, if possible.
That way I won't have to worry about what kind of keyboard the backline folks comes up with.

Just to share :)

DC

Locked