Launchpad latency on session mode (Update: youtube link)

UHE is now closed. For Technical Support from Ableton, please go here: http://www.ableton.com/support
iloyd2
Posts: 117
Joined: Wed Jul 15, 2009 9:23 pm
Location: CA
Contact:

Re: Launchpad latency on session mode (Update: youtube link)

Post by iloyd2 » Thu Nov 04, 2010 12:39 am

coke wrote:
iloyd2 wrote:
coke wrote:( that's too bad, I would love to hear from some another Novation Launchpad user that the thing works as intended, if I would considered the APC better :(

Anyway, I think is not hardware related, beacause the other modes in my launchpad work flawless without any noticiable latency, I think it is a software issue with the way Live and the Launchpad talk to each other on the session mode.

I have contacted Novation but they doesn' answer neither :(
I hope it's not an hardware issue and they have a solution. On my side I can also notice a lag when I press the mute button on/off in Mixer mode.
I don't have that lag at all as I recall, I would have to do the test and come back to tell you.

I am now emailing with novation support, but I think the problem I have is with the ableton mapping of the launchpad.
Cool! I never checked it as a regular midi controller I always used it with Ableton mapping. So looks like there is hope that they can fix the problem!

soddell
Posts: 1
Joined: Wed Nov 18, 2009 1:24 am

Re: Launchpad latency on session mode

Post by soddell » Fri Dec 03, 2010 1:11 am

I had the same latency problem. I've just switched from internal soundcard to external card with ASIO driver ==> problem solved.

Jacques

FinlayB
Posts: 1
Joined: Sun Dec 05, 2010 12:01 am

Re: Launchpad latency on session mode (Update: youtube link)

Post by FinlayB » Fri Dec 17, 2010 8:07 pm

I am having the exact same problem except on a PC laptop with the APC20. Is anyone else experiencing this. Any solutions?

I'm still awaiting a response from Ableton about this.

What's going on:

Running Ableton on XP laptop.
Latency is fantastic. 3ms or less.
Triggering in session mode works well with QWERTY or midi keyboard in remote setup.
Latency is great when using APC20 as a standard midi controller in remote setup.
Latency is TERRIBLE when APC20 is setup as 'Control Surface'.

What gives?

FinlayB

pedroschki
Posts: 64
Joined: Thu Feb 21, 2008 2:54 pm

Re: Launchpad latency on session mode (Update: youtube link)

Post by pedroschki » Thu Mar 24, 2011 4:07 pm

Apologies for dragging up such an old post, but did anyone solve this?

When controlling clips in Live's session view, I have the same problem. Pretty sure it's not a latency issue as, using MLRV, Launchpad responds how I'd expect....

vs
Posts: 6
Joined: Tue Jul 26, 2011 3:08 pm

Re: Launchpad latency on session mode (Update: youtube link)

Post by vs » Tue Jul 26, 2011 7:31 pm

I have the same issue with apc20. Latency only in session controller mode. With ordinary midi mappings there is no latency, but there is no light feedback too. Did anybody found the solution?

yur2die4
Posts: 6383
Joined: Sat Oct 03, 2009 3:02 am
Location: Menasha, Wisconsin
Contact:

Re: Launchpad latency on session mode (Update: youtube link)

Post by yur2die4 » Wed Jul 27, 2011 9:56 pm

On pc, download asio4all. Configure properly and it should work. That is if you are using a standard pc or laptop soundcard. If you have an audio interface and still have problems, best of luck, I can't help you haha

vs
Posts: 6
Joined: Tue Jul 26, 2011 3:08 pm

Re: Launchpad latency on session mode (Update: youtube link)

Post by vs » Mon Aug 01, 2011 3:27 pm

Problems described in this thread are not due to audio latency. I have perfect latencies with ~3mS with external asio compatible card. But apc20 latency in session controller mode is still there...

luisarm
Posts: 1
Joined: Mon Aug 01, 2011 12:17 am

Re: Launchpad latency on session mode (Update: youtube link)

Post by luisarm » Tue Aug 02, 2011 2:35 pm

try this*** I noticed that on your live screen shot next to OVR (ovedub button, located next to the play and stop and all that jazz) you? have it set to 1bar, choose the sample you dabbling with and change that to 1/8t or lower on the scale to say 1/32 to get the results you want. Happy sampling fellow Launchpadder

vs
Posts: 6
Joined: Tue Jul 26, 2011 3:08 pm

Re: Launchpad latency on session mode (Update: youtube link)

Post by vs » Wed Aug 03, 2011 11:58 am

There is no latency of my sound card. and there is no quantization problems, my ASIO latency is only 3mS. and I have quantization settings set to none on those clips.

Based on what I read on posts on this website Ableton is incapable to launch clips (Gate/No quantization) without noticable latency when you use dedicated controller with ligt/led feedback.
The only way to launch those clips correctly is to set manual midi mapping but you will not have a LED feedback.
Unfortunately LED feedback is a significant feature of Launchpad and APC controllers.

I understood that APC Launchpad and Maschine all had similar problems. and maybe the problem is in ableton.

Morphido
Posts: 33
Joined: Thu Apr 02, 2009 10:38 am
Location: Madrid, Spain

Re: Launchpad latency on session mode (Update: youtube link)

Post by Morphido » Wed Sep 21, 2011 10:44 am

Same problem :(
I can map the slots in user2 page and launch clips without any lag, like single shots from a drum rack... but in Session View, with none quantization, I have a kind of latency (lag) which is impossible to perform any rhythm synced with the tempo.
Launchpad is great for its dedicated Session Mode, Ableton is able to play clips without any tempo grid, so the problem is the native communication between Launchpad and Ableton Live.
I'll try to contact both companies in order to receive any answer about this big issue.
MacPro 6 Cores | MacBookPro | Apollo 8

jpodtbc
Posts: 30
Joined: Wed Jun 18, 2008 1:56 pm

Re: Launchpad latency on session mode (Update: youtube link)

Post by jpodtbc » Wed Mar 14, 2012 6:25 am

hi guys.

i've done some experimentation with custom control surface scripts and i've noticed the same thing. previously i used my MPD midi controller with direct mappings and it responded very quickly. i wanted to expand my ability to control ableton so i wrote a custom midi remote script and used the MPD as a control surface. enter delay.

midi remote scripts are written in python. i believe that the delay comes from the communication between python and ableton. direct midi mappings don't use python script to my knowledge. to fix this ableton would have to address the way that the midi remote scripts trigger ableton functions and optimize it for speed. this is probably why they're not responding to questions about it.

as a side note, i get very frustrated with companies that don't respond to these kinds of problems. i have had several with ableton and they pretty much ignore them all.

Locked