All times are UTC

 
 



Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 4 posts ] 
Author Message
 Post subject: Launchpad Weirdness when used with nanokontrol and Oxygen 8
PostPosted: Mon May 23, 2011 11:41 pm 

Joined: Mon Apr 18, 2011 3:14 pm
Posts: 65
Location: Asheville, NC
Hello,

I have a strange scenario, I just got my launchpad today, and I intend to use it with my oxygen 8 and nanokontrol, but I've noticed in sets where I have things mapped to the Oxygen or NanoKontrol the Launchpad will start behaving strangley

For example, the session button will flash and will function normally, but if I go to the mixer scene I cannot go back to session

Some of the arrows will also flash and will not function, for example I can go right and up, but not back left or down.

Removing all the midi mappings seems to fix the problem.

I installed the latest driver, but did NOT install Automap (and I don't want to if I don't have to)

But I think it looks like I may need to?

How does everyone else manage using the launchpad with several other controllers at the same time?


Top
 Profile  
 
 Post subject: Re: Launchpad Weirdness when used with nanokontrol and Oxygen 8
PostPosted: Tue May 24, 2011 2:30 am 

Joined: Sat Oct 03, 2009 3:02 am
Posts: 4256
Location: Menasha, Wisconsin
MIDI Channels. The LP uses like 8 different ones. Figure out what they all are, then you will know what channels you are free to use on other controllers.

The easiest way to figure out the channels is to have the LP on each page, go to MIDI Assign Mode, and assign anything to a button, the first number will be the Midi Channel, the second will be the Note#.

The pages consist of:
Session, User1, User2, Mixer, Volume, Pan, Send1, Send2


Top
 Profile  
 
 Post subject: Re: Launchpad Weirdness when used with nanokontrol and Oxygen 8
PostPosted: Tue May 24, 2011 5:04 am 

Joined: Mon Apr 18, 2011 3:14 pm
Posts: 65
Location: Asheville, NC
Thank you so much, that was exactly the solution!

FWIW My LP Transmits on Channels 1,5,6,7,8,9,10 & 11


Top
 Profile  
 
 Post subject: Re: Launchpad Weirdness when used with nanokontrol and Oxygen 8
PostPosted: Fri Jun 17, 2011 4:42 am 

Joined: Mon Apr 26, 2010 6:38 am
Posts: 1336
My recommendation with the LP is if you don't use the USER modes for control and don't need CC feedback, don't enable the MIDI Output to the LP. If its set as a control surface it still operates fine as a clip launcher, mixer etc but you shouldn't get feedback issues from your other controllers.

I have a dozen controllers and spent days documenting the channels used for CC and Notes on all devices and using Bome to change some devices so I don't get cross-controller issues. Nothing worse than mapping a control to something, recording some automation and finding you have overwritten automation in another track with a shared control.

_________________
Image


Top
 Profile  
 
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 4 posts ] 

All times are UTC

 
 

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group