Page 1 of 1

sustain pedal with looper

Posted: Mon Aug 15, 2011 8:30 pm
by jhoiland3103
I have an Maudio sustain pedal and axiom 49. I'm trying to get the sustain pedal to work with Looper. I'm able to map it to looper, but when i press it the button just goes back and forth between rec and play. If I use my mouse everything works right. if i hit record with my mouse and then use the footswitch it triggers the global play button. I've tried everything, any ideas?

Re: sustain pedal with looper

Posted: Tue Aug 16, 2011 9:26 pm
by yur2die4
Try to change your footpedal setting on the Axiom from a CC# to a midi note. That seems to have the very best results :)

Re: sustain pedal with looper

Posted: Sat Aug 20, 2011 1:05 am
by jhoiland3103
Well if I could figure out how to do that I would. If I assign a midi note to the pedal using the enigma software it still gives it a CC#...147. CC147 doesn't seem to be recognized by Live...no incoming midi signal is registered. I can't see any way of just assigning a note with no CC. Maybe I just don't understand the concept of notes and CCs well enough.
If I assign the looper button to a key on the axiom it does the exact same as if I was using the pedal. If I assign the looper to a key on my computer keyboard, everything works as it should.
So I need to get my pedal to send the same message as if it were a computer keyboard. Any experience with Enigma or perhaps a better program? Is the axiom even capable of this?

Re: sustain pedal with looper

Posted: Sat Aug 20, 2011 1:43 am
by jhoiland3103
Well after some more reading, I've been able to get the pedal to produce a midi note. BUT nothing has changed with looper. it's gotta be the pedal

Re: sustain pedal with looper

Posted: Sat Aug 20, 2011 2:53 am
by yur2die4
Is it set to Momentary or Toggle? There is either a switch on the pedal, or possibly options in the Enigma editor.

Re: sustain pedal with looper

Posted: Sat Aug 20, 2011 5:55 am
by jhoiland3103
I've tried switching between the two with no results. Just did an experiment though...I plugged my sustain pedal into my e-drum brain which also sends midi into Live, and it works fine. SO, it has something to do with the fact that the Axiom can only send note information through CC147. Supposedly Live ignores this CC and just receives the note, but apparently not.
If anything this experience has taught me a lot about using enigma and the axiom i've had for 3years! Thanks for your time