Disappearing U-he plugins

UHE is now closed. For Technical Support from Ableton, please go here: http://www.ableton.com/support
Locked
tone61
Posts: 376
Joined: Fri Dec 21, 2007 5:09 am

Disappearing U-he plugins

Post by tone61 » Thu Feb 23, 2012 10:37 pm

has anyone else experienced this using Live 8.2.8:
Dive and Zebra2 somehow become invalid. When trying to add either one to a MIDI track, Live says the instrument is not compatible with Live or something.
If I try rescanning VSTs, those instruments disappear from VST list.
Normally those vsts are in a u-he subfolder of my custom VST folder. If I move those problem vst dll files to my vst folder, then Live shows them in VST list.
But using them fails because for example Zebra cannot find some files it needs.

Any idea what might be causing this?
It has happened twice now using Live 8.2.8, can't remember how I fixed it first time.

rasputin
Posts: 645
Joined: Wed Mar 19, 2003 10:16 pm
Location: San Diego, California, USA
Contact:

Re: Disappearing U-he plugins

Post by rasputin » Fri Feb 24, 2012 2:03 am

I have a similar problem with Zebrify. A set that used it came up with a message that it was not a compatible plug in. I'm not sure what was causing it. I created a new Template set, deleted preferences and it was OK.

However I still have the problem with Zebra2 when it is instantiated in Live. If I move it off the edge of the screen, and then back, the graphics paints a series of white lines parallel to the edge I moved it off. It happens with different graphics cards. Overall Zebra 2.5.2 is working well and I can put up with that minor glitch given its awesome sound.

(Live on Windows XP)
Live 9.1 <> occasionally Reason 4.0.1 <> Reaper.latest! <> Windows 7 on a bespoke Intel Q6600 <> ASUS P5E <> 8GB RAM, M-Audio Delta 2496 and that's it.


tone61
Posts: 376
Joined: Fri Dec 21, 2007 5:09 am

Re: Disappearing U-he plugins

Post by tone61 » Fri Feb 24, 2012 2:04 pm

The problem is not crashing. First using the VST works.
Then later you cannot add the instrument to a track anymore.
and: even though the VST cannot be used in Live, it works normally in another DAW.

rasputin
Posts: 645
Joined: Wed Mar 19, 2003 10:16 pm
Location: San Diego, California, USA
Contact:

Re: Disappearing U-he plugins

Post by rasputin » Sun Feb 26, 2012 1:47 am

Yup. This is what I am seeing. Now Zrev is disappearing but only in 8.2.8. 8.2.6 can still see it.
Other DAWs can see it OK. Some database that Live uses seems to have a corrupt value that is not getting cleared out. Reinstalling u-he plugs does not fix. Something is a little strange with u-he architecture as dlls for Zebra2, Zebralette, Zebrify and Zrev are all the same length in bytes. I would like to split them up into two folders but maybe that is not permitted. Haven't seen anything about this on u-he's boards.
Live 9.1 <> occasionally Reason 4.0.1 <> Reaper.latest! <> Windows 7 on a bespoke Intel Q6600 <> ASUS P5E <> 8GB RAM, M-Audio Delta 2496 and that's it.

tone61
Posts: 376
Joined: Fri Dec 21, 2007 5:09 am

Re: Disappearing U-he plugins

Post by tone61 » Sun Feb 26, 2012 4:50 pm

It would be nice if Ableton could fix this 8.2.8 problem.

One way you can fix it temporarily is:
-move the problem VST dll files (like zebra2.dll) outside your VST folder.
-In Live Preferences, click rescan plugins buttons (maybe needs pressing ALT while clicking the button, so scan is done the slow way)
-close Live
-copy dll files back to your VST folder
-start Live
now your plugins should be usable again. But they may disappear after some time.
Not sure exactly what causes this plugin list corruption...

Locked