Re-enable random clip colors in session view

Share your wishes for the future of Ableton Live
Post Reply
Idonotlikebroccoli
Posts: 1203
Joined: Thu Aug 11, 2005 12:29 pm
Location: Norway

Re: Re-enable random clip colors in session view

Post by Idonotlikebroccoli » Tue Nov 03, 2015 10:45 am

For sure! I don't mind automatic track colours, but random clip colours is very important to me too.

One problem with random mode is that clips sometimes get a similar colour as the previous one. I think this is because there are too many colours in Live (which by the way are too saturated and ugly). I quite like Bitwig's colour palette:

Image
Please vote! Live 10's "multi" clip editing should allow selection+editing of multiple clips in one action:

(L10-SUG-0228) Multiple MIDI transpose

viewtopic.php?f=3&t=228094

jessicatramg
Posts: 1
Joined: Tue Nov 10, 2015 9:50 pm

Re: Re-enable random clip colors in session view

Post by jessicatramg » Tue Nov 10, 2015 9:52 pm

I absolutely agree. I got so used to the random color assignment for clips that it became a huge (and very helpful) part of my workflow. Especially when I was working with large sets I would have a memory of what color was what and it made it much easier to get around.

I would love to see the option come back!

staxxx
Posts: 2
Joined: Fri Nov 13, 2015 9:52 pm

Re: Re-enable random clip colors in session view

Post by staxxx » Fri Nov 13, 2015 9:58 pm

Oh man!

I'm with everyone on this. I totally see the usefulness of the two new options for color assignment in 9.5, BUT BUT BUT! Losing random color assignment has really messed with my work flow.

I created a custom template with specific colors to kick start any new session. That template is null and void, my carefully chosen color scheme is gone. The specific problem is that there are only two alternatives and neither is acceptable for my needs.

Alternative 1) Live set new random colors - not helpful, since they are different every time I launch!!
Alternative 2) Use a pre-determined color for all new tracks. Also not helpful because, not only are all tracks the same color now, in both cases, all clips are assigned the same color as the track. I can't quickly differentiate between takes, variations, edits, or clips I've composed on one track and am mirroring on another track.

The whole thing has slowed me down. We should have a "legacy color" option, which sets everything back to the classic color assignment. I'm really surprised Ableton bungled on this feature!

Idonotlikebroccoli
Posts: 1203
Joined: Thu Aug 11, 2005 12:29 pm
Location: Norway

Re: Re-enable random clip colors in session view

Post by Idonotlikebroccoli » Tue Feb 02, 2016 4:54 pm

Edit: It's back in 9.6! :)
Please vote! Live 10's "multi" clip editing should allow selection+editing of multiple clips in one action:

(L10-SUG-0228) Multiple MIDI transpose

viewtopic.php?f=3&t=228094

Post Reply