pattr hide from pattrstorage not working

Questions and discussion about building and using Max for Live devices
Post Reply
Jabbon
Posts: 156
Joined: Wed Apr 16, 2008 8:57 am
Contact:

pattr hide from pattrstorage not working

Post by Jabbon » Tue Nov 09, 2010 11:45 am

no matter what, new pattr , new pattrstorage, different names, if I select the hide from pattstorage in pattr it will not work (if I open the pathcer again the option is not clicked in the object inspector).


I also deleted preferences.
Did not try a reinstall of Max.


Macbook pro 10.6
Live 8.2
Max latest
A=B B=C C=A

hoffman2k
Posts: 14689
Joined: Tue Jun 15, 2004 6:40 pm
Location: Belgium
Contact:

Re: pattr hide from pattrstorage not working

Post by hoffman2k » Tue Nov 09, 2010 12:07 pm

If something is Italic in the inspector, it means the property is set using an argument.
I'm not sure if there is an argument to hide it (can't find it in the reference), but you can deselect pattr objects in the pattrstorage client window. Which is almost the same thing.

Jabbon
Posts: 156
Joined: Wed Apr 16, 2008 8:57 am
Contact:

Re: pattr hide from pattrstorage not working

Post by Jabbon » Tue Nov 09, 2010 2:00 pm

exactly, but somehow, they re-appear in the pattr list as active.
It means that when I store a pattrstorage slot I recall everything

I tried also working it around making them inactive from a recalling point of view, but somehow it does not work, actually it makes things worse.
I explain better, e.g.:
I have 2 pattr objects, we will call them A and B.
I have a pattrstorage object to which ONLY (in theory) B is patterized.
A is in parameter mode enable, and should store lists from a matrix (also this pretty whacky if the Live set is big), with the option hide from pattrstorage on, and with @autorestore 0.

Now I close and save the demo patch, store some stuff around.
Recalling the preset slot will recall the setting also of A, which should not be, am I correct?

Now, let´s say I work it around by deactivating A in the pattrstorage . This operation happens at loadbang level, so on start up I have a problem:
Live will send to A information.
Then pattrstorage will send to A information, then it is deactivated, which means I need to query again the pattr object after a certain amount of time. 3 operations... instead of 1.
Another thing, having the save active states attribute of pattrstorage on, still does not solve the problem, they will still come after Live.
I also thought about recalling orders, but again I really dunno here, because it does not seem to work quite as documented. At least I cannot rely on this.
Plus add I am not the brightest programmer...



boh??? 8O
A=B B=C C=A

benbracken
Posts: 68
Joined: Tue Sep 01, 2009 4:07 pm

Re: pattr hide from pattrstorage not working

Post by benbracken » Wed Nov 10, 2010 12:06 am

Its not totally clear to me exactly what you are seeing. A simple example with some steps to reproduce would be helpful.

thanks,
-Ben

Post Reply