possible BUG: wrong sampling rate in timing objects

Questions and discussion about building and using Max for Live devices
Post Reply
ring (Simon Slowik)
Posts: 121
Joined: Fri Oct 30, 2009 3:35 pm

possible BUG: wrong sampling rate in timing objects

Post by ring (Simon Slowik) » Tue May 17, 2011 3:49 pm

Dear ableton team,

when I use the @format attribute of metro and timer object, it always thinks in 44100 samples no matter what my settings in the audio preferences are.

here you can see what I mean:

<code>
----------begin_max5_patcher----------
442.3ocyU98SCBCDG+YVx9enoOilBie5S5eGlESGzwpAZIzt3zE8ucaKvFQG
CDWx1KbIW60668oGW2OelEbEeGQ.AO.dFXYsW4wx3S6wp0gEr.uKIGKLaDJ4
YY4DncyZ7sxbhT9dIo9XfTlDBV1tLM0DDe0q24DdHnRrLYCkk8REIQVGWTf2
8Hafimu13hZ+d7nXaKnLUtLxvoi2ZIT6138y4yzVkwdzkEi7lRjGTnjryHLX
AQVwANHDp+RdElkc5ZN5PPq4LICWXBA9TEEmeVZ3uvPin.sIzc.Z31CM5lbA
8CSxcTG1joz5btJE8SB05XIz9bHwMdpLIJVigEnZz3FMsVD2KNT5s0QH4BbQ
o3q9AlflwzkcK5NMxBlJxbq+aJz7uUzhaEhcIZi7mHSh8pabBaZi7t0aijzB
RE3w07pBrDnanxUyrGlc8LE1ex8RlYQtdMyoQSalzX4V8oByore8.kQb5E9A
ME7sUIsXnsVANG0WJQHoLrjxYc1ktSBzoJ1PSSIlMfZcUPSK4pG1ZTBXY+Wx
+MwgFTbAWEwYR6vjK9pHtnw.NmqzsZ3XDWzMN2b9WZS6PY9FWEmSP.
-----------end_max5_patcher-----------
</code>

cheers,
simon

broc
Posts: 1148
Joined: Mon Jul 26, 2004 8:37 am

Re: possible BUG: wrong sampling rate in timing objects

Post by broc » Tue May 17, 2011 5:20 pm

I think the same bug also occurs with [translate].
This was once confirmed on the c74 forum by developers without promising a quick fix.

pukunui
Posts: 405
Joined: Thu Jan 29, 2009 10:26 pm
Location: Los Angeles

Re: possible BUG: wrong sampling rate in timing objects

Post by pukunui » Tue May 17, 2011 7:23 pm

Yeah sorry about this. You'll have to work around it for now.

It's ticketed for the next major release of Max.

-A

Post Reply