clip linker not working in 8.2.2, help needed

Questions and discussion about building and using Max for Live devices
frz001
Posts: 23
Joined: Fri May 15, 2009 3:21 pm

clip linker not working in 8.2.2, help needed

Post by frz001 » Wed May 18, 2011 1:28 pm

Anyone can help me ?
I got this very useful patch working in Live 8.2 and not working in 8.2.2
(I am running last version of m4l)
I tried but didn't find the reason
(patch is coming from here, btw : http://www.maxforlive.com/library/device.php?id=608 )

the patch :

{
"boxes" : [ {
"box" : {
"maxclass" : "message",
"text" : "call stop",
"outlettype" : [ "" ],
"fontname" : "Arial Bold",
"numinlets" : 2,
"fontsize" : 10.0,
"numoutlets" : 1,
"patching_rect" : [ 220.0, 227.0, 51.0, 16.0 ],
"id" : "obj-21"
}

}
, {
"box" : {
"maxclass" : "message",
"text" : "-1",
"outlettype" : [ "" ],
"fontname" : "Arial Bold",
"numinlets" : 2,
"fontsize" : 10.0,
"numoutlets" : 1,
"patching_rect" : [ 148.0, 291.0, 50.0, 16.0 ],
"id" : "obj-12"
}

}
, {
"box" : {
"maxclass" : "live.text",
"varname" : "live.text",
"outlettype" : [ "", "" ],
"parameter_enable" : 1,
"texton" : "ON",
"presentation_rect" : [ 23.0, 14.0, 40.0, 20.0 ],
"numinlets" : 1,
"text" : "OFF",
"numoutlets" : 2,
"patching_rect" : [ 271.0, 26.0, 40.0, 20.0 ],
"presentation" : 1,
"id" : "obj-18",
"saved_attribute_attributes" : {
"valueof" : {
"parameter_longname" : "live.text",
"parameter_modmin" : 0.0,
"parameter_linknames" : 0,
"parameter_modmode" : 0,
"parameter_info" : "",
"parameter_units" : "",
"parameter_order" : 0,
"parameter_defer" : 0,
"parameter_speedlim" : 1.0,
"parameter_invisible" : 0,
"parameter_steps" : 0,
"parameter_annotation_name" : "",
"parameter_enum" : [ "val1", "val2" ],
"parameter_exponent" : 1.0,
"parameter_unitstyle" : 10,
"parameter_mmax" : 1.0,
"parameter_mmin" : 0.0,
"parameter_type" : 2,
"parameter_initial_enable" : 0,
"parameter_shortname" : "live.text",
"parameter_modmax" : 127.0
}

}

}

}
, {
"box" : {
"maxclass" : "newobj",
"text" : "gate",
"outlettype" : [ "" ],
"fontname" : "Arial Bold",
"numinlets" : 2,
"fontsize" : 10.0,
"numoutlets" : 1,
"patching_rect" : [ 271.0, 61.0, 32.5, 18.0 ],
"id" : "obj-2"
}

}
, {
"box" : {
"maxclass" : "comment",
"text" : "slaved track",
"fontname" : "Arial Bold",
"presentation_rect" : [ 6.0, 84.0, 69.0, 18.0 ],
"numinlets" : 1,
"fontsize" : 10.0,
"numoutlets" : 0,
"patching_rect" : [ 44.0, 115.0, 150.0, 18.0 ],
"presentation" : 1,
"id" : "obj-19"
}

}
, {
"box" : {
"maxclass" : "number",
"outlettype" : [ "int", "bang" ],
"ignoreclick" : 1,
"fontname" : "Arial Bold",
"bgcolor" : [ 0.380392, 0.768627, 0.286275, 1.0 ],
"presentation_rect" : [ 24.0, 100.0, 35.0, 18.0 ],
"numinlets" : 1,
"fontsize" : 10.0,
"numoutlets" : 2,
"patching_rect" : [ 44.0, 94.0, 50.0, 18.0 ],
"presentation" : 1,
"id" : "obj-15"
}

}
, {
"box" : {
"maxclass" : "newobj",
"text" : "+ 1",
"outlettype" : [ "int" ],
"fontname" : "Arial Bold",
"numinlets" : 2,
"fontsize" : 10.0,
"numoutlets" : 1,
"patching_rect" : [ 44.0, 62.0, 32.5, 18.0 ],
"id" : "obj-11"
}

}
, {
"box" : {
"maxclass" : "comment",
"text" : "master track",
"fontname" : "Arial Bold",
"presentation_rect" : [ 4.0, 38.0, 73.0, 18.0 ],
"numinlets" : 1,
"fontsize" : 10.0,
"numoutlets" : 0,
"patching_rect" : [ 29.0, 27.0, 150.0, 18.0 ],
"presentation" : 1,
"id" : "obj-5"
}

}
, {
"box" : {
"maxclass" : "newobj",
"text" : "pack",
"outlettype" : [ "" ],
"fontname" : "Arial Bold",
"numinlets" : 2,
"fontsize" : 10.0,
"numoutlets" : 1,
"patching_rect" : [ 271.0, 99.0, 33.0, 18.0 ],
"id" : "obj-46"
}

}
, {
"box" : {
"maxclass" : "newobj",
"text" : "route -2 -1",
"outlettype" : [ "", "", "" ],
"fontname" : "Arial Bold",
"numinlets" : 1,
"fontsize" : 10.0,
"numoutlets" : 3,
"patching_rect" : [ 35.0, 291.0, 59.0, 18.0 ],
"id" : "obj-45"
}

}
, {
"box" : {
"maxclass" : "live.menu",
"varname" : "live.menu",
"outlettype" : [ "", "", "float" ],
"parameter_enable" : 1,
"activebgcolor" : [ 0.901961, 0.129412, 0.129412, 1.0 ],
"pictures" : [ ],
"presentation_rect" : [ 28.0, 54.846153, 30.0, 15.0 ],
"numinlets" : 1,
"numoutlets" : 3,
"patching_rect" : [ 32.0, 7.0, 41.0, 15.0 ],
"presentation" : 1,
"id" : "obj-17",
"saved_attribute_attributes" : {
"valueof" : {
"parameter_longname" : "live.menu",
"parameter_modmin" : 0.0,
"parameter_linknames" : 0,
"parameter_modmode" : 0,
"parameter_info" : "",
"parameter_units" : "",
"parameter_order" : 0,
"parameter_defer" : 0,
"parameter_speedlim" : 1.0,
"parameter_invisible" : 0,
"parameter_steps" : 0,
"parameter_annotation_name" : "",
"parameter_enum" : [ "1", "2", "3", "4", "5", "6", "7", "8", "9", "10", "11", "12", "13", "14", "15", "16" ],
"parameter_exponent" : 1.0,
"parameter_unitstyle" : 10,
"parameter_mmax" : 127.0,
"parameter_mmin" : 0.0,
"parameter_type" : 2,
"parameter_initial_enable" : 0,
"parameter_shortname" : "live.menu",
"parameter_modmax" : 127.0
}

}

}

}
, {
"box" : {
"maxclass" : "message",
"text" : "call fire",
"outlettype" : [ "" ],
"fontname" : "Arial Bold",
"numinlets" : 2,
"fontsize" : 10.0,
"numoutlets" : 1,
"patching_rect" : [ 271.0, 237.0, 46.0, 16.0 ],
"id" : "obj-16"
}

}
, {
"box" : {
"maxclass" : "newobj",
"text" : "t b l",
"outlettype" : [ "bang", "" ],
"fontname" : "Arial Bold",
"numinlets" : 1,
"fontsize" : 10.0,
"numoutlets" : 2,
"patching_rect" : [ 271.0, 207.0, 108.5, 18.0 ],
"id" : "obj-8"
}

}
, {
"box" : {
"maxclass" : "newobj",
"text" : "live.object",
"outlettype" : [ "" ],
"fontname" : "Arial Bold",
"numinlets" : 2,
"fontsize" : 10.0,
"numoutlets" : 1,
"patching_rect" : [ 271.0, 257.0, 162.0, 18.0 ],
"id" : "obj-10",
"saved_object_attributes" : {
"_persistence" : 0
}

}

}
, {
"box" : {
"maxclass" : "message",
"text" : "path live_set tracks $2 clip_slots $1",
"outlettype" : [ "" ],
"fontname" : "Arial Bold",
"numinlets" : 2,
"fontsize" : 10.0,
"numoutlets" : 1,
"patching_rect" : [ 271.0, 154.0, 180.0, 16.0 ],
"id" : "obj-13"
}

}
, {
"box" : {
"maxclass" : "newobj",
"text" : "live.path",
"outlettype" : [ "", "", "" ],
"fontname" : "Arial Bold",
"numinlets" : 1,
"fontsize" : 10.0,
"numoutlets" : 3,
"patching_rect" : [ 271.0, 180.0, 157.0, 18.0 ],
"id" : "obj-14"
}

}
, {
"box" : {
"maxclass" : "message",
"text" : "property fired_slot_index",
"outlettype" : [ "" ],
"fontname" : "Arial Bold",
"numinlets" : 2,
"fontsize" : 10.0,
"numoutlets" : 1,
"patching_rect" : [ 35.0, 238.0, 131.0, 16.0 ],
"id" : "obj-9"
}

}
, {
"box" : {
"maxclass" : "newobj",
"text" : "t b l",
"outlettype" : [ "bang", "" ],
"fontname" : "Arial Bold",
"numinlets" : 1,
"fontsize" : 10.0,
"numoutlets" : 2,
"patching_rect" : [ 35.0, 203.0, 108.5, 18.0 ],
"id" : "obj-7"
}

}
, {
"box" : {
"maxclass" : "newobj",
"text" : "live.observer",
"outlettype" : [ "", "" ],
"fontname" : "Arial Bold",
"numinlets" : 2,
"fontsize" : 10.0,
"numoutlets" : 2,
"patching_rect" : [ 35.0, 258.0, 159.0, 18.0 ],
"id" : "obj-6",
"saved_object_attributes" : {
"_persistence" : 0
}

}

}
, {
"box" : {
"maxclass" : "message",
"text" : "path live_set tracks $1",
"outlettype" : [ "" ],
"fontname" : "Arial Bold",
"numinlets" : 2,
"fontsize" : 10.0,
"numoutlets" : 1,
"patching_rect" : [ 35.0, 155.0, 117.0, 16.0 ],
"id" : "obj-3"
}

}
, {
"box" : {
"maxclass" : "newobj",
"text" : "live.path",
"outlettype" : [ "", "", "" ],
"fontname" : "Arial Bold",
"numinlets" : 1,
"fontsize" : 10.0,
"numoutlets" : 3,
"patching_rect" : [ 35.0, 181.0, 157.0, 18.0 ],
"id" : "obj-1"
}

}
],
"lines" : [ {
"patchline" : {
"source" : [ "obj-45", 0 ],
"destination" : [ "obj-21", 0 ],
"hidden" : 0,
"midpoints" : [ ]
}

}
, {
"patchline" : {
"source" : [ "obj-17", 1 ],
"destination" : [ "obj-46", 1 ],
"hidden" : 0,
"midpoints" : [ ]
}

}
, {
"patchline" : {
"source" : [ "obj-46", 0 ],
"destination" : [ "obj-13", 0 ],
"hidden" : 0,
"midpoints" : [ ]
}

}
, {
"patchline" : {
"source" : [ "obj-17", 0 ],
"destination" : [ "obj-3", 0 ],
"hidden" : 0,
"midpoints" : [ ]
}

}
, {
"patchline" : {
"source" : [ "obj-6", 0 ],
"destination" : [ "obj-45", 0 ],
"hidden" : 0,
"midpoints" : [ ]
}

}
, {
"patchline" : {
"source" : [ "obj-7", 0 ],
"destination" : [ "obj-9", 0 ],
"hidden" : 0,
"midpoints" : [ ]
}

}
, {
"patchline" : {
"source" : [ "obj-8", 0 ],
"destination" : [ "obj-16", 0 ],
"hidden" : 0,
"midpoints" : [ ]
}

}
, {
"patchline" : {
"source" : [ "obj-16", 0 ],
"destination" : [ "obj-10", 0 ],
"hidden" : 0,
"midpoints" : [ ]
}

}
, {
"patchline" : {
"source" : [ "obj-8", 1 ],
"destination" : [ "obj-10", 1 ],
"hidden" : 0,
"midpoints" : [ 370.0, 240.5, 423.5, 240.5 ]
}

}
, {
"patchline" : {
"source" : [ "obj-14", 0 ],
"destination" : [ "obj-8", 0 ],
"hidden" : 0,
"midpoints" : [ ]
}

}
, {
"patchline" : {
"source" : [ "obj-13", 0 ],
"destination" : [ "obj-14", 0 ],
"hidden" : 0,
"midpoints" : [ ]
}

}
, {
"patchline" : {
"source" : [ "obj-3", 0 ],
"destination" : [ "obj-1", 0 ],
"hidden" : 0,
"midpoints" : [ ]
}

}
, {
"patchline" : {
"source" : [ "obj-1", 0 ],
"destination" : [ "obj-7", 0 ],
"hidden" : 0,
"midpoints" : [ ]
}

}
, {
"patchline" : {
"source" : [ "obj-7", 1 ],
"destination" : [ "obj-6", 1 ],
"hidden" : 0,
"midpoints" : [ 134.0, 239.0, 184.5, 239.0 ]
}

}
, {
"patchline" : {
"source" : [ "obj-9", 0 ],
"destination" : [ "obj-6", 0 ],
"hidden" : 0,
"midpoints" : [ ]
}

}
, {
"patchline" : {
"source" : [ "obj-17", 1 ],
"destination" : [ "obj-11", 0 ],
"hidden" : 0,
"midpoints" : [ ]
}

}
, {
"patchline" : {
"source" : [ "obj-11", 0 ],
"destination" : [ "obj-15", 0 ],
"hidden" : 0,
"midpoints" : [ ]
}

}
, {
"patchline" : {
"source" : [ "obj-45", 2 ],
"destination" : [ "obj-2", 1 ],
"hidden" : 0,
"midpoints" : [ 84.5, 318.0, 187.25, 318.0, 187.25, 51.0, 294.0, 51.0 ]
}

}
, {
"patchline" : {
"source" : [ "obj-2", 0 ],
"destination" : [ "obj-46", 0 ],
"hidden" : 0,
"midpoints" : [ ]
}

}
, {
"patchline" : {
"source" : [ "obj-18", 0 ],
"destination" : [ "obj-2", 0 ],
"hidden" : 0,
"midpoints" : [ ]
}

}
, {
"patchline" : {
"source" : [ "obj-6", 0 ],
"destination" : [ "obj-12", 1 ],
"hidden" : 0,
"midpoints" : [ ]
}

}
, {
"patchline" : {
"source" : [ "obj-21", 0 ],
"destination" : [ "obj-10", 0 ],
"hidden" : 0,
"midpoints" : [ ]
}

}
]
}
-
Live 8.2.2 m4l 5.1.8
OSX

chapelier fou
Posts: 5042
Joined: Mon May 15, 2006 12:15 pm

Re: clip linker not working in 8.2.2, help needed

Post by chapelier fou » Thu May 19, 2011 7:13 am

i made this little patch,
but i am touring (back tomorrow) and can't check right now....

uh i just checked, it works well for me, except some little weirdness :

sometimes, the first launch doesn't have any effect for some reason...
did you click on the OFF/ON button ?

Anyway, i ve seen another patch in m4l.com which seemed to do the same job with more flexibility.
MacBook Pro 13" Retina i7 2.8 GHz OS 10.13, L10.0.1, M4L.
iMac 27" Retina i5 3,2 GHz OS 10.11.3 L10.0.1 M4L.

glamourboy
Posts: 253
Joined: Thu Jul 26, 2007 11:57 am
Location: Copenhagen

Re: clip linker not working in 8.2.2, help needed

Post by glamourboy » Thu May 19, 2011 7:25 am

Anyway, i ve seen another patch in m4l.com which seemed to do the same job with more flexibility.
can you give the name of that patch?

chapelier fou
Posts: 5042
Joined: Mon May 15, 2006 12:15 pm

Re: clip linker not working in 8.2.2, help needed

Post by chapelier fou » Thu May 19, 2011 7:29 am

nope sorry.
Leaving for brussels right now !
MacBook Pro 13" Retina i7 2.8 GHz OS 10.13, L10.0.1, M4L.
iMac 27" Retina i5 3,2 GHz OS 10.11.3 L10.0.1 M4L.

frz001
Posts: 23
Joined: Fri May 15, 2009 3:21 pm

Re: clip linker not working in 8.2.2, help needed

Post by frz001 » Thu May 19, 2011 3:54 pm

@chapelier fou
Yep, I did click the on/off button.
What is strange is that it works for me with live 8.2, and doesn't work with Live 8.2.2
Maybe it doesn't comes from your plug but from something in the installation of Live 8.2.2 and m4l. Very strange.
In any case, I am actually using Live 8.2 so that I can use your plug (really useful). Hope I will solve this bug with 8.2.2 (I would like to use Kapture, and it is not working in 8.2).
Someone had this kind of issue with 8.2 and 8.2.2 ?

@glamourboy :
I think the plug chapelier fou is talking about is psuedo group.
It works the same except you can link any track you like (in clip linker, you can link 2 tracks if they are side by side).
But psuedo group only fire the clip. When you stop it, his "twin clip" doesn't stop. Wich Clip linker does.

(and by the way, I have the same problem with psuedo group : working in 8.2, not in 8.2.2)
-
Live 8.2.2 m4l 5.1.8
OSX

chapelier fou
Posts: 5042
Joined: Mon May 15, 2006 12:15 pm

Re: clip linker not working in 8.2.2, help needed

Post by chapelier fou » Thu May 19, 2011 4:15 pm

Weird,
it's working for me on 8.2.2 on this computer....
I can't help, sorry.
MacBook Pro 13" Retina i7 2.8 GHz OS 10.13, L10.0.1, M4L.
iMac 27" Retina i5 3,2 GHz OS 10.11.3 L10.0.1 M4L.

frz001
Posts: 23
Joined: Fri May 15, 2009 3:21 pm

Re: clip linker not working in 8.2.2, help needed

Post by frz001 » Thu May 19, 2011 4:40 pm

Yep, that confirm what I suspected : the problem doen't come from the plug but from the software.
Thanks for your help : at least, it helps me to know it is working in 8.2.2 for someone.
I think I will post about this problem.
Have a good concert !
-
Live 8.2.2 m4l 5.1.8
OSX

hoffman2k
Posts: 14700
Joined: Tue Jun 15, 2004 6:40 pm
Location: Belgium
Contact:

Re: clip linker not working in 8.2.2, help needed

Post by hoffman2k » Thu May 19, 2011 5:35 pm

Try uninstalling Max and installing it again.
I'm guessing, when you open the Max window (right-click device) it shows an error like "live.thisdevice: no such object".
A complete reinstall of Max has worked for some users of my devices. But I don't know why the install fails for some people.

frz001
Posts: 23
Joined: Fri May 15, 2009 3:21 pm

Re: clip linker not working in 8.2.2, help needed

Post by frz001 » Thu May 19, 2011 6:26 pm

Thanks for the tip 'right clic' to open max window, didn't know that.
I did already uninstall max and reinstall but no changes.
I just trashed the 'max5' folder. Is it enough, or are there any other files to delete ? Or any uninstaller.
I reinstalled max from the same dmg file I got. Maybe I should re download it ?
What do you recommend ?

In case of : with the max window, I know some more.
It seems the problem comes from the live.observer box. I did put a print on the live.observer.
When working - in 8.2 - the print return correctly the index of the clip launched.
When not working - in 8.2.2 - the print always return '-1'
(but the max window doesn't say "live.thisdevice: no such object" in my case).
-
Live 8.2.2 m4l 5.1.8
OSX

hoffman2k
Posts: 14700
Joined: Tue Jun 15, 2004 6:40 pm
Location: Belgium
Contact:

Re: clip linker not working in 8.2.2, help needed

Post by hoffman2k » Thu May 19, 2011 7:10 pm

Ah. I thought there was an uninstall button in the installer. But that seems to be gone now.
A reinstall (version 45300) should have done the trick though. So I'm out of ideas.
You'll need to contact Cycling Support for this issue I think.

frz001
Posts: 23
Joined: Fri May 15, 2009 3:21 pm

Re: clip linker not working in 8.2.2, help needed

Post by frz001 » Thu May 19, 2011 8:20 pm

Ok, I did contact cycling.
I will tell you if they find the solution, in case someone has the same problem.
Thanks for your help.
-
Live 8.2.2 m4l 5.1.8
OSX

chapelier fou
Posts: 5042
Joined: Mon May 15, 2006 12:15 pm

Re: clip linker not working in 8.2.2, help needed

Post by chapelier fou » Fri May 20, 2011 1:56 pm

does it still happen when you reselect the "master track" ?
MacBook Pro 13" Retina i7 2.8 GHz OS 10.13, L10.0.1, M4L.
iMac 27" Retina i5 3,2 GHz OS 10.11.3 L10.0.1 M4L.

frz001
Posts: 23
Joined: Fri May 15, 2009 3:21 pm

Re: clip linker not working in 8.2.2, help needed

Post by frz001 » Fri May 20, 2011 2:04 pm

Unfortunatly, yes.
-
Live 8.2.2 m4l 5.1.8
OSX

frz001
Posts: 23
Joined: Fri May 15, 2009 3:21 pm

Re: clip linker not working in 8.2.2, help needed

Post by frz001 » Fri Jun 10, 2011 6:45 am

Hello there,
Cycling found out what the problem was (thanks to them) :

In fact, the fired_slot_index is working ok in 8.2, whatever your quantization setting is on or off.
But in 8.2.2, if quantization is set to none, the fired_slot_index is not working anymore.
-
Live 8.2.2 m4l 5.1.8
OSX

pukunui
Posts: 405
Joined: Thu Jan 29, 2009 10:26 pm
Location: Los Angeles

Re: clip linker not working in 8.2.2, help needed

Post by pukunui » Fri Jun 10, 2011 2:14 pm

fired_slot_index = blinking state

Quantization set to none = no blinking

-A

Post Reply