problem with autopattr, pattrstorage and preset

Questions and discussion about building and using Max for Live devices
Post Reply
ned rush
Posts: 402
Joined: Wed Sep 23, 2009 1:45 pm
Contact:

problem with autopattr, pattrstorage and preset

Post by ned rush » Wed Oct 19, 2011 8:30 pm

i've made a synth, everything works fine, brought in pattr etc for presets, however it is not recalling setting for parameters that i have in bpatchers. all 3 of my oscillators are contained in separate bpatchers and autopattr is not saving them to presets. how do i get round this?

many thanks
ned :)


toscanini
Posts: 410
Joined: Thu May 05, 2005 5:42 pm

Re: problem with autopattr, pattrstorage and preset

Post by toscanini » Tue Oct 25, 2011 7:13 pm

Gregory, I haven't read anything in those files about pattr objects stopping to work if encapsulated. I haven't tried with bpatchers but had the same problem with popup windows attached to pcontrol, or with abstractions dropped into a structure, basically in all cases where the pattr objects are in a patcher one level deeper in the structure.

Btw the information about autopattr in the cycling docs you refer to is wrong, autopattr is necessary to automatically detect live.dial and live.numbox objects, as I know from your brilliant tutorial!

...so along with ned I am anxious to find out is something can be done about this pattr inside patcher issue...

ned rush
Posts: 402
Joined: Wed Sep 23, 2009 1:45 pm
Contact:

Re: problem with autopattr, pattrstorage and preset

Post by ned rush » Tue Oct 25, 2011 8:26 pm

i should mention i actually brought in autopattr rather than pattr in to the patch etc, just to avoid confusion. oops.

Post Reply