M4L Stability

Questions and discussion about building and using Max for Live devices
musikmachine
Posts: 619
Joined: Wed Aug 05, 2009 12:56 am

Re: M4L Stability

Post by musikmachine » Sun Aug 17, 2014 2:26 pm

eyeknow wrote:Oh yeah, I forgot to say @asio4all. I can't believe that ableton would recommend that driver over my stock driver, but I'm going to do a clean install pretty soon so when I get the other computer up to speed, I guess I'll try the no script/asio4all.

What makes me upset though is that for the average user, you pretty much have a feel for a "bullshit" o-meter and mine is pegged currently. If all the resetting (which fraked my settings) didn't do it, and 600 of us have the SAME EXACT PROBLEMS, then I'm doubtful it's anything other than a pipe dream.
Yeah i got that kinda response yet most of the issues were gone in the betas. :?

@rosko seems you can't start one in the M4L forum unless someone from ableton caught wind and quickly removed that option. :lol:

I guess you'd have to post in the main forum but looks good, it would be good to know whether convrev is crashing for a lot of people too cause that could be a specific issue with the device.

Yeah i too thought quirks with M4L being new but maybe there something more although looking around the web i can't find much else reporting issues unless people are thinking the same.

Rosko
Posts: 213
Joined: Sun Jan 22, 2006 4:12 pm

Re: M4L Stability

Post by Rosko » Sun Aug 17, 2014 3:25 pm


BojanKerkez
Posts: 8
Joined: Fri Dec 23, 2011 11:01 pm

Re: M4L Stability

Post by BojanKerkez » Sun Sep 21, 2014 8:07 am

I've installed 9.1.5 yesterday and it seems they have fixed whatever was causing all those M4L crashes on Windows 7 64-bit. Convolution Reverb Pro can be used again without crashing Live, both on tracks and on returns, and out of all M4L devices I've tested, only Envelope MIDI device from M4L Essentials Pack crashed the host almost every time it initialised Max.

Rosko
Posts: 213
Joined: Sun Jan 22, 2006 4:12 pm

Re: M4L Stability

Post by Rosko » Sun Sep 21, 2014 8:45 am

If they have they didn't do that intentionally. Did you update or install fresh?

S4racen
Posts: 5237
Joined: Fri Aug 24, 2007 4:08 pm
Location: Dunstable
Contact:

Re: M4L Stability

Post by S4racen » Sun Sep 21, 2014 9:41 am

Just a tip, a user of mine found their crash problems were isolated to having Blue2 installed... they removed the dll and saw an end to the crashes!

Cheers
D

BojanKerkez
Posts: 8
Joined: Fri Dec 23, 2011 11:01 pm

Re: M4L Stability

Post by BojanKerkez » Sun Sep 21, 2014 4:07 pm

Rosko wrote:If they have they didn't do that intentionally. Did you update or install fresh?
I didn't use the autoupdate, I downloaded the installer and chose replace during installation.

eyeknow
Posts: 5822
Joined: Fri Jul 15, 2005 6:16 am

Re: M4L Stability

Post by eyeknow » Sun Sep 21, 2014 10:01 pm

BojanKerkez wrote:I've installed 9.1.5 yesterday and it seems they have fixed whatever was causing all those M4L crashes on Windows 7 64-bit. Convolution Reverb Pro can be used again without crashing Live, both on tracks and on returns, and out of all M4L devices I've tested, only Envelope MIDI device from M4L Essentials Pack crashed the host almost every time it initialised Max.
9.1.5? You mean the beta?

BojanKerkez
Posts: 8
Joined: Fri Dec 23, 2011 11:01 pm

Re: M4L Stability

Post by BojanKerkez » Mon Sep 22, 2014 7:16 am

eyeknow wrote:9.1.5? You mean the beta?
I also thought it was still in beta cause 9.1.4 is still in the sticky, but when you go to Your Account page 9.1.5 is available for download.

eyeknow
Posts: 5822
Joined: Fri Jul 15, 2005 6:16 am

Re: M4L Stability

Post by eyeknow » Mon Sep 22, 2014 9:28 pm

BojanKerkez wrote:
eyeknow wrote:9.1.5? You mean the beta?
I also thought it was still in beta cause 9.1.4 is still in the sticky, but when you go to Your Account page 9.1.5 is available for download.
How weird

Rosko
Posts: 213
Joined: Sun Jan 22, 2006 4:12 pm

Re: M4L Stability

Post by Rosko » Mon Sep 22, 2014 11:13 pm

9.1.5 came out a few days ago. BTW the latest beta 9.1.6 has some M4L fixes. I uninstalled blue2 as well & reinstalled max & live to the c drive. No issues so far but i haven't had chance to test proper.

eyeknow
Posts: 5822
Joined: Fri Jul 15, 2005 6:16 am

Re: M4L Stability

Post by eyeknow » Tue Sep 23, 2014 2:07 am

9.1.5 still crashed when I turned on push with convo verb in the return. But it's not crashing every single time.

tone61
Posts: 376
Joined: Fri Dec 21, 2007 5:09 am

Re: M4L Stability

Post by tone61 » Fri Oct 03, 2014 8:57 pm

This Convolution Reverb Pro causing crashes when opening projects is really annoying because it's the M4L device I like most when it's working.

And: after reading this thread today I decided to try the Blue2 trick.
I moved Blue2.dll away from my VST folder and Convolution Reverb no longer crashed. Unbelievable - and thanks for the tip!!!

eyeknow
Posts: 5822
Joined: Fri Jul 15, 2005 6:16 am

Re: M4L Stability

Post by eyeknow » Sat Oct 04, 2014 12:11 am

Hmmmmmmmmm. I don't have blue2. I wonder now if it's not something like that.

That's actually the weirdest thing. Why would a VST be causing the convo verb to crash?

And here, it's mostly on the bus that it crashes. When it's just inserted into a track, it rarely crashes :?

Rosko
Posts: 213
Joined: Sun Jan 22, 2006 4:12 pm

Re: M4L Stability

Post by Rosko » Sat Oct 04, 2014 1:01 am

Do you have iZotope Trash? try removing that, apparently may cause the same issue.

S4racen
Posts: 5237
Joined: Fri Aug 24, 2007 4:08 pm
Location: Dunstable
Contact:

Re: M4L Stability

Post by S4racen » Sun Oct 05, 2014 10:46 am

tone61 wrote:This Convolution Reverb Pro causing crashes when opening projects is really annoying because it's the M4L device I like most when it's working.

And: after reading this thread today I decided to try the Blue2 trick.
I moved Blue2.dll away from my VST folder and Convolution Reverb no longer crashed. Unbelievable - and thanks for the tip!!!
No worries, i didn't find it myself but it's best to share!

Cheers
D

Post Reply