M4L Stability

Questions and discussion about building and using Max for Live devices
NoSonic822
Posts: 700
Joined: Sat Jun 01, 2013 8:38 am

Re: M4L Stability

Post by NoSonic822 » Sat Mar 14, 2015 5:25 am

Angstrom wrote:
stringtapper wrote:I

You being you, Angstrom, I'm sure you've been reporting this stuff. It seems like it's pretty clearly a Windows oriented issue just from the numbers I see here.

You guys have a list of particular M4L devices that are causing the issues?
My normal 'crash on open' crashlog I sent them a huuuuge bombardment of for a while, and when it was acknowledged on the beta / centercode I slowed those dumps to a minimum. Otherwise it would be my dayjob.

The others, the bluscreens, the weird crashes, I usually report those unless its bluscreened me so hard i have to walk away from the computer and next time I start it up I've forgotten what this particular crashlog is. Because I always get a "live crashed last time" alert, its not exactly a reminder.

My assumption is that max devices with heavy memory or file read requirements can cause issues, and can cause issues on loading in a default set because the delay incurred triggers the win OS circular reference issue. Live starts to load-> starts to load Max-> max device in default set calls LiveAPI -> LIve Api calls an as yet undefined max object, shit goes horrible.
Windows is stricter than Unix in requiring every symbol to have a resolution at link time.
If the initial device is small the load latency is mere milliseconds and the circular reference issue is often avoided by luck. But if the m4l device is larger, it loads slower and the two apps start juggling nulls.

Obviously this is complete guesswork, but the leniency of Unix based systems and the stringency of Win systems, combined with the issues regarding larger max devices makes me think issues related to that are problematic.

I have no clues on the other more bluescreeny crashes. They are quite random and often happen when I just link an LFO to a parameter, or touch the LFO dial. Those ones just make me want to take up woodturning, or basket weaving.
i dont understand computers at all and i dont understan anything youre taking about really....but you seem to know waht is going on. i also would get crashes from inserting conv reverb....and also using other devices, like the instant haus.....it would cause really awful midi problems....it would make midi clips disappear......like in arrangement view....if i had a instant haus or osome other randomize midi device...it would cause something in a totally unrelated track t, it would make it so that when you drag to resize a midi clip, if you stretched the clip over another clip it would just erase that part of that clip...forever...you cant get it back.....its just gone.....it's directly related to having some of those midi randomize m4l devices.....like devices that 4n 4nt etc your midi..

alexandermon
Posts: 9
Joined: Sun Feb 23, 2014 6:03 am

Re: M4L Stability

Post by alexandermon » Mon Mar 16, 2015 3:40 pm

Joining this thread a bit late apparently.

Just wanted to report that I'm getting consistent crashes whenever I open ANY M4L device. 100% of the time.

Using the new 2015 13" MBP, so I assumed it was hardware-related but I suppose it might not be.


Any advice? I've tried several versions of Java to no avail, and I've tried a complete reformat of the HDD.

stringtapper
Posts: 6272
Joined: Sat Aug 28, 2004 6:21 pm

Re: M4L Stability

Post by stringtapper » Mon Mar 16, 2015 5:20 pm

What versions of Live and Max do you have installed?
Unsound Designer

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: M4L Stability

Post by Stromkraft » Thu Mar 26, 2015 1:15 pm

This may not be relevant to everyone, but as the results are clear I'm repeating info given in another thread here:

At the suggestion from Ableton support (after they've reviewed my crash log) which mentioned that my Options file contained unsupported features I removed the ShowDevices option from it. When I did this recurring crashes disappeared after a restart and other issues I had with Convolution Reverb and previously also with "Magnetic" of Dub Machines also seem to have stopped.

I can't tell for sure if my lack of those latter issues with MaxForLive audio effect devices since is due to this removal as I haven't been using these as much lately until just recently, but I have repeated this crash/fix cycle twice with Live 9.1.7 and again with Live 9.2.b4 and crashes stopped which is why I am mentioning this here.

Originally answered in Convo Reverb not loading the IRs when i reload a project.
Make some music!

musikmachine
Posts: 619
Joined: Wed Aug 05, 2009 12:56 am

Re: M4L Stability

Post by musikmachine » Fri Apr 17, 2015 1:59 pm

Is anyone still having issues with M4L in the beta? I thougt the convo issue was fixed but couldn't adam and eve it when i loaded a project and the impulses were missing again. :?

I tried removing the showdevices tweak in options.txt and thought that was it initially. I want to use M4L more extensively and buy some devices but i'm relucant to say the least. And yes i've sent crash logs but got no response. :(

Angstrom
Posts: 14665
Joined: Mon Oct 04, 2004 2:22 pm
Contact:

Re: M4L Stability

Post by Angstrom » Fri Apr 17, 2015 2:07 pm

musikmachine wrote:Is anyone still having issues with M4L in the beta? I thougt the convo issue was fixed but couldn't adam and eve it when i loaded a project and the impulses were missing again. :?

I tried removing the showdevices tweak in options.txt and thought that was it initially. I want to use M4L more extensively and buy some devices but i'm relucant to say the least. And yes i've sent crash logs but got no response. :(
Yeah, I use the latest beta most of the time and it has the same issues.

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: M4L Stability

Post by Stromkraft » Fri Apr 17, 2015 9:15 pm

I have no issues with any Max Device in either 9.1.7, 9.2b5 on Windows 7 nor in OS X Mavericks. However, the stability in 9.2b5 is very erratic. It doesn't seem related to Max For Live as crashes happens when accessing the menu system, saving or quitting. Or not. Besides this performance is stellar in 9.2b5.
Make some music!

musikmachine
Posts: 619
Joined: Wed Aug 05, 2009 12:56 am

Re: M4L Stability

Post by musikmachine » Sat Apr 18, 2015 12:35 am

Cheers Angstrom.

@Stromkraft i'm having the same issue as i had in 9.1.7 but otherwise 9.2b5 is pretty stable, i've finished a couple of tracks with it, had a few crashes but no more than usual.

Frustrating cause Max issues are supposed to have been fixed so lord knows why i'm still having the exact same issue and seems i'm not the only one.

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: M4L Stability

Post by Stromkraft » Sun Apr 19, 2015 11:42 am

Stromkraft wrote:I have no issues with any Max Device in either 9.1.7, 9.2b5 on Windows 7 nor in OS X Mavericks. However, the stability in 9.2b5 is very erratic. It doesn't seem related to Max For Live as crashes happens when accessing the menu system, saving or quitting. Or not. Besides this performance is stellar in 9.2b5.
One potentially interesting anecdote: I had problems with a project crashing in both 9.1.7 and 9.2b5 at strange times like when accessing preferences or switching to Arrangement. I had Convolution Reverb on one of the returns. I decided to replace it with Native Instrument Reflektor (Guitar Rig effect) and it stopped crashing in Live 9.2b5 at least.

I'd like to add I have other projects with multiple instances of Dub Machines Magnetic, a Max For Live device, and I have no crashes with those projects.
Make some music!

musikmachine
Posts: 619
Joined: Wed Aug 05, 2009 12:56 am

Re: M4L Stability

Post by musikmachine » Mon Apr 20, 2015 7:01 pm

Maybe it is device specific but i like the integration and it has a lot of good impulses. It's a major pain when you get so far into a project and everythings been tweaked.

Do you know if you can use Convos' impulses with Reflektor?

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: M4L Stability

Post by Stromkraft » Mon Apr 20, 2015 11:51 pm

Stromkraft wrote:
One potentially interesting anecdote: I had problems with a project crashing in both 9.1.7 and 9.2b5 at strange times like when accessing preferences or switching to Arrangement. I had Convolution Reverb on one of the returns. I decided to replace it with Native Instrument Reflektor (Guitar Rig effect) and it stopped crashing in Live 9.2b5 at least.
This was probably not related for that project at least, There's an old issue with Waves plug-ins in your default template that actually seemed to cause the crashes in multiple projects. Mine were all inactivated in my template and activated in my projects for the most part. There were no issues with regular work with the Waves plug-ins but I got crashes with stuff like I go to the menubar, use the shortcut for the preferences, clicking on the waves plugin but not on a button and installing Live packs.

The fix was easy: delete Waves plug-ins from the default template
(not from the project sets)!

I also received some additional pointers from Waves that I haven't followed up on yet. Ableton Support were very helpful supplying this info.
Make some music!

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: M4L Stability

Post by Stromkraft » Tue Apr 21, 2015 12:10 am

musikmachine wrote:
Do you know if you can use Convos' impulses with Reflektor?
It works with any aiff based IRs. Just point it to "../Factory Packs/Max for Live Essentials/Max Audio Effect/Convolution Reverb/IRs".

Reflektor picks up folders very nicely and lets you advance to the next IR in the interface as well as supply reverse, R pos, decay, start and size. I'm not sure how it compares to Convolution Reverb Pro. but it's an alternative. Especially so if you already have it, as I did.
Last edited by Stromkraft on Wed Apr 22, 2015 9:08 am, edited 2 times in total.
Make some music!

musikmachine
Posts: 619
Joined: Wed Aug 05, 2009 12:56 am

Re: M4L Stability

Post by musikmachine » Wed Apr 22, 2015 12:15 am

Wicked, will try it tomorrow. :)

Daniel Morgenroth
Posts: 17
Joined: Wed Apr 29, 2015 1:29 pm

Re: M4L Stability

Post by Daniel Morgenroth » Wed Apr 29, 2015 2:33 pm

Hi all!

I'm new here, just bought the Live9Suite/Push-Bundle a month ago.

Bought the Suite especially because of "M4L". I'm on Windows 7, 64-bit,SP1. Live 9.1.7, Max 6.1.10.

And now I'm just shocked. For two weeks I had no problems (already bought some devices by J74), now I get crashes when I even dare to look at a M4L-Device.

Send them Crash-Reports, Support-Reports and all that to get an "answer" like: "We know about the problem (for a long time?) but we don't know if we will ever be able to solve it."

M4L is in my eyes a "Stock-Plugin". Of course, Ableton is not Cycling, but "Max for Live" is still "Max for Live", Part of Live9 Suite.
I've been working with DAWs for 15 years(mainly Logic and Cubase)but I never ran into one that has this kind of "serious" problems with it's Stock-Plugins.

That's a major shock. If a software is this buggy (crashes with one track open, which contains a stock-plugin)I generally can't trust it anymore.

I don't need years of constant crashes.

As I wrote before, I'm into Ableton-World for one month and I've already seen enough that just makes me want to run away.

My Tip: If you need something like Max for Live (only working), buy Bitwig.

After searching this forum, this seems to be the only reliable workaround.

scheffkoch
Posts: 492
Joined: Thu Jan 08, 2015 12:37 pm

Re: M4L Stability

Post by scheffkoch » Wed Apr 29, 2015 2:58 pm

...do you want help or do you just want to rant about live?...
in case you want help i'd first update live to the latest version...and then you could report what plugins make your set crash...?....
macbook pro late 2016, osx 10.13.6, rme multiface via sonnet thunderbolt expresscard adapter + thunderbolt to usb-c adapter, ableton live 10.0.1, push 2, komplete 9, maschine 2.7.6, touchable

Post Reply