M4L Stability

Questions and discussion about building and using Max for Live devices
Post Reply
tecolo
Posts: 60
Joined: Tue Jun 03, 2014 1:21 pm

Re: M4L Stability

Post by tecolo » Mon Oct 13, 2014 7:51 am

This is copy paste from email received yesterday from J74 Progressive developer:

This email is about the J74 Progressive tool set and it applies only to users using the Progressive tool set in a Windows environment.

In certain situations and on a Windows OS environment, Live may crash if you delete the Progressive device from the Liveset or if you save or open a Liveset containing the Progressive device. Just for the sake of clarity, this is not strictly a J74 Progressive problem, since the same problem applies to other Max for Live devices as well (all having a certain degree of complexity, such as for instance Ableton Convolution Reverb as well). The reasons why this happens are unfortunately not yet clear, neither to me or to Ableton and Cycling 74.

Anyway there is one finding you may be interested to hear about: a workaround to avoid crashes and still use the Progressive device is possible. This consists in "disabling" the device prior to saving the liveset or prior to deleting the Progressive device from the liveset.

Just use the "Device Activator" button on the device docked interface as in the picture below before you delete Progressive or save it in your liveset.

Additional comments: this is an empiric finding and may possibly not cover all cases. Anyway, since I found it to be consistent enough as a workaround, I decided to share about it. It still remains the fact that the main bug we deal with needs to be solved, as it makes the whole stability concept of Max for Live questionable. As far as I can do (as said the issue affects also other Max for Live devices, even ones made by Ableton) I am supporting Ableton and Cycling74 teams in testing and debugging this kind of issue. If you have any information to share, please do.

Again this issue only applies to Windows OS environments. The issue should not apply to MAC OS systems.


So...it's not our fault after all...

f.poce@tiscali.nl
Posts: 103
Joined: Sun Mar 21, 2010 4:14 pm

Re: M4L Stability

Post by f.poce@tiscali.nl » Mon Oct 13, 2014 12:15 pm

To whoever is listening. Just a few other comments.

I have no real evidence, but there is something I noticed and that makes me think Ableton Live does something not completely right with M4L and its memory allocation management. For small devices this is not an issue, since memory in use may be small, but for larger devices it may get nasty (cause Live to crash in certain sporadic conditions, unpredictably, as people report of).

What I have noticed is that if you take one of these M4L devices which give problems and drop/delete many times from the same liveset, then this may get the crash in question to happen. Not always, it is not that bad, but sporadically (which makes it unpredictable). Just drop it, then delete it, then drop it again, then delete it again and go on: sooner or later Live will crash. Specially (if not exclusively) if Windows is the OS in use.

On the other hand if you, instead, do a little different sequence you'll get a noticeable different outcome: drop the M4L device, then drop or delete another device (not a M4L device, by a plugin device like Live's Operator synth), then delete the M4L device in question and repeat again and again. No crashes.
It looks to me, knowing a bit about programming and memory allocation/garbage collection, that the latter approach forces memory allocation (garbage collection) to be done properly while something goes not right if M4L is involved exclusively.

It is just speculations, maybe is the M4L device which has something wrong (but then, why in version 9.1.2 nobody had issues and suddenly the same identical device in 9.1.3/9.1.4/etc. start giving issues?), but my common sense makes me think something in memory allocating in Live/M4L has since then (9.1.3? 9.1.4?) changed (and gone wrong).

Gr
Fab

tecolo wrote:This is copy paste from email received yesterday from J74 Progressive developer:

This email is about the J74 Progressive tool set and it applies only to users using the Progressive tool set in a Windows environment.

In certain situations and on a Windows OS environment, Live may crash if you delete the Progressive device from the Liveset or if you save or open a Liveset containing the Progressive device. Just for the sake of clarity, this is not strictly a J74 Progressive problem, since the same problem applies to other Max for Live devices as well (all having a certain degree of complexity, such as for instance Ableton Convolution Reverb as well). The reasons why this happens are unfortunately not yet clear, neither to me or to Ableton and Cycling 74.

Anyway there is one finding you may be interested to hear about: a workaround to avoid crashes and still use the Progressive device is possible. This consists in "disabling" the device prior to saving the liveset or prior to deleting the Progressive device from the liveset.

Just use the "Device Activator" button on the device docked interface as in the picture below before you delete Progressive or save it in your liveset.

Additional comments: this is an empiric finding and may possibly not cover all cases. Anyway, since I found it to be consistent enough as a workaround, I decided to share about it. It still remains the fact that the main bug we deal with needs to be solved, as it makes the whole stability concept of Max for Live questionable. As far as I can do (as said the issue affects also other Max for Live devices, even ones made by Ableton) I am supporting Ableton and Cycling74 teams in testing and debugging this kind of issue. If you have any information to share, please do.

Again this issue only applies to Windows OS environments. The issue should not apply to MAC OS systems.


So...it's not our fault after all...

tecolo
Posts: 60
Joined: Tue Jun 03, 2014 1:21 pm

Re: M4L Stability

Post by tecolo » Mon Oct 13, 2014 2:55 pm

f.poce@tiscali.nl wrote:To whoever is listening. Just a few other comments.

I have no real evidence, but there is something I noticed and that makes me think Ableton Live does something not completely right with M4L and its memory allocation management. For small devices this is not an issue, since memory in use may be small, but for larger devices it may get nasty (cause Live to crash in certain sporadic conditions, unpredictably, as people report of).

What I have noticed is that if you take one of these M4L devices which give problems and drop/delete many times from the same liveset, then this may get the crash in question to happen. Not always, it is not that bad, but sporadically (which makes it unpredictable). Just drop it, then delete it, then drop it again, then delete it again and go on: sooner or later Live will crash. Specially (if not exclusively) if Windows is the OS in use.

On the other hand if you, instead, do a little different sequence you'll get a noticeable different outcome: drop the M4L device, then drop or delete another device (not a M4L device, by a plugin device like Live's Operator synth), then delete the M4L device in question and repeat again and again. No crashes.
It looks to me, knowing a bit about programming and memory allocation/garbage collection, that the latter approach forces memory allocation (garbage collection) to be done properly while something goes not right if M4L is involved exclusively.

It is just speculations, maybe is the M4L device which has something wrong (but then, why in version 9.1.2 nobody had issues and suddenly the same identical device in 9.1.3/9.1.4/etc. start giving issues?), but my common sense makes me think something in memory allocating in Live/M4L has since then (9.1.3? 9.1.4?) changed (and gone wrong).

Gr
Fab

Thanks man...as i said and reported and many user did - crash is tedious to isolate because it happen on random occasion. It was like this from the beginning of my Live/Max usage and quite frankly i am surprised that this issue is/was not resolved already. Makes me think on what all these Windows betatester are doing.

I sold Live completely because i was so disappointed in stability of it but i do miss it and will monitor how these things eventually evolve in to something better..

eyeknow
Posts: 5822
Joined: Fri Jul 15, 2005 6:16 am

Re: M4L Stability

Post by eyeknow » Mon Oct 13, 2014 6:04 pm

It's hard to keep up but it sounds as though maybe some people are on the case.

Rosko
Posts: 213
Joined: Sun Jan 22, 2006 4:12 pm

Re: M4L Stability

Post by Rosko » Mon Oct 13, 2014 8:10 pm

Well i'm still getting great stability. Not sure if reinstalling latest beta & max to system drive helped but something has worked for me.(note the recent fix in 9.1.6b1 regarding m4l crashes) I was testing m4l & getting regular crashes since pretty much day one. Apparently it seems to effect certain sound cards & windows. Live is not clearing the buffer or something but its causing issues with m4l & i think some plugins.

f.poce@tiscali.nl
Posts: 103
Joined: Sun Mar 21, 2010 4:14 pm

Re: M4L Stability

Post by f.poce@tiscali.nl » Thu Nov 06, 2014 9:11 am

Probably very good news here from the Ableton development team as you can read in 9.1.6 release notes:

"Fixed a crash that could occur under certain conditions when loading Live sets containing a large amount of VST plug-ins and Max for Live devices."

https://www.ableton.com/en/articles/liv ... ase-notes/

Greets
Fab//J74
http://fabriziopoce.com

tecolo
Posts: 60
Joined: Tue Jun 03, 2014 1:21 pm

Re: M4L Stability

Post by tecolo » Thu Nov 13, 2014 4:40 pm

Nope...same thing. I just tried managed to crash ableton 10 times in a row. Very simple. Here is what i do:

Run Ableton. Drag Reaktor VSTi from browser to clip view. It loaded fine. (i mean empty reaktor, no ensemble is loaded). Now i am trying to load J74 StepSequencer in front of Reaktor (something i do very often) - Drag and drop - Crash! I can repeat this 10 times and it will crash ableton.

Then i open Ableton and i try to load J74 StepSequencer on Empty MIDI track - it load fine, then i drag and drop Reaktor after j74 and it's fine. I mean What the hell?

And i am going to repeat for 500th times - my setup is super i mean really super stable. Three different DAW applications all VST plugins work flawless in all three. I only have shenanigans when i am loading M4live plugins. Making whole projects using m4l totally unreliable.

What a mess..

before anyone ask - yes i have latest official m4l and ableton installed..

f.poce@tiscali.nl
Posts: 103
Joined: Sun Mar 21, 2010 4:14 pm

Re: M4L Stability

Post by f.poce@tiscali.nl » Thu Nov 13, 2014 6:36 pm

tecolo wrote:Nope...same thing. I just tried managed to crash ableton 10 times in a row. Very simple. Here is what i do:

Run Ableton. Drag Reaktor VSTi from browser to clip view. It loaded fine. (i mean empty reaktor, no ensemble is loaded). Now i am trying to load J74 StepSequencer in front of Reaktor (something i do very often) - Drag and drop - Crash! I can repeat this 10 times and it will crash ableton.

Then i open Ableton and i try to load J74 StepSequencer on Empty MIDI track - it load fine, then i drag and drop Reaktor after j74 and it's fine. I mean What the hell?

And i am going to repeat for 500th times - my setup is super i mean really super stable. Three different DAW applications all VST plugins work flawless in all three. I only have shenanigans when i am loading M4live plugins. Making whole projects using m4l totally unreliable.

What a mess..

before anyone ask - yes i have latest official m4l and ableton installed..
Mmm.
While I definitively do believe you, the only thing I can tell you is that from exchange of emails with users I get reports of general stability lately, even on Windows.
Just reporting a general trend.

I really do not want to frustrate you with even more work on your side, but it may be a good idea to get a clean installation of Ableton Live and Max the next time you can (turn off auto update, de-install MAx before installing a new version, keep of course you Live Library - otherwise you would need to take a week off....). Maybe a good idea could be to try this with Max 7 as MAX for Live engine. Live 9.1.6 works with Max 7.

It may get things to "reset"....

Anyway, just guessing here.....

Gr
Fab

tecolo
Posts: 60
Joined: Tue Jun 03, 2014 1:21 pm

Re: M4L Stability

Post by tecolo » Thu Nov 13, 2014 11:41 pm

f.poce@tiscali.nl wrote:
tecolo wrote:Nope...same thing. I just tried managed to crash ableton 10 times in a row. Very simple. Here is what i do:

Run Ableton. Drag Reaktor VSTi from browser to clip view. It loaded fine. (i mean empty reaktor, no ensemble is loaded). Now i am trying to load J74 StepSequencer in front of Reaktor (something i do very often) - Drag and drop - Crash! I can repeat this 10 times and it will crash ableton.

Then i open Ableton and i try to load J74 StepSequencer on Empty MIDI track - it load fine, then i drag and drop Reaktor after j74 and it's fine. I mean What the hell?

And i am going to repeat for 500th times - my setup is super i mean really super stable. Three different DAW applications all VST plugins work flawless in all three. I only have shenanigans when i am loading M4live plugins. Making whole projects using m4l totally unreliable.

What a mess..

before anyone ask - yes i have latest official m4l and ableton installed..
Mmm.
While I definitively do believe you, the only thing I can tell you is that from exchange of emails with users I get reports of general stability lately, even on Windows.
Just reporting a general trend.

I really do not want to frustrate you with even more work on your side, but it may be a good idea to get a clean installation of Ableton Live and Max the next time you can (turn off auto update, de-install MAx before installing a new version, keep of course you Live Library - otherwise you would need to take a week off....). Maybe a good idea could be to try this with Max 7 as MAX for Live engine. Live 9.1.6 works with Max 7.

It may get things to "reset"....

Anyway, just guessing here.....

Gr
Fab
Thanks for your input but....i already tried that. And reported same findings. There is no reason to belive me or not belive me because i am not reporting this out of some cloud. If you want PM me and i will give you access to my computer and you can see for yourself. Or i can record a video. Anyway or other i already tried every combination i could. Even clean install...well i did not installed max 7 but anyway i am not going to do even that after i am being tortured by VERY unstable m4l.It is a total mess. I mean m4l. I've found quite a few bugs in their step seqeuncer (one shipped with ableton), and ableton confirmed it to me (i saw people talked about this issue here) in email conversation but year passed and nothing changed. Literally nothing. I already sold one of my licence and i am leaving it totally as i can not rely on it. Since i only have problems with m4l i can only blame m4l. And i can not afford to loose any more time in clean installations and whatever, i did that and nothing changed. Last time i did clean install of 9.1.5 on literally clean machine and m4l i can't recall version but it was latest available at that time. Same thing. If you try to use search here you will find i am not alone. Yes i did reported it to support i already sent 60-70 crash logs but noone ever replied back to me.

Worst thing it is totally random. Sometimes i get 10 crashes and then it start to work. Sometimes i get crashes but then i load some old project and then try to load crashing project and it is loading fine. Really random nonsense..I have NI komplete, U-he plugins, UAD, Nebula and really i have quite a lot of them. None is crashing Ableton. Literally none. Super stable. I only have issues when i am using m4l.

f.poce@tiscali.nl
Posts: 103
Joined: Sun Mar 21, 2010 4:14 pm

Re: M4L Stability

Post by f.poce@tiscali.nl » Fri Nov 14, 2014 7:20 am

Sure.

Since you have now sold your license the update to Max 7 is not a possibility anymore.
I am sorry for the frustration you went through, that must have been.... mmm frustrating.
Anyway, though, I still have to say that I get from other people a different report (M4L crashes have become less of an issue lately).
But for reasons I cannot say, that does not apply to you.

Cheers
Fab

tecolo
Posts: 60
Joined: Tue Jun 03, 2014 1:21 pm

Re: M4L Stability

Post by tecolo » Fri Nov 14, 2014 8:02 am

f.poce@tiscali.nl wrote:Sure.

Since you have now sold your license the update to Max 7 is not a possibility anymore.
I am sorry for the frustration you went through, that must have been.... mmm frustrating.
Anyway, though, I still have to say that I get from other people a different report (M4L crashes have become less of an issue lately).
But for reasons I cannot say, that does not apply to you.

Cheers
Fab
Yes i know. Obviously 3rd party plugins aren't issue. I mean i am aware of buggy m4l plugins but J74 tools aren't buggy (IMHO). It happens with Ableton m4l devices as well..From past i can recall that i did not had such issues at start. It happened with live 9 and newer versions of Max. Needless to say that m4l was one of major option why i get into Live in the first place. Well it was a bad experience for me. Without any sense or way to isolate this weird bug. Sometimes it just works, most of the time it does not or i have to run weird procedures to make it work (load polugins in specific order). Like i said i have Adobe Suite, 3dsmax and use this machine in production pipeline. No single application is crashing or giving me problems. I only have problems runing m4l devices in Ableton. Only then my computer is not reliable.

Good luck to anyone and hope they will sort it out..

Reimund
Posts: 12
Joined: Sat Apr 04, 2009 12:48 pm

Re: M4L Stability

Post by Reimund » Wed Nov 26, 2014 7:46 am

i also have these issues. when i updated a few days ago to live 9.1.6 and max 6.9.1 in the beginning everything was fine and i could load m4l devices without crashes. yesterday when i started live again and tried to use different m4l devices i got crashes again. like for the other users the crashes are randomly and cannot be reproduced. as was reported earlier crashes are more frequent when i try to add a m4l device in a track that already contains a vst plugin. loading a m4l device in a new track most of the time works fine. i also noticed that after i had used a m4l device the madrona labs aalto plugin which i loaded afterwards did not behave correctly in a way that the preset browser could not be opened (whatever that means). it would be really great if that bug could finally be resolved because one of the reasons for me to use ableton live is the integration with m4l and the great m4l devices that are available.

tecolo
Posts: 60
Joined: Tue Jun 03, 2014 1:21 pm

Re: M4L Stability

Post by tecolo » Wed Nov 26, 2014 10:16 pm

Reimund wrote:i also have these issues. when i updated a few days ago to live 9.1.6 and max 6.9.1 in the beginning everything was fine and i could load m4l devices without crashes. yesterday when i started live again and tried to use different m4l devices i got crashes again. like for the other users the crashes are randomly and cannot be reproduced. as was reported earlier crashes are more frequent when i try to add a m4l device in a track that already contains a vst plugin. loading a m4l device in a new track most of the time works fine. i also noticed that after i had used a m4l device the madrona labs aalto plugin which i loaded afterwards did not behave correctly in a way that the preset browser could not be opened (whatever that means). it would be really great if that bug could finally be resolved because one of the reasons for me to use ableton live is the integration with m4l and the great m4l devices that are available.
Once when these issues are ironed out i will buy Ableton Suite again for sure(i really miss it). But until then - i can't afford to waste any time with buggy m4l..

Fingers crossed

19oclock
Posts: 54
Joined: Thu Aug 21, 2014 5:40 pm

Re: M4L Stability

Post by 19oclock » Wed Dec 17, 2014 7:37 am

M4L is no good to me in the traditional sense. Devices that span more than three pipes are suspect. I have experience using commercial M4L releases that crash frequently. If the professional developers cannot get it going right then I won't trust it.

This happens on my desktop and my laptop. Both are Windows 7 32bit machines.

Since I've ditched the commercial stuff things are better. Use M4L with caution if you are a performer!

tecolo
Posts: 60
Joined: Tue Jun 03, 2014 1:21 pm

Re: M4L Stability

Post by tecolo » Wed Dec 17, 2014 10:29 am

19oclock wrote:M4L is no good to me in the traditional sense. Devices that span more than three pipes are suspect. I have experience using commercial M4L releases that crash frequently. If the professional developers cannot get it going right then I won't trust it.

This happens on my desktop and my laptop. Both are Windows 7 32bit machines.

Since I've ditched the commercial stuff things are better. Use M4L with caution if you are a performer!
But the whole M4l idea was attracting to me and i jumped on to it because of m4l. I am working on it ocassionaly at friend studio because i am tryingf to translate my projects to other DAW.


Oh crap...

Is there any i mean any official reply on this issue...I see super long post of fixes on Live itself on Ableton suite but m4l is mentioned rarely..
Last edited by tecolo on Tue Dec 23, 2014 11:26 am, edited 1 time in total.

Post Reply