Time & Timbre crashes

Questions and discussion about building and using Max for Live devices
4am
Posts: 573
Joined: Mon Nov 29, 2004 12:36 pm
Location: switzerland
Contact:

Time & Timbre crashes

Post by 4am » Thu Feb 19, 2015 2:06 pm

Hi

Time & Timbre makes Ableton Live crash.

Is anyone experiencing the same problem?

Thank you

Cheers

störgeräusche
Posts: 325
Joined: Thu May 08, 2008 9:04 pm
Contact:

Re: Time & Timbre crashes

Post by störgeräusche » Thu Feb 19, 2015 2:30 pm

really crashy here and having conflicts with push.
I hope an update will be out soon -not a cheap pack so I really hope a quick fix will be delivered soon
soundcloud
website
______________________________________________________
Win7 Pro 64 - i7 870 @ 2.93 GHz - 16 GB RAM - RME Multiface II

Live Suite 9 - Komplete 9 - Waldorf Largo & Edition - Elektron Analog Rytm - Push 1&2- Launch Control & XL -
Adam P33A

4am
Posts: 573
Joined: Mon Nov 29, 2004 12:36 pm
Location: switzerland
Contact:

Re: Time & Timbre crashes

Post by 4am » Thu Feb 26, 2015 9:04 am

I've noticed that the price of the device has decreased.
I'm wondering about the reason.
It's because the device is buggy?

sbx
Posts: 35
Joined: Thu Jul 08, 2010 11:10 pm

Re: Time & Timbre crashes

Post by sbx » Thu Feb 26, 2015 11:03 am

hi, could you please detail? what system / live version / max version are you on?
please make sure that you use max 6.1.9, and downloaded the latest version (should be 1.02 if you right click on the time device and show max monitor)

feel free to contact us - support (a-t) skinnerbox (d-o-t) de

thanks

störgeräusche
Posts: 325
Joined: Thu May 08, 2008 9:04 pm
Contact:

Re: Time & Timbre crashes

Post by störgeräusche » Thu Feb 26, 2015 2:28 pm

my setup:
Win7 Pro 64bit
Live 9.1.7 64 bit
Max 6.1.9
T&T 1.0.2 Downloaded 02/17/2015

Thanks
soundcloud
website
______________________________________________________
Win7 Pro 64 - i7 870 @ 2.93 GHz - 16 GB RAM - RME Multiface II

Live Suite 9 - Komplete 9 - Waldorf Largo & Edition - Elektron Analog Rytm - Push 1&2- Launch Control & XL -
Adam P33A

4am
Posts: 573
Joined: Mon Nov 29, 2004 12:36 pm
Location: switzerland
Contact:

Re: Time & Timbre crashes

Post by 4am » Fri Feb 27, 2015 10:37 am

hi sbx

thanks for replying.

i have exactly the same setup as störgeräusche

my setup:
Win7 Pro 64bit
Live 9.1.7 64 bit
Max 6.1.9
T&T 1.0.2

lg

sbx
Posts: 35
Joined: Thu Jul 08, 2010 11:10 pm

Re: Time & Timbre crashes

Post by sbx » Fri Feb 27, 2015 1:26 pm

hi both, thanks for your reply, we will do our best to get a hold of a windows system asap and check this issue,

best

sbx

störgeräusche
Posts: 325
Joined: Thu May 08, 2008 9:04 pm
Contact:

Re: Time & Timbre crashes

Post by störgeräusche » Fri Feb 27, 2015 5:05 pm

thanks sbx.i'll be sending crash reports to ableton. do you need a copy?
soundcloud
website
______________________________________________________
Win7 Pro 64 - i7 870 @ 2.93 GHz - 16 GB RAM - RME Multiface II

Live Suite 9 - Komplete 9 - Waldorf Largo & Edition - Elektron Analog Rytm - Push 1&2- Launch Control & XL -
Adam P33A

sbx
Posts: 35
Joined: Thu Jul 08, 2010 11:10 pm

Re: Time & Timbre crashes

Post by sbx » Sat Feb 28, 2015 5:04 am

we dont need the logs, never the less, is it possible for you to test if it crashes on 32 bit mode as well?

thanks and sorry for the inconvenience,

störgeräusche
Posts: 325
Joined: Thu May 08, 2008 9:04 pm
Contact:

Re: Time & Timbre crashes

Post by störgeräusche » Sat Feb 28, 2015 9:25 am

hi sbx

i dont have a 32 version installed. if i find some time i will install the 32 bit versions of live and max, test and report.
soundcloud
website
______________________________________________________
Win7 Pro 64 - i7 870 @ 2.93 GHz - 16 GB RAM - RME Multiface II

Live Suite 9 - Komplete 9 - Waldorf Largo & Edition - Elektron Analog Rytm - Push 1&2- Launch Control & XL -
Adam P33A

Because789
Posts: 440
Joined: Thu Apr 28, 2011 1:26 pm

Re: Time & Timbre crashes

Post by Because789 » Sun Mar 01, 2015 1:32 pm

Might be the same issue:
f.poce@tiscali.nl wrote:Ableton developers pointed out in the beta forum that there is one crash situation on Windows which they do recognize (and are working on - so it was reported):

At M4L initialization (that is: when you start M4L for the *first time* since Live was open, so with the *black* Max for Live logo popping up) things can go wrong.
In particular on Windows 7 OS. M4L requires some windows dll library to start. With large M4L devices those libraries may called before fully loaded causing a Live crash. It is a matter of timing (therefore the unpredictable aspect).

A workaround (not a solution) they suggested is to load the simplest Max for Live device possible first.
For instance load first the empty "Max Midi Effect" device, which you can find in Live browser under Max for Live // Max Midi Effect.
Wait then a few seconds (yes it sounds stupid, but they said it allows all dll's to be loaded). This has the effect of starting up Max for Live engine with no such issues.
After that it should be possible to load complex M4L devices without crashes.

My own experience kind of confirms this workaround does indeed help.
viewtopic.php?p=1652340#p1652340
Live 9.5 (64bit), Max 7.0.6, Windows 10, Push 2, Korg electribe2, Bass Station II, Launch Control XL, Faderfox DJ3

M4L

4am
Posts: 573
Joined: Mon Nov 29, 2004 12:36 pm
Location: switzerland
Contact:

Re: Time & Timbre crashes

Post by 4am » Sun Mar 01, 2015 4:44 pm

it is definitely the same issue.
when i start live opening another project it doesn't crash.
thank you for pointing this out.

sbx
Posts: 35
Joined: Thu Jul 08, 2010 11:10 pm

Re: Time & Timbre crashes

Post by sbx » Sun Mar 01, 2015 4:55 pm

@4am, thanks for posting that, its a good start,
could you both confirm that TnT is stable if the these steps are taken?

best
sbx

störgeräusche
Posts: 325
Joined: Thu May 08, 2008 9:04 pm
Contact:

Re: Time & Timbre crashes

Post by störgeräusche » Mon Mar 02, 2015 8:58 am

thanks for this tip. I am going to try it out next time I'll be in the studio.

The last crashes I had (4 in a row) happened when hotswapping the preset while device was running (3x) and with the device stopped (1).
No other crashes to report.
I'll be sending the reports tonight to Ableton.
soundcloud
website
______________________________________________________
Win7 Pro 64 - i7 870 @ 2.93 GHz - 16 GB RAM - RME Multiface II

Live Suite 9 - Komplete 9 - Waldorf Largo & Edition - Elektron Analog Rytm - Push 1&2- Launch Control & XL -
Adam P33A

4am
Posts: 573
Joined: Mon Nov 29, 2004 12:36 pm
Location: switzerland
Contact:

Re: Time & Timbre crashes

Post by 4am » Mon Mar 02, 2015 9:06 am

sbx wrote:@4am, thanks for posting that, its a good start,
could you both confirm that TnT is stable if the these steps are taken?

best
sbx
i did some more tests and i can confirm that starting m4l with another project solves the problem.
sometimes, if i maltreat the device with lots of quick commands, it crashes. but this does not happen often.

there are also a couple of projects i've made with time & timbre that do not crash, even if i open them directly.

the device itself is visionary and very interesting, i hope a fix can be found soon.

thank you

andres

Post Reply