Time & Timbre crashes

Questions and discussion about building and using Max for Live devices
sbx
Posts: 35
Joined: Thu Jul 08, 2010 11:10 pm

Re: Time & Timbre crashes

Post by sbx » Mon Mar 02, 2015 8:48 pm

@4am thanks for that, we will do some "stress-tests" within windows 7 for future updates, unfortunately sounds like the main issue is not really under our control and we will just have to wait for the c74 guys to fix the loading issue,

best

sbx
Posts: 35
Joined: Thu Jul 08, 2010 11:10 pm

Re: Time & Timbre crashes

Post by sbx » Tue Mar 03, 2015 3:23 pm

@störgeräusche, im assuming that you have push connected when you hotswap, and you hotswap the "time" device?
this is an issue with push m4l api, and i recently reported that to the ableton push guys, they have filed this as a bug and they are on it, i hope there will be a fix soon,

@4am, can you please describe what kind of quick commands? this will help us to try reproducing the issue,

best

störgeräusche
Posts: 325
Joined: Thu May 08, 2008 9:04 pm
Contact:

Re: Time & Timbre crashes

Post by störgeräusche » Wed Mar 04, 2015 8:50 am

yes sbx, I have push connected when I hotswap, and I hotswap the time device. Which is very cool anyway :)
soundcloud
website
______________________________________________________
Win7 Pro 64 - i7 870 @ 2.93 GHz - 16 GB RAM - RME Multiface II

Live Suite 9 - Komplete 9 - Waldorf Largo & Edition - Elektron Analog Rytm - Push 1&2- Launch Control & XL -
Adam P33A

4am
Posts: 573
Joined: Mon Nov 29, 2004 12:36 pm
Location: switzerland
Contact:

Re: Time & Timbre crashes

Post by 4am » Wed Mar 04, 2015 9:07 am

sbx wrote: @4am, can you please describe what kind of quick commands? this will help us to try reproducing the issue,
best
i can't reproduce the issue with quick commands, it simply happens, randomly, when the project becomes more complex
since i start another m4l device before to launch time & timbre i rarely get crashes

olivierlasson
Posts: 2
Joined: Thu Jul 10, 2014 10:46 am

Re: Time & Timbre crashes

Post by olivierlasson » Sat Mar 14, 2015 2:10 pm

Hi,
Time & Timbre is really awesome and seriously buggy for me, makes Live either randomly crash or each time I remove the plugin (rack), push matrix stays freeze on Time lights configuration (hope its' clear) even if I change tracks and push no more sends midi (!)
OSX 10.9.5
Max 702 (same with 6.1.9)
Live 9.1.7
Hope sbx can something
Thks

sbx
Posts: 35
Joined: Thu Jul 08, 2010 11:10 pm

Re: Time & Timbre crashes

Post by sbx » Sun Mar 15, 2015 9:07 pm

@olivierlasson, the push matrix led issue is known to us, we are in contact with the push api devs about it as it seems to be an issue there and hopefully we can fix that together soon,
about the crashes, im using exactly the same setup and having no crashes what so ever, are you using any external scripts or can try to narrow the issue down? any info would be helpful,

best

andrewbrewer
Posts: 596
Joined: Sat Mar 26, 2005 4:01 pm

Re: Time & Timbre crashes

Post by andrewbrewer » Mon Mar 16, 2015 12:52 am

It's exciting that this pack is getting attention from sbx! Your free drum m4l device from years ago was brilliant so that led me to try TnT.

Unfortunately I'm in the same boat as other users, in that I am wrestling with malfunction. I have been in talks with Ableton support to get this working on my system (windows 7). The problem on my end is that racks will not delete (delete will cause ableton to hang and become non responsive) -- unless I do something special: if there are two of the TnT drum modules that use the same m4l file (for example two toms) I have to delete one tom. If I do that first, then I can delete the rack successfully. This unfortunately means that I am restricted to using one instance of each m4l TnT module file in a rack.

sbx
Posts: 35
Joined: Thu Jul 08, 2010 11:10 pm

Re: Time & Timbre crashes

Post by sbx » Mon Mar 16, 2015 10:46 am

@andrewbrewer

can you please send me a detailed explanation of how to reproduce the issue to support ( a...t ) skinnerbox (dot) de ?
as there seems to be a bigger issue with win7 and m4l as described in other threads in the forum, does this happens to you only with TnT or with other m4l devices?

thanks!

olivierlasson
Posts: 2
Joined: Thu Jul 10, 2014 10:46 am

Re: Time & Timbre crashes

Post by olivierlasson » Mon Mar 16, 2015 10:57 am

Thks sbx
Crashes occurred a few times when I played fast patterns...
Hope ableton can do something regarding push matrix in the next 9.2
Using PXT & Touchable, same with or without and push is the first selected

4am
Posts: 573
Joined: Mon Nov 29, 2004 12:36 pm
Location: switzerland
Contact:

Re: Time & Timbre crashes

Post by 4am » Mon Jun 01, 2015 9:27 am

Hi
any news on this issue?
Thank you

f.poce@tiscali.nl
Posts: 103
Joined: Sun Mar 21, 2010 4:14 pm

Re: Time & Timbre crashes

Post by f.poce@tiscali.nl » Thu Jun 04, 2015 8:28 am

If you are on windows you may check this thread.
viewtopic.php?f=35&t=205402&start=180

In a post from [rry] (Ableton Support) a patch in explained (with downloads) which requires the use of Max 7.0.3 in combination with replacement of the "maxurl" object. It is also said this is targeted as a fix for next Max releases.

Post Reply