macOS High Sierra: "Wrong Max version" issue (x64)

Questions and discussion about building and using Max for Live devices
Post Reply
Posts: 53
Joined: Thu Jun 11, 2009 7:40 am

macOS High Sierra: "Wrong Max version" issue (x64)

Post by Valery_Kondakoff » Wed Sep 27, 2017 11:48 am


I'm unable to load any M4L device after installing macOS High Sierra. There is an error "The selected Max application could not be loaded, a 64-bit version is probably required" when trying to load any *.amxd file. First Live asks a permission to make changes and then gives an aforementioned error.
I tried to reinstall both Max and Live (deleting preferences first) - this does not help. The path to the Max app is set correctly in the Live settings.

Ableton and Cycling'74 support answers something like this: "This is a really vexing issue that seems to happen if you launch Max for Live for the first time when the disk image is still open. After that we have not found any way to force the OS to launch the proper version of Max (it points to the quarantine location created as part of the AppTranslocation feature of 10.12 and 10.13). The only solution we know of at this point is a clean install of the OS. From there, you have to make sure to install Live and max, unmount both disk images and restart, then launch Live and Max for Live."

But it seems even clean install of the OS does not fix the issue:

Anybody here experiencing this?

chapelier fou
Posts: 5346
Joined: Mon May 15, 2006 12:15 pm

Re: macOS High Sierra: "Wrong Max version" issue (x64)

Post by chapelier fou » Wed Sep 27, 2017 2:35 pm

Wow. Thanks for sharing, i cannot help but wish you good luck in solving this.
MacBook Pro 13" Retina i7 2.8 GHz OS 10.13, L10.0.1, M4L.
iMac 27" Retina i5 3,2 GHz OS 10.11.3 L10.0.1 M4L.

Posts: 42
Joined: Mon Dec 17, 2007 9:40 pm

Re: macOS High Sierra: "Wrong Max version" issue (x64)

Post by verstaerker » Thu Sep 28, 2017 7:01 am

i have the same issue - I will not do a clean install of my OS. I prefer waiting for a real solution.

i also tried removing the quarantine attribute on max ( xattr -c -r /Applications/ )
but it didn't help

oblique strategies
Posts: 3586
Joined: Thu Nov 02, 2006 9:57 pm
Location: Another Green World

Re: macOS High Sierra: "Wrong Max version" issue (x64)

Post by oblique strategies » Sun Oct 01, 2017 11:46 am

Please see: MacOS 10.3 High Sierra & Max for Live incompatibility Issue


Post Reply