Page 1 of 1

Weird bug in the Envelope device with 3 note chords

Posted: Thu Nov 08, 2018 4:22 pm
by Puddi
I have noticed that there's something wrong with the Envelope device when playing chords with 3 notes (or 6 notes, 9 notes etc)

Here's an example of how it sounds. First it's 2 notes, then 3, then 4:

Original sound: https://instaud.io/2TNT

With Envelope device modulating the gain: https://instaud.io/2TNU

You can also see how the Gain acts up in this GIF:

Image

Can anyone else confirm this bug?

It makes no sense why it only happens on chords of 3. Is it possible for some Max for Live wizard to fix this in the Max editor or can only Ableton themselves do it?

Re: Weird bug in the Envelope device with 3 note chords

Posted: Thu Nov 08, 2018 7:13 pm
by pottering
Yeah, I seeing it too, seems with 3 notes the Note Off also triggers the Envelope.

You should report it to Ableton's Support.

Re: Weird bug in the Envelope device with 3 note chords

Posted: Thu Nov 08, 2018 7:45 pm
by [jur]
Please report this to support@ableton.com Puddi, thanks.

Re: Weird bug in the Envelope device with 3 note chords

Posted: Thu Nov 08, 2018 9:37 pm
by Puddi
Some helpful users on Reddit solved the problem for me: https://www.reddit.com/r/ableton/commen ... meone_fix/
I had a look at the device and the behaviour you're seeing is down to the sustain behaviour of the function object in Max. The envelope device wasn't built as far as I can tell to accept multiple note on/note off events at once and the only way to fix the device for this scenario would be to establish some logic for combining several notes into a chord.

You can do this by opening the device. Unfreeze/unlock and exit presentation mode. You should see a object 'p MIDILogic' on the left hand side of the network. Command/ctrl double click to open this patcher.

The output of the 'midiparse' object is the individual note data of the chords. Create a 'thresh 20' object. This will combine notes within 20ms of each other into a single event. Connect the new object between 'midiparse' and 'unpack 0 0'.

If you now save this patcher and the parent device (refreeze it first) it should fix your issue.
I had a quick look at the .amxd file and found an issue with the note off which is causing double triggers, I have fixed this for both Max for Live versions 9 and 10..

Here's a dropbox link..

https://www.dropbox.com/s/cdmkhh1ohhj2k ... x.zip?dl=0

[Edit]

For anybody wondering how it was fixed, the link below takes you to the post on Cycling74's forum that includes a screenshot and some details..

https://cycling74.com/forums/max-for-li ... rigger-bug
Ableton might want to implement one of these solutions. :wink:

Re: Weird bug in the Envelope device with 3 note chords

Posted: Thu Nov 08, 2018 10:56 pm
by pottering
Thanks for link, and thanks to Max user Fora for the fix.

I'm actually going to keep a backup of the broken version, for funsies.

Re: Weird bug in the Envelope device with 3 note chords

Posted: Fri Nov 09, 2018 1:37 am
by [jur]
Thanks for the info!
Will forward it, and hopefully the device will be updated soon.