M4L LFO, Shaper and recording issues

Questions and discussion about building and using Max for Live devices
Post Reply
iTerentius
Posts: 4
Joined: Fri Jan 11, 2019 11:46 pm

M4L LFO, Shaper and recording issues

Post by iTerentius » Fri Jan 11, 2019 11:53 pm

Hello,

I am loving these new inclusions in Live 10 of Max for Live parameter modulators. However, it seems since the waveform is ever moving, you never get the same output twice which is a huge workflow problem. Everything is limited edition!

When the LFO is set to Hz instead of Beats this even worse. It seems when you record it starts wherever it happens to be.

Am I missing something?

Worse with random waves as well. But that is sort of obvious. I also tried re-triggering as an automation point at the beginning, but no change. Seems like I'm missing something. How does anyone use these tools in a workflow?

Thanks,
ITL

[jur]
Site Admin
Posts: 1356
Joined: Mon Jun 01, 2015 3:04 pm
Location: Ableton

Re: M4L LFO, Shaper and recording issues

Post by [jur] » Sat Jan 12, 2019 3:29 am

In hertz mode the waveform is running freely, so of course you get some unpredictability.
You need to use the beat mode instead.
Ableton Forum Moderator

chapelier fou
Posts: 4830
Joined: Mon May 15, 2006 12:15 pm

Re: M4L LFO, Shaper and recording issues

Post by chapelier fou » Sat Jan 12, 2019 7:23 am

I’ll see how to implement a reset function. Could be useful !
MacBook Pro 13" Retina i7 2.8 GHz OS 10.13, L10.0.1, M4L.
iMac 27" Retina i5 3,2 GHz OS 10.11.3 L10.0.1 M4L.

iTerentius
Posts: 4
Joined: Fri Jan 11, 2019 11:46 pm

Re: M4L LFO, Shaper and recording issues

Post by iTerentius » Sat Jan 12, 2019 5:17 pm

chapelier fou wrote:I’ll see how to implement a reset function. Could be useful !
Yeah, that would be ridiculously useful. I'd assume the calculation of any wave form would start at a common point, if a reset occurred. My Max skills are pretty weak, but I was poking around in the plugins. Might take someone with a better grasp of it than I have.

iTerentius
Posts: 4
Joined: Fri Jan 11, 2019 11:46 pm

Re: M4L LFO, Shaper and recording issues

Post by iTerentius » Sat Jan 12, 2019 5:21 pm

[jur] wrote:In hertz mode the waveform is running freely, so of course you get some unpredictability.
You need to use the beat mode instead.
That makes sense. But I also found that beats, and using a plain square wave, you have a 50% chance of it being On or Off. Very short waveforms, probably no big deal. Long ones - totally different thing.

iTerentius
Posts: 4
Joined: Fri Jan 11, 2019 11:46 pm

Re: M4L LFO, Shaper and recording issues

Post by iTerentius » Mon Jan 14, 2019 8:51 pm

After a bit of experimentation, setting all LFOs to beats and not Hz, not using 'random' as a waveform, out put is still different per render. MAX LFO has a 're-trigger' option which I would think would work, but doesn't seem to, even if I set an automation point at the beginning.

Obviously 'Random' is, well, random. Free running Hz waves though seem like they would be more useful in the case by having the random phase but with a common starting point. For a synth, I get it. For automation controls, doesn't make sense.

Post Reply