mxj object not working in live, unless max8 patch window open...

Questions and discussion about building and using Max for Live devices
Post Reply
rydan
Posts: 258
Joined: Tue May 08, 2007 2:51 pm
Location: Stockholm, Sweden
Contact:

mxj object not working in live, unless max8 patch window open...

Post by rydan » Sat Jun 22, 2019 9:31 am

Hi.

Have a really strange problem. I have a m4l midi effect, a very simple note in/out patch, using a mxj object for doing round-robin logic for automating the sample selector (or any other parameter, assignable). The patch is locked, frozen and saved, and the java object is in the same directory as the patch.

Now, if i load the m4l patch in live and assign it to control any parameter, it does absolutely nothing. If I then just click the "edit" button, to open the patch in max/msp8, it starts working as soon as the patcher window opens. Still in presentation mode, still locked and frozen, nothing altered at all. As soon as I close the max/msp edit window, regardless if I save or not, it stops working again.

Anybody having any idea why? Driving me nuts at the moment...
Live + M4L, MacBookPro & Ultralite mk3. Plugins from Softube, Soundtoys, Eventide, 2CAudio, Cytomic, AudioDamage, OhmForce, FabFilter, SonicCharge, Waves, MadronaLabs, NI and ExpertSleepers. Oh, and a bunch of hardware... =D

http://www.pinknoise.se

chapelier fou
Posts: 4914
Joined: Mon May 15, 2006 12:15 pm

Re: mxj object not working in live, unless max8 patch window open...

Post by chapelier fou » Sat Jun 22, 2019 1:17 pm

What if you save, delete, and reload the device ?
MacBook Pro 13" Retina i7 2.8 GHz OS 10.13, L10.0.1, M4L.
iMac 27" Retina i5 3,2 GHz OS 10.11.3 L10.0.1 M4L.

rydan
Posts: 258
Joined: Tue May 08, 2007 2:51 pm
Location: Stockholm, Sweden
Contact:

Re: mxj object not working in live, unless max8 patch window open...

Post by rydan » Sat Jun 22, 2019 2:15 pm

chapelier fou wrote:
Sat Jun 22, 2019 1:17 pm
What if you save, delete, and reload the device ?
Same. In fact, this seems to be the case with all devices I have using mxj objects. Can anybody confirm mxj working correctly on their system without the device editor open on mac/osx?
Live + M4L, MacBookPro & Ultralite mk3. Plugins from Softube, Soundtoys, Eventide, 2CAudio, Cytomic, AudioDamage, OhmForce, FabFilter, SonicCharge, Waves, MadronaLabs, NI and ExpertSleepers. Oh, and a bunch of hardware... =D

http://www.pinknoise.se

chapelier fou
Posts: 4914
Joined: Mon May 15, 2006 12:15 pm

Re: mxj object not working in live, unless max8 patch window open...

Post by chapelier fou » Sat Jun 22, 2019 2:51 pm

I’m not home but I can try next Monday.
MacBook Pro 13" Retina i7 2.8 GHz OS 10.13, L10.0.1, M4L.
iMac 27" Retina i5 3,2 GHz OS 10.11.3 L10.0.1 M4L.

[jur]
Site Admin
Posts: 1629
Joined: Mon Jun 01, 2015 3:04 pm
Location: Ableton

Re: mxj object not working in live, unless max8 patch window open...

Post by [jur] » Sat Jun 22, 2019 5:27 pm

What Live/Max versions are you using? What has changed recently on your system that could explain that it's not working anymore?
Where are you mxj objects located at? Make sure those paths are in your Max files preferences.
Ableton Forum Moderator

rydan
Posts: 258
Joined: Tue May 08, 2007 2:51 pm
Location: Stockholm, Sweden
Contact:

Re: mxj object not working in live, unless max8 patch window open...

Post by rydan » Sat Jun 22, 2019 5:33 pm

[jur] wrote:
Sat Jun 22, 2019 5:27 pm
What Live/Max versions are you using? What has changed recently on your system that could explain that it's not working anymore?
Where are you mxj objects located at? Make sure those paths are in your Max files preferences.
Live 10.1, with the bundles Max8 version. mxj objects are located in the same directory as the device using it, which should work regardless (and, also, if the class weren't in classpath, I don't think it would work with editor view open either.)

The change is the upgrade to Live 10.1...
Live + M4L, MacBookPro & Ultralite mk3. Plugins from Softube, Soundtoys, Eventide, 2CAudio, Cytomic, AudioDamage, OhmForce, FabFilter, SonicCharge, Waves, MadronaLabs, NI and ExpertSleepers. Oh, and a bunch of hardware... =D

http://www.pinknoise.se

[jur]
Site Admin
Posts: 1629
Joined: Mon Jun 01, 2015 3:04 pm
Location: Ableton

Re: mxj object not working in live, unless max8 patch window open...

Post by [jur] » Sat Jun 22, 2019 6:30 pm

10.1 got its bundled Max version updated to 8.0.4. Some bugs have been fixed on the Max side since then.
Can you try using Max 8.0.6?
Ableton Forum Moderator

rydan
Posts: 258
Joined: Tue May 08, 2007 2:51 pm
Location: Stockholm, Sweden
Contact:

Re: mxj object not working in live, unless max8 patch window open...

Post by rydan » Sat Jun 22, 2019 7:12 pm

[jur] wrote:
Sat Jun 22, 2019 5:27 pm
What Live/Max versions are you using? What has changed recently on your system that could explain that it's not working anymore?
Where are you mxj objects located at? Make sure those paths are in your Max files preferences.
Actually, adding the exact path to the folder where the class/device files are located in Max file preferences makes it work. So, apparently, classpaths are treated differently when a device is running in the max8 editor window, compared to it running directly inside Live. That can't be intentional, methinx...
Live + M4L, MacBookPro & Ultralite mk3. Plugins from Softube, Soundtoys, Eventide, 2CAudio, Cytomic, AudioDamage, OhmForce, FabFilter, SonicCharge, Waves, MadronaLabs, NI and ExpertSleepers. Oh, and a bunch of hardware... =D

http://www.pinknoise.se

[jur]
Site Admin
Posts: 1629
Joined: Mon Jun 01, 2015 3:04 pm
Location: Ableton

Re: mxj object not working in live, unless max8 patch window open...

Post by [jur] » Sat Jun 22, 2019 9:50 pm

Cool.
Yeah, I think there is some issues with device freezing since Max 8.
Ableton Forum Moderator

Post Reply