Max For Live Core Library LFO "Serious Program Error" crash

Questions and discussion about building and using Max for Live devices
Post Reply
jbone1313
Posts: 449
Joined: Wed Dec 12, 2007 2:44 am

Max For Live Core Library LFO "Serious Program Error" crash

Post by jbone1313 » Thu Nov 14, 2019 6:44 pm

Getting a lot of "Serious Program Error" crashes using the core library LFO.

Super frustrating.

After some googling, I see others have also experienced this.

I would assume this device should be very stable, given that it is a part of the core library.

Anyone else having this issue? Any solutions?

I'm using the bundled MFL with the latest non-beta Live 10.1.

Win 10 x64. Clean machine. Updated video card drivers, etc.

[jur]
Site Admin
Posts: 1740
Joined: Mon Jun 01, 2015 3:04 pm
Location: Ableton

Re: Max For Live Core Library LFO "Serious Program Error" crash

Post by [jur] » Thu Nov 14, 2019 8:06 pm

Is it a new issue for you or was it always the case?
At what point do you get the crash? When mapping? Randomly? When loading?
Ableton Forum Moderator

ShelLuser
Posts: 3863
Joined: Sun Dec 06, 2009 10:26 pm
Location: Wageningen, Netherlands

Re: Max For Live Core Library LFO "Serious Program Error" crash

Post by ShelLuser » Thu Nov 14, 2019 10:01 pm

My first suggestion would be to upgrade to the latest Live, 10.1.4. Also because there have been quite a few bug fixes implemented in the meantime.
With kind regards,

Peter

Using the 'Power' Trio: Live 10 Suite (+ Push & Max 8 ), Reason 10 and Maschine Mk3 (+ the ultimate Komplete 12).
Blog: SynthFan (under heavy construction!)

jbone1313
Posts: 449
Joined: Wed Dec 12, 2007 2:44 am

Re: Max For Live Core Library LFO "Serious Program Error" crash

Post by jbone1313 » Thu Nov 14, 2019 10:21 pm

[jur] wrote:
Thu Nov 14, 2019 8:06 pm
Is it a new issue for you or was it always the case?
Not sure. I think I noticed it about six months ago, but I just started using the LFO device again this week.
[jur] wrote:
Thu Nov 14, 2019 8:06 pm
At what point do you get the crash? When mapping? Randomly? When loading?
I get the crash when loading the device. When I get back to my studio, I can upload the rack if needed. I already sent some crash reports.
ShelLuser wrote:
Thu Nov 14, 2019 10:01 pm
My first suggestion would be to upgrade to the latest Live, 10.1.4. Also because there have been quite a few bug fixes implemented in the meantime.
Yes, I checked today, and I am already on the latest build. Still have the issue.

ShelLuser
Posts: 3863
Joined: Sun Dec 06, 2009 10:26 pm
Location: Wageningen, Netherlands

Re: Max For Live Core Library LFO "Serious Program Error" crash

Post by ShelLuser » Fri Nov 15, 2019 12:11 am

jbone1313 wrote:
Thu Nov 14, 2019 10:21 pm
ShelLuser wrote:
Thu Nov 14, 2019 10:01 pm
My first suggestion would be to upgrade to the latest Live, 10.1.4. Also because there have been quite a few bug fixes implemented in the meantime.
Yes, I checked today, and I am already on the latest build. Still have the issue.
So, are you using the embedded M4l engine or did you point Live to a Max installation of your own?
With kind regards,

Peter

Using the 'Power' Trio: Live 10 Suite (+ Push & Max 8 ), Reason 10 and Maschine Mk3 (+ the ultimate Komplete 12).
Blog: SynthFan (under heavy construction!)

jbone1313
Posts: 449
Joined: Wed Dec 12, 2007 2:44 am

Re: Max For Live Core Library LFO "Serious Program Error" crash

Post by jbone1313 » Fri Nov 15, 2019 1:38 am

ShelLuser wrote:
Fri Nov 15, 2019 12:11 am
So, are you using the embedded M4l engine or did you point Live to a Max installation of your own?
Embedded.

Thanks for taking the time to take a look at this.

dr_yolo
Posts: 15
Joined: Sun Sep 10, 2017 4:38 pm

Re: Max For Live Core Library LFO "Serious Program Error" crash

Post by dr_yolo » Thu Nov 28, 2019 1:24 pm

Yo just wanting to chime in on this as its completely destroying my workflow... 90% of my projects have something as basic as a M4L LFO and for months now I have been getting Serious Program Error crashes.

The only solution I can find is to revert to the Max for live pack I have installed from ableton 9 still (no crashes when using this). However its driving me insane still as whenever I try to open an old project it often takes me 5 attempts of re opening Ableton, as the crash occurs before the project has even finished loading.

I have am Ableton 10.1.5
Laptop: Razer Blade 15" (2019)
Processor: Intel i7-8750H
RAM: 16GB

Soundcard: Focusrite Scarlett 18i20

Post Reply