Fed Up With Mono Sequencer

Questions and discussion about building and using Max for Live devices
Post Reply
iancrewe
Posts: 5
Joined: Thu Dec 17, 2020 12:56 am

Fed Up With Mono Sequencer

Post by iancrewe » Tue Jan 19, 2021 8:48 pm

Hi folks,

I've been struggling with the mono sequencer for months now, and have found it to be an incredibly flaky piece of software. I regularly have issues with:
1. Most common: Notes playing endlessly, BEFORE reaching the MIDI clip they are supposed to play, or continuing to play the last sequence endlessly after the clip has ended. Pausing and unpausing has no effect.
2. Not playing audio from the tracks with mono sequencer at all.

I have tried disabling the mono sequencer to confirm the problem doesn't lie elsewhere in the signal chain. The solution to these issues seems to be different each time - letting it play the last sequence of the clip again, changing a random parameter on the sequencer (like number of steps) and back again, etc. On another forum, someone suggested setting the MIDI dropdown on the MS to 'transpose and gate', but that only worked for a few days. Each time, the issues return, sometimes multiple times in a few hours, and not in response to any changes I've made, as far as I can tell.

Yesterday I tried bouncing those tracks to stems, and one of them in particular bounced the endless repetition as well - even if I didn't hear it before I started the bounce. In the end, I had to automate turning the MS on and off to stop the problem.

So, I have two questions I hope someone can help with:
1. Is there by any chance, something I've missed which is causing the mono sequencer to behave so buggy, and
2. Assuming there isn't, can someone recommend a better sequencer with similar features? I particularly like the option of changing the note duration on specific steps.

Thanks for hearing me out, y'all!

[jur]
Site Admin
Posts: 2588
Joined: Mon Jun 01, 2015 3:04 pm
Location: Ableton

Re: Fed Up With Mono Sequencer

Post by [jur] » Wed Jan 20, 2021 3:52 am

It might sound like a stupid question, but are you sure it doesn't have automated parameters that you've automated without noticing?
Ableton Forum Moderator

iancrewe
Posts: 5
Joined: Thu Dec 17, 2020 12:56 am

Re: Fed Up With Mono Sequencer

Post by iancrewe » Sun Jan 24, 2021 9:10 pm

Hi jur,

No stupid questions here :) The only thing I have automated for the mono sequencer is the on/off device and the pattern. Tbh though, I don't know what controls would even allow the sequencer to play notes when there is no note input. Wondering if this could be a broader compatibility issue? I'm running off a mid-2012 Macbook, Mojave OS, with over 100GB storage available.

jonbenderr
Posts: 127
Joined: Sat Feb 27, 2010 11:20 pm

Re: Fed Up With Mono Sequencer

Post by jonbenderr » Tue Jan 26, 2021 10:58 am

If you are automating device on/off, you may be getting hung notes that never received a proper "note off" from mono sequencer since the device may be disabled before sending the note off.

Ableton's device on/off really messes with Max based sequencers in a few different ways.

[jur]
Site Admin
Posts: 2588
Joined: Mon Jun 01, 2015 3:04 pm
Location: Ableton

Re: Fed Up With Mono Sequencer

Post by [jur] » Wed Jan 27, 2021 2:31 pm

iancrewe wrote:
Sun Jan 24, 2021 9:10 pm
Hi jur,

No stupid questions here :) The only thing I have automated for the mono sequencer is the on/off device and the pattern. Tbh though, I don't know what controls would even allow the sequencer to play notes when there is no note input. Wondering if this could be a broader compatibility issue? I'm running off a mid-2012 Macbook, Mojave OS, with over 100GB storage available.
Which "MIDI" entry from the drop-down menu are you using (it's the top right-hand side button)?
Ableton Forum Moderator

iancrewe
Posts: 5
Joined: Thu Dec 17, 2020 12:56 am

Re: Fed Up With Mono Sequencer

Post by iancrewe » Wed Jan 27, 2021 10:13 pm

jonbenderr wrote:
Tue Jan 26, 2021 10:58 am
If you are automating device on/off, you may be getting hung notes that never received a proper "note off" from mono sequencer since the device may be disabled before sending the note off.
Thanks Jon, but the issue started before I automated the on/off - it's actually the only thing that seems to have helped at this point.

iancrewe
Posts: 5
Joined: Thu Dec 17, 2020 12:56 am

Re: Fed Up With Mono Sequencer

Post by iancrewe » Wed Jan 27, 2021 10:16 pm

[jur] wrote:
Wed Jan 27, 2021 2:31 pm
Which "MIDI" entry from the drop-down menu are you using (it's the top right-hand side button)?
It's set to 'Transpose and Gate'. I'm not familiar enough with the software to understand what that means, but someone on another forum suggested that setting might stop the issue. It didn't, unfortunately.

[jur]
Site Admin
Posts: 2588
Joined: Mon Jun 01, 2015 3:04 pm
Location: Ableton

Re: Fed Up With Mono Sequencer

Post by [jur] » Thu Jan 28, 2021 12:24 pm

Which Live/Max versions are you using?
Ableton Forum Moderator

Post Reply