Live Performance, Sends, Clip Envelopes, Automation ....

Share your Ableton Live secrets here
bubbleandsquawk
Posts: 16
Joined: Mon Feb 01, 2016 1:59 am

Live Performance, Sends, Clip Envelopes, Automation ....

Post by bubbleandsquawk » Wed Mar 15, 2017 8:51 am

I'm working on a live set for performance. It has a lot of different things going on and sometimes I like to automate parameters with clip envelopes as a safeguard so I don't have to remember to turn a million knobs. Every song has it's own vibe and I use a lot of reverb and delays to create unique spacial environments for each song.

What I'd like to do is at the beginning of each song trigger clip envelopes across my tracks that set all my sends to a kind of base level for that particular song, and then I can pick it up from there. The problem I am having is that when I launch another clip all my sends revert to where they were before the previous one was launched.
One work around seems to be to input all the same clip envelopes for each track per song (very laborious!), but then I lose any changes that I've made on the fly. Another one I tried is to create another track with a max for live device (multimap) controlling the sends on my other tracks, and then using one dummy track per song, but then I can only control those sends from the M4L device. I use a push, so it makes for a nicer workflow if the sends just work where they are meant to.

Has anyone worked out a way to deal with this? Am I missing something simple? Halp pls!!

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Live Performance, Sends, Clip Envelopes, Automation ....

Post by Stromkraft » Wed Mar 15, 2017 12:10 pm

bubbleandsquawk wrote:
What I'd like to do is at the beginning of each song trigger clip envelopes across my tracks that set all my sends to a kind of base level for that particular song, and then I can pick it up from there. The problem I am having is that when I launch another clip all my sends revert to where they were before the previous one was launched.
That in bold surprises me. Are you sure that "another clip" doesn't contain any automation. I can't see another reason for the automation to reset. Or are you loading in a new set?
Make some music!

bubbleandsquawk
Posts: 16
Joined: Mon Feb 01, 2016 1:59 am

Re: Live Performance, Sends, Clip Envelopes, Automation ....

Post by bubbleandsquawk » Wed Mar 15, 2017 12:55 pm

In my case there usually is some other unrelated automation (such as a chain selector in an instrument rack). However I've replicated it without. Say I have three clips (in session view), I have the second one set to reset all of my sends to zero using envelopes and the other two have no envelopes. I play the first clip and mess around with a send level and leave it at 12 o clock. I play the second and the sends snap down to zero. Great! But then I play the third clip and my send jumps back up to 12 o clock.
This is not the same for you?
Last edited by bubbleandsquawk on Wed Mar 15, 2017 2:09 pm, edited 1 time in total.

antic604
Posts: 579
Joined: Tue Jan 10, 2017 8:14 am
Location: Warsaw, Poland

Re: Live Performance, Sends, Clip Envelopes, Automation ....

Post by antic604 » Wed Mar 15, 2017 1:12 pm

bubbleandsquawk wrote:In my case their usually is some other unrelated automation (such as a chain selector in an instrument rack). However I've replicated it without. Say I have three clips (in session view), I have the second one set to reset all of my sends to zero using envelopes and the other two have no envelopes. I play the first clip and mess around with a send level and leave it at 12 o clock. I play the second and the sends snap down to zero. Great! But then I play the third clip and my send jumps back up to 12 o clock.
This is not the same for you?
If there's no automation, the devices apparently return to their manually-set state in Session view. Late introduction of automation to the Session clips would suggest that Live was developed with automation being useful for Arrangement, while Session was more geared towards live performance & live manipulation.

I remember there was a discussion whether this is how it's supposed to be and if there should be an option in Settings to choose the desired behaviour.

bubbleandsquawk
Posts: 16
Joined: Mon Feb 01, 2016 1:59 am

Re: Live Performance, Sends, Clip Envelopes, Automation ....

Post by bubbleandsquawk » Wed Mar 15, 2017 2:33 pm

antic604 wrote:If there's no automation, the devices apparently return to their manually-set state in Session view. Late introduction of automation to the Session clips would suggest that Live was developed with automation being useful for Arrangement, while Session was more geared towards live performance & live manipulation.

I remember there was a discussion whether this is how it's supposed to be and if there should be an option in Settings to choose the desired behaviour.
but live manipulation is exactly what I'm trying to do! :?

antic604
Posts: 579
Joined: Tue Jan 10, 2017 8:14 am
Location: Warsaw, Poland

Re: Live Performance, Sends, Clip Envelopes, Automation ....

Post by antic604 » Wed Mar 15, 2017 2:59 pm

bubbleandsquawk wrote:
antic604 wrote:If there's no automation, the devices apparently return to their manually-set state in Session view. Late introduction of automation to the Session clips would suggest that Live was developed with automation being useful for Arrangement, while Session was more geared towards live performance & live manipulation.

I remember there was a discussion whether this is how it's supposed to be and if there should be an option in Settings to choose the desired behaviour.
but live manipulation is exactly what I'm trying to do! :?
Yes, but Live somehow distinguishes two states - one is the state of parameters you open the device with and change manually and the other, when the parameters are changed via automation. So if after opening the project you have Send at 0%, then a clip changes that to 50% and then a new clip comes along without automation for Send, it will revert back to it's default/manual state of 0%.

I - and many others - were also expecting it to stay at 50% for the new clip, but that's not how it works and there's no option to change that.

bubbleandsquawk
Posts: 16
Joined: Mon Feb 01, 2016 1:59 am

Re: Live Performance, Sends, Clip Envelopes, Automation ....

Post by bubbleandsquawk » Wed Mar 15, 2017 3:43 pm

antic604 wrote:Yes, but Live somehow distinguishes two states - one is the state of parameters you open the device with and change manually and the other, when the parameters are changed via automation. So if after opening the project you have Send at 0%, then a clip changes that to 50% and then a new clip comes along without automation for Send, it will revert back to it's default/manual state of 0%.

I - and many others - were also expecting it to stay at 50% for the new clip, but that's not how it works and there's no option to change that.
That's a real shame. Well I hope they can add an option for it in a future update.

I'd love to hear anyone's workarounds for this kind of problem.

I've often thought it would be nice to use another controller to manage my mix levels and sends, but it seems that I've exceeded the limits of what is commercially viable for the controller market. :twisted:

I'd like something with small faders, classic absolute pots with nicely marked knobs, where I can see at a glance what's going on. Then I wouldn't need to automate so much! I'd need a lot of knobs though, I like sends.
Something with good visual feedback like the push would be amazing! :lol:

antic604
Posts: 579
Joined: Tue Jan 10, 2017 8:14 am
Location: Warsaw, Poland

Re: Live Performance, Sends, Clip Envelopes, Automation ....

Post by antic604 » Thu Mar 16, 2017 9:39 am

Maybe it's old news for you, but you may want to consider using dummy clips to achieve what you need?
Here's a quick tutorial on this: http://abletonlife.com/a-detailed-guide ... leton-live

Basically, what you're achieving is creating a 'silent' track - with clips containing only automation, no sound - that will control the parameters of your actual 'audible' track.

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Live Performance, Sends, Clip Envelopes, Automation ....

Post by Stromkraft » Fri Mar 17, 2017 6:25 am

bubbleandsquawk wrote: This is not the same for you?
It's the same: I was thinking about Arrangement, where it more or less kind works the opposite.

I note that the state of a send when I modulate it with an envelope in one clip and not at all in another resets to zero and not the state from the template.
Make some music!

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Live Performance, Sends, Clip Envelopes, Automation ....

Post by Stromkraft » Fri Mar 17, 2017 6:29 am

antic604 wrote:Maybe it's old news for you, but you may want to consider using dummy clips to achieve what you need?
Here's a quick tutorial on this: http://abletonlife.com/a-detailed-guide ... leton-live

Basically, what you're achieving is creating a 'silent' track - with clips containing only automation, no sound - that will control the parameters of your actual 'audible' track.
But I think bubbleandsquawk already stated he tried this with MultiMap? Or you're more hinting at delegating a send to a dummy track? Then you'd need one dummy track per track, no? I'm not sure I see the advantage.
Make some music!

antic604
Posts: 579
Joined: Tue Jan 10, 2017 8:14 am
Location: Warsaw, Poland

Re: Live Performance, Sends, Clip Envelopes, Automation ....

Post by antic604 » Fri Mar 17, 2017 7:35 am

Stromkraft wrote:[Then you'd need one dummy track per track, no? I'm not sure I see the advantage.
Yes, but it's the only workaround I could think of :)

Maybe he doesn't need it for every single track? Or maybe he can route several tracks into one dummy clip track?

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Live Performance, Sends, Clip Envelopes, Automation ....

Post by Stromkraft » Fri Mar 17, 2017 10:40 am

antic604 wrote:
Stromkraft wrote:[Then you'd need one dummy track per track, no? I'm not sure I see the advantage.
Yes, but it's the only workaround I could think of :)

Maybe he doesn't need it for every single track? Or maybe he can route several tracks into one dummy clip track?
I think one of the preset Max For Live solutions would be very useful in this case, if MFL is a possibility.
Make some music!

AliMc
Posts: 20
Joined: Sat Jan 29, 2011 2:29 am

Re: Live Performance, Sends, Clip Envelopes, Automation ....

Post by AliMc » Fri Mar 17, 2017 5:28 pm

I think Clyphx would be pretty useful for this. You can use the Track Action "SEND" to set your send levels.
Just set up a clip at the start point of each new song.

http://beatwise.proboards.com/thread/99 ... phx-live-8

Stromkraft
Posts: 7033
Joined: Wed Jun 25, 2014 11:34 am

Re: Live Performance, Sends, Clip Envelopes, Automation ....

Post by Stromkraft » Fri Mar 17, 2017 5:35 pm

AliMc wrote:I think Clyphx would be pretty useful for this. You can use the Track Action "SEND" to set your send levels.
Just set up a clip at the start point of each new song.

http://beatwise.proboards.com/thread/99 ... phx-live-8
Yes! I forgot to mention this stapleware.
Make some music!

AliMc
Posts: 20
Joined: Sat Jan 29, 2011 2:29 am

Re: Live Performance, Sends, Clip Envelopes, Automation ....

Post by AliMc » Fri Mar 17, 2017 10:40 pm

Stromkraft wrote: Yes! I forgot to mention this stapleware.
Yeah, I always seem to have amnesia about Clyphx and look for over complicated ways of doing things when Clyphx offers a nice simple solution!
Remembered this time though 8)

Post Reply