Page 1 of 1

Arm exclusive doesn't work with midi mapping?

Posted: Thu Feb 22, 2018 11:50 am
by LucasLer
Hi,
I'm trying to map a Maschine mkii (in controller mode) to Ableton to use it while playing live. I mapped some pads to the arm button of my tracks and set arm exclusive in my settings. However when I arm a track it doesn't turn off the other "arm" switch, it worked sometimes but not for a long time and I have no idea what to do to make it work now. I tried sending CC and notes from the controller but it doesn't seem to make any difference. I've read that it was already an issue like ten years ago so I hope there's a fix :o
Thanks :)

Re: Arm exclusive doesn't work with midi mapping?

Posted: Fri Mar 09, 2018 9:46 am
by wearemindflux
I know when you hold CMD (Mac) that even if you are in arm exclusive mode it over rides this.

I wonder when you are mapping to the maschine pads it acts like CMD

try mapping to your computers keyboard using the key mapping, use something like 1,2,3 etc for your tracks.

Also in maschine mk3 if it is like the kk mk2 (the keyboard) you can use the 4d encoder to move between tracks and the midi arm follows, maybe you could use that.

Re: Arm exclusive doesn't work with midi mapping?

Posted: Thu Mar 15, 2018 10:28 am
by stoter
edit:
LucasLer wrote:... and set arm exclusive in my settings.
my bad, sorry.


(original reply:

check Preferences --> Record/Warp/Launch --> Exclusive --> Arm.

My guess is, you have this option turned off right now.. is it grey?)

Re: Arm exclusive doesn't work with midi mapping?

Posted: Mon Jul 02, 2018 1:45 pm
by nomenome
LucasLer wrote:Hi,
I'm trying to map a Maschine mkii (in controller mode) to Ableton to use it while playing live. I mapped some pads to the arm button of my tracks and set arm exclusive in my settings. However when I arm a track it doesn't turn off the other "arm" switch, it worked sometimes but not for a long time and I have no idea what to do to make it work now. I tried sending CC and notes from the controller but it doesn't seem to make any difference. I've read that it was already an issue like ten years ago so I hope there's a fix :o
Thanks :)
Same experience here. Exclusive arm doesn't work with any MIDI controller that I've tried. I have exclusive arm selected in preferences and I've tried using both CCs and MIDI Notes.
Has anyone found a workaround for this?

As far as I can tell, this issue goes back to Live 5 in 2005.

Re: Arm exclusive doesn't work with midi mapping?

Posted: Wed Dec 26, 2018 1:33 am
by pirco
so what's the re/solution for this issue?

I'm working with KMI soft step 2 and it does not arm exclusively, although that setting is specified in Live 9 (standard)