All times are UTC

 
 



Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: Ableton Live 10 - Global Quantization Delay? Is this a Bug?
PostPosted: Mon Nov 19, 2018 4:27 am 

Joined: Wed Nov 14, 2018 2:01 am
Posts: 3
Hello everyone. I encountered this unexpected behavior of Global Quantization when triggering clips (Ableton Live 10 - 10.0.1).

On normal condition, with 1 Bar Quantization, the clip playing will change after a bar regardless when exactly you trigger another clips.

In my case, the Quantization does work, but there's an unexpected behavior:
    - If a clip is playing, and I trigger another clip during its first to third beats, the clip playing will change exactly after one bar.
    - However, if a clip is playing, and I trigger another clip during its fourth beat, the clip playing will change two beats after that one bar.
    - Interestingly, I noticed that this delay behavior only happens when Global Quantization set to 1 Bar and 2 Bar.

This happens on every MIDI & Audio clips on EVERY tracks & groups.

I noticed this behavior only happened on the newest save of my latest project. On the older saves of the same project, the quantization behaves normally.

I have checked my Global Quantization option. All my clips are also set to follow Global Quantization within the Launch Box option. The settings are basically the same with the older save of the same project but somehow it behaves differently. There's also no problem on the latency.

My best guess is that his is a bug? I don't think I ever see this on my previous projects using Live 10, neither does in Live 9.

Any help is greatly appreciated. Thanks.


Top
 Profile  
 
 Post subject: Re: Ableton Live 10 - Global Quantization Delay? Is this a Bug?
PostPosted: Mon Nov 19, 2018 10:28 pm 

Joined: Mon Apr 26, 2010 6:38 am
Posts: 2920
What is your audio interface and buffer settings? Could be that your audio buffer is so large it throws off any accuracy you would need.

_________________
Freelance SoundLabs
Soundcloud


Top
 Profile  
 
 Post subject: Re: Ableton Live 10 - Global Quantization Delay? Is this a Bug?
PostPosted: Wed Nov 21, 2018 2:54 am 

Joined: Wed Nov 14, 2018 2:01 am
Posts: 3
jestermgee wrote:
What is your audio interface and buffer settings? Could be that your audio buffer is so large it throws off any accuracy you would need.


I'm using Asio driver from Bheringer UMC204 soundcard with 512 samples. Audio interface & buffer settings seems irrelevant to this problem. If buffer is the culprit, then the problem would also show if the global quantization was set to under 1 bar (1/2, 1/4,..etc). But this delay problem seems only to happen when using 1 & 2 bar of global quantization.

Besides, whatever audio setting I choose the problem still persist.


Top
 Profile  
 
 Post subject: Re: Ableton Live 10 - Global Quantization Delay? Is this a Bug?
PostPosted: Wed Nov 21, 2018 4:25 am 

Joined: Mon Apr 26, 2010 6:38 am
Posts: 2920
Without knowing, your buffer could create a delay for triggering. Not really sure what the issue is then.

_________________
Freelance SoundLabs
Soundcloud


Top
 Profile  
 
 Post subject: Re: Ableton Live 10 - Global Quantization Delay? Is this a Bug?
PostPosted: Wed Nov 21, 2018 5:43 pm 

Joined: Wed Nov 14, 2018 2:01 am
Posts: 3
jestermgee wrote:
Without knowing, your buffer could create a delay for triggering. Not really sure what the issue is then.


I know. But I'm pretty sure this is a bug after all. I 'fixed' this with temporary solution.

If anyone out there encounter this bug and wondering how the fix, it's pretty much copy paste everything from your current set to a new live set. Simply go to Session View > select every tracks (not the clips) by shift+left click, and then open new live set and paste it. Every clips within each tracks in Session View will be pasted automatically as well as the arrangement in Arrangement View.

Probably a code within the save files got corrupted or something, because this fix the bug without changing the project or the setting.


Top
 Profile  
 
 Post subject: Re: Ableton Live 10 - Global Quantization Delay? Is this a Bug?
PostPosted: Mon Nov 26, 2018 9:07 am 
Site Admin

Joined: Mon Jun 01, 2015 3:04 pm
Posts: 1199
Location: Ableton
It would be nice if you could report it to support@ableton.com
thx

_________________
Ableton Forum Moderator


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC

 
 

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group