Data loss when connecting e-drum

Share your Ableton Live secrets here
Post Reply
Dirk C
Posts: 78
Joined: Sun Aug 24, 2014 5:07 pm
Location: Ghent - Belgium

Data loss when connecting e-drum

Post by Dirk C » Tue Sep 17, 2019 10:56 am

I have a Fame DD-6500 e-drum that I connect to Ableton Live! 10.1 on a windows 10 PC.

I tried 2 scenario's:

First: using a MIDI-cable between the e-drum an a Scarlett Focusrite 8I18 (my external sound card with midi busses) . On the midi-track I load a drumset. When playing the drums, I can clearly hear the different pads of the drums. Also, when I add an audio-track, connected to the audio out of the e-drum I can record the sound of it without any problems.
But, when opening the midi-track, I see that half of the midi-notes are not recorded. So I started to record the different pads separately while beating on them soft and hard, but there is no clear pattern: I just loose halve of the midi-notes (and this is not in relationship with the way I've beaten on the pads!).
Second: I used a USB-cable instead. same tests, but in that case I hardly keep some midi-data in the midi track: most is just not recorded!

My questions are:
> What happens here? While just playing, all hits are translated by the drumset I've loaded on the track).
> Is there a problem with a "notes off" parameter in Live!?
> Is there some parameter that influences the sensitivity of incoming midi-data?

Thanks for considering a suggestion!

Dirk C
Posts: 78
Joined: Sun Aug 24, 2014 5:07 pm
Location: Ghent - Belgium

Re: Data loss when connecting e-drum

Post by Dirk C » Wed Oct 09, 2019 8:19 pm

The cause is the drum module that generates a low quality midi signal. That's a pity, but after having tries everything else, this is the bare conclusion.

garyboozy
Posts: 2586
Joined: Mon Jul 16, 2007 12:27 pm
Location: UK
Contact:

Re: Data loss when connecting e-drum

Post by garyboozy » Thu Oct 10, 2019 1:16 pm

have you updated to 10.1.2? there was a bug in earlier versions that meant Live didnt record shorter notes from drum controllers

[jur]
Site Admin
Posts: 1703
Joined: Mon Jun 01, 2015 3:04 pm
Location: Ableton

Re: Data loss when connecting e-drum

Post by [jur] » Thu Oct 10, 2019 5:12 pm

Yep L10.1.2 fixes this issue.
Ableton Forum Moderator

Dirk C
Posts: 78
Joined: Sun Aug 24, 2014 5:07 pm
Location: Ghent - Belgium

Re: Data loss when connecting e-drum

Post by Dirk C » Mon Nov 11, 2019 11:07 pm

I will try that. Thanks!

Dirk C
Posts: 78
Joined: Sun Aug 24, 2014 5:07 pm
Location: Ghent - Belgium

Re: Data loss when connecting e-drum

Post by Dirk C » Wed Nov 13, 2019 12:31 pm

Thanks guys for the golden tip! I've downloaded the latest version of Live! and yes, I can record the e-drum without data loss. Great!
I was really thinking that my e-drum was the problem, so it wasn't...

Dirk

[jur]
Site Admin
Posts: 1703
Joined: Mon Jun 01, 2015 3:04 pm
Location: Ableton

Re: Data loss when connecting e-drum

Post by [jur] » Wed Nov 13, 2019 10:05 pm

Good to hear!
Ableton Forum Moderator

Post Reply