FCB1010 controller pedal question

Share your Ableton Live secrets here
Post Reply
chris vine
Posts: 674
Joined: Fri Jul 22, 2005 2:01 am
Location: Brazil

FCB1010 controller pedal question

Post by chris vine » Sat Sep 17, 2005 2:51 pm

Hi All,
I am using a controller pedal on an FCB1010 midi floorboard to control crossfading in LIve 4 and the response seems sluggish - the initial pedal movement generates no change in the crossfade, so I only have a small amount of pedal travel time that actually works - it is kinda off then suddenly on. I have my controller values set to 0 - 127.
Am not so savvy with midi controller messages, so any help greatly appreciated.

Thankx,
Chris


LIve 4.3 (have L5 but ain't installed it yet) AMD athlon 2600, 1gig ddr 333 RAM, M Audio Firewire 410, Samsung 160gb 7200 HD

Machinate
Posts: 11646
Joined: Thu Jun 24, 2004 2:15 pm
Location: Denmark
Contact:

Post by Machinate » Sat Sep 17, 2005 7:51 pm

sounds like you need to calibrate your fcb... copy/paste from loopers delight (which was copied from the fcb yahoo group;) )
---------------------------------------------------
1. Keep footswitches 1 and 3 pressed while switching on the unit (This bit
you can't do standing up!). Release the switches when the display blanks. The LEDs on the footswitches, the ones on the display and each segment of the two numeric displays will turn on and off in sequence.

2. Wait until all footswitch LEDs are on. Depress all footswitches one at a
time,

including UP and DOWN, until all LEDs are off.

3. Wait until relay switch test is finished. (There will be a couple of
mechanical

clicks, and the display will end up reading "F1" (at least, it did on
mine)). [Also, if you have connected a MIDI cable between the MIDI in and out, the display will show "A1" before this, meaning the midi ports work correctly.]
4. Press DOWN once.

5. Adjust the left expression pedal (A) to the lowest value. Once adjusted
press UP.

6. Adjust the left expression pedal (A) to the highest value. Once adjusted
press UP.

7. Adjust the right expression pedal (B) to the lowest value. Once adjusted
press UP.

8. Adjust the right expression pedal (B) to the highest value. Once
adjusted
press UP.

9. Select a patch which has both pedals set to their full range, and check
the expression pedals now send 0-127 (0x00-0x7F)
mbp 2.66, osx 10.6.8, 8GB ram.

chris vine
Posts: 674
Joined: Fri Jul 22, 2005 2:01 am
Location: Brazil

Post by chris vine » Sat Sep 17, 2005 8:03 pm

Thanks,
I did this once when I got the FCB recently and it didn't seem to make any difference to the cross fader response - although it did enable the 2nd controller pedal to work!

Will give it a go.

Cheers.............. :)

Machinate
Posts: 11646
Joined: Thu Jun 24, 2004 2:15 pm
Location: Denmark
Contact:

Post by Machinate » Sat Sep 17, 2005 8:16 pm

maybe live has seen the controller as incremental instead of absolute - that would also make the fader jump.
mbp 2.66, osx 10.6.8, 8GB ram.

chris vine
Posts: 674
Joined: Fri Jul 22, 2005 2:01 am
Location: Brazil

Post by chris vine » Sat Sep 17, 2005 10:37 pm

Hmm, somewhere in the FCB edit prog I seem to remember a menu for various types of midi data.............
will check

thanks!

chris vine
Posts: 674
Joined: Fri Jul 22, 2005 2:01 am
Location: Brazil

Post by chris vine » Sat Sep 17, 2005 11:10 pm

Just found a pdf on the FCB1010 yahoo group that details my problem, so not just a recalibration but possibly a re-alignment of the led sensor in the pedal is needed.

Anyway, will switch pedals first before I reach for the toolbox!

TX for yr help.

Machinate
Posts: 11646
Joined: Thu Jun 24, 2004 2:15 pm
Location: Denmark
Contact:

Post by Machinate » Sat Sep 17, 2005 11:19 pm

nah, I meant the error could be in the way that live has assigned the controller - make sure the crossfader assignment is set to absolute.
mbp 2.66, osx 10.6.8, 8GB ram.

chris vine
Posts: 674
Joined: Fri Jul 22, 2005 2:01 am
Location: Brazil

Post by chris vine » Sun Sep 18, 2005 2:45 pm

I reset the control values for the pedals in the FCB sysex prog and it seems to much better, thanks.

Post Reply